Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005545 [DCSS] Patches minor have not tried 2012-04-09 00:46 2012-05-05 16:34
Reporter Zannick View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.11 ancient branch
Summary 0005545: Orb mimics
Description A small set of changes for orb mimics, which were already possible but not placed anywhere. Summary of changes in this patch:

- Rework Zot:5 vaults to have the orb placed at random among Z glyphs, with the other Z locations having a 1/10 chance each of having a mimic. This is a no-op for most vaults (but it allows future vaults with potential mimics to be easier to add), except orb_two_ways now has a 1/10 chance of generating an orb mimic. Since that vault only has a 5/40 = 1/8 chance of generating, and the player has a 1/2 chance of getting the real orb, that's a 1/160 chance of the player running into the mimic before the real orb.
- Name the mimic "orb mimic" rather than "Orb of Zot mimic".
- Upon discovery, the orb mimic shrieks like the orb does on pickup.
- Fix an incorrect indent I discovered in code dealing with apporting the orb.

Misc comments:
- Sorry if the lua thing seems a little overengineered. ;)
- The orb chambers all tag ! as no_item_gen, but then subst ! away. I think this makes it fail (it did for me in one test).
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Introduce-shrieking-orb-mimics.patch [^] (7,039 bytes) 2012-04-09 00:46 [Show Content]

- Relationships

-  Notes
neil (administrator)
2012-04-09 07:21
edited on: 2012-04-09 07:29

Committed to trunk, with the "o" glyph changed to "O" since the former already means something (0.11-a0-1048-g243254a).

There is a general feeling among the devs I spoke to that orb mimics should remain quite rare: 1/80 games, as it is currently, is fine, but 1/2 would not be. I'm not sure how much the 1/80 could be increased without the trick becoming dull.

KiloByte (manager)
2012-04-26 22:28

Neil: why is this one still open?
neil (administrator)
2012-05-05 16:34

kilobyte: I was waiting for other devs to comment, then I forgot about it.

- Issue History
Date Modified Username Field Change
2012-04-09 00:46 Zannick New Issue
2012-04-09 00:46 Zannick File Added: 0001-Introduce-shrieking-orb-mimics.patch
2012-04-09 07:21 neil Note Added: 0017686
2012-04-09 07:21 neil Status new => resolved
2012-04-09 07:21 neil Fixed in Branch => 0.11 development branch
2012-04-09 07:21 neil Resolution open => done
2012-04-09 07:21 neil Assigned To => neil
2012-04-09 07:21 neil Status resolved => feedback
2012-04-09 07:21 neil Resolution done => reopened
2012-04-09 07:29 neil Note Edited: 0017686
2012-04-26 22:28 KiloByte Note Added: 0017876
2012-05-05 16:34 neil Note Added: 0017976
2012-05-05 16:34 neil Status feedback => closed
2012-05-05 16:34 neil Resolution reopened => done

Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker