Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005532 [DCSS] Bug Report crash always 2012-04-04 08:29 2013-04-17 22:59
Reporter HilariousDeathArtist View Status public  
Assigned To KiloByte
Priority normal Resolution done  
Status closed   Product Branch 0.10 ancient branch
Summary 0005532: Crash when entering Hell
Description In my current game (name: HilariousDeathArtist), every time when I try to enter any of the portals to Hell, the game crashes which kicks out me and any spectators. When I restart the game it is reloaded at the autosave when entering the level.

I had previously been using the Portals; this has only started since my recent escape from Pan.
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-HilariousDeathArtist-20120404-061542[1].txt [^] (47,290 bytes) 2012-04-04 08:31 [Show Content]

- Relationships

-  Notes
(0017615)
HilariousDeathArtist (reporter)
2012-04-04 08:31

Attached crash file located at http://crawl.develz.org/morgues/0.10/HilariousDeathArtist/crash-HilariousDeathArtist-20120404-061542.txt [^]
(0017619)
neil (administrator)
2012-04-04 10:04

Could you make a save backup and post the link here? The problem is that get_skill_progress() is computing a negative number for your Evocations progress; but the numbers in your skill dump table look correct (and should be yielding a positive number). The only thing I can think of, without loading the save in a debugger, is that maybe you.time_taken is negative.
(0017620)
KiloByte (manager)
2012-04-04 12:15

It was a matter of rod recharging while off-level.

Fixed.

Note that there are issues with updating 0.10 webtiles, I'll try asking for an update but don't hold your breath :( Since your game is quite worth recovering, something may be possible, not sure how.
(0017631)
HilariousDeathArtist (reporter)
2012-04-04 23:33

I was able to bypass the issue this morning by searching (CTRL-F) for the rod (which was in Vestibule of Hell) and using the quick travel feature while standing on the portal to Hell.

The game seems to be progressing fine now.

Thanks for the info and quick response!
(0017632)
KiloByte (manager)
2012-04-04 23:46

Actually, viewing that level in any way would crash, but apparently you gained enough Evocations skill to pass an integer level of the skill.

The crash depends on (time off level)*(xp put into a partial level of Evoc).
(0017635)
HilariousDeathArtist (reporter)
2012-04-05 00:24

Hmm, I'm not sure how I would have gained any Evocations skill. I hadn't moved from the save last night to kill anything or gain exp and my evocations skill has been disabled since midgame.

Either way, I seem to be able to enter and exit Hell fine now.

Thanks again!
(0022324)
HilariousDeathArtist (reporter)
2013-04-17 22:59

Confirm/close

- Issue History
Date Modified Username Field Change
2012-04-04 08:29 HilariousDeathArtist New Issue
2012-04-04 08:31 HilariousDeathArtist File Added: crash-HilariousDeathArtist-20120404-061542[1].txt
2012-04-04 08:31 HilariousDeathArtist Note Added: 0017615
2012-04-04 10:04 neil Note Added: 0017619
2012-04-04 10:04 neil Status new => feedback
2012-04-04 12:15 KiloByte Note Added: 0017620
2012-04-04 12:15 KiloByte Status feedback => resolved
2012-04-04 12:15 KiloByte Fixed in Branch => 0.11 development branch
2012-04-04 12:15 KiloByte Resolution open => done
2012-04-04 12:15 KiloByte Assigned To => KiloByte
2012-04-04 23:33 HilariousDeathArtist Note Added: 0017631
2012-04-04 23:46 KiloByte Note Added: 0017632
2012-04-05 00:24 HilariousDeathArtist Note Added: 0017635
2013-04-17 22:59 HilariousDeathArtist Note Added: 0022324
2013-04-17 22:59 HilariousDeathArtist Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker