Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005463 [DCSS] Bug Report major random 2012-03-20 20:03 2014-03-25 19:58
Reporter doublep View Status public  
Assigned To galehar
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005463: Monsters are way too bold rushing into poison clouds
Description My character has poison cloud spell and often uses it and runs away. The strategy is that chasing monsters are then weakened by poison. This is fine. However, often after leaving the poisonous cloud on the map and running somewhere --- not even seeing the cloud place anymore --- I start receiving messages "you feel a bit more experienced" *a lot*.

This means that monsters not even seeing me (i.e. there cannot be justification like: "if I stay behind the cloud he'll nuke me from afar") rush into cloud only to die. When I come back later, I find several corpses lying around.

So,
- either monsters way too underestimate killing power of poison; or
- monsters should not run into any dangerous clouds at all if there are no pressing matters to deal with --- i.e. when the player is gone anyway.

Or both.
Additional Information
Tags AI
Attached Files

- Relationships
related to 0004117resolvedgalehar non-confused sky beast walks into a flame cloud only to die 
related to 0005548closedMarvinPA nerf cloud spells 

-  Notes
(0017385)
galehar (administrator)
2012-03-21 00:13

fire and freezing clouds:
mons->hit_points >= 15 + random2avg(46, 5) => average: 38

poisonous clouds:
mons->hit_points >= random2avg(37, 4) => average: 18.5

maybe the latter needs to be changed.

Something that could help the Elves of E:5 (among others) is to add a check for intelligent patrolling monsters. If a cloud is preventing them to reach their target (foe), they should go back to their patrolling point instead of entering a dangerous cloud.
(0017389)
simon1tan (reporter)
2012-03-21 03:51

I tend to agree that the intelligence of the monster should play a role in whether they wander into a poisonous cloud or not. Also, almost all monsters should realize and get the F* away once caught in such a cloud.
(0017390)
minmay (reporter)
2012-03-21 16:56

Isn't the underlying problem here just that cloud spells let you hit things out of LOS?
(0017391)
galehar (administrator)
2012-03-21 17:50

Is it? What's the underlying solution then?
Have another safety check for monster with intelligence >= normal, if the foe is out of LOS, don't enter a dangerous cloud?
(0017393)
minmay (reporter)
2012-03-21 19:00

Well, if monsters avoid clouds then they're just abusable in a different way - remember that brief period in 0.8-a where you could stop titans from following you around corners by using a level 3 spell? You'd certainly be able to do the same with this proposal. Also, you'd still be able to kill monsters from out of LOS if you used a corridor since Poisonous/Freezing Cloud can *create* clouds out of LOS. So your proposal is only going to solve one of several related problems and it's going to introduce more problems in the meantime.

My solution would be for player-created clouds to disappear if they leave the player's LOS. Flavour this as the caster having to maintain concentration on the clouds, and they must be able to see the clouds to do so. This solves the issue in a way that isn't spoilery or complicated. All the cloud spells are quite strong so they can take this nerf, and there seems to be general agreement that attacking monsters out of LOS is bad so removing it is surely a good thing!
(0017394)
doublep (reporter)
2012-03-21 19:44

That's a possible solution. While I'm not particularly fond of it, it sure is worthy of at least evaluation.

If current state is maintained, monsters could probably use pathfinding to estimate how many turns they are going to spend in the cloud. It is one thing when a monster has to travel 2 squares of flame and another if it is 4. And relate this to "how strong" they want to get to the other side: if the player is in sight, risks might be worthy to take (or else, if the player is able to create cloud, he almost certainly can throw nasty spells from afar too). If the player is not even in LOS, chasing monsters should be more conservative e.g. estimate they have at least 40% of max HP after crossing the cloud. If the reasons are weak (merely investigate suspicious sounds, or just following to a waypoint), they should avoid risks at all.

Also, monsters should be able to sacrifice a turn to sidestep around the player to avoid clouds. Currently they don't --- I'm playing as a demonspawn with foul stench mutation and monsters are fine with staying in miasma clouds, even when they could step to another square besides my character and not block someone else.
(0017397)
ion_frigate (reporter)
2012-03-21 23:40
edited on: 2012-03-21 23:41

One persistent problem that seems to come up is that monster cloud behavior more complex than it is currently would be very spoilery. There's a simple solution to this: have monsters have multiple possible behaviors WRT clouds, and make it vary from individual to individual (i.e. two deep elf fighters might have different ways of reacting to clouds). For example, some monsters could judge based on their HP, some could simply never pursue through clouds, some could always, some could only do so if the player is in LOS, some could attempt to path around.

It would be set for the individual monsters and then never vary, so the cloud-using player would have to deal with a variety of "personalities." This would prevent spoilers like "Annihilate Elf:5 by dropping clouds out of LOS" and "Strand a monster across a cloud and shoot it to death" from being universal enough to be useful. In addition, it would create a more varied feel to monster AI, which tends to be very same-y.

(0017406)
simon1tan (reporter)
2012-03-22 04:36

I like ion_frigate's idea. I don't like the idea of the cloud disappearing once out of LOS because what if I walk back? Does the cloud have to reappear?
(0020191)
DuxOrbis (reporter)
2012-09-18 09:54
edited on: 2012-09-19 23:48

I would like to see a monster that is caught in a cloud do a check to all adjacent squares, if a space is clear it will choose any of the clear spaces at random (or the one that paths around the cloud toward the player), this would mitigate the damage to those caught in the edge of clouds, making the center of clouds more effective, choosing your target carefully actually matters instead of herds rushing through your easily avoidable cloud. Some figure out how to get away. Perhaps have a 50% chance of failing to do this check and moving through the cloud before doing the check again. If no free spaces are available on this check monsters behave as they do now, path to the player until a free space becomes available. Not perfect, but it makes it less cruel to those poor yaks as well as making conjure flame, mephitic cloud, miasma, poisonous cloud, ignite poison and ignite blood more tactically difficult to steamroll with out in the open.

(0025697)
galehar (administrator)
2014-03-25 19:57

Clouds dissipate fast when outside of LOS now (see 5548)

- Issue History
Date Modified Username Field Change
2012-03-20 20:03 doublep New Issue
2012-03-20 23:45 galehar Relationship added related to 0004117
2012-03-21 00:13 galehar Note Added: 0017385
2012-03-21 03:51 simon1tan Note Added: 0017389
2012-03-21 16:56 minmay Note Added: 0017390
2012-03-21 17:50 galehar Note Added: 0017391
2012-03-21 19:00 minmay Note Added: 0017393
2012-03-21 19:44 doublep Note Added: 0017394
2012-03-21 23:40 ion_frigate Note Added: 0017397
2012-03-21 23:41 ion_frigate Note Edited: 0017397
2012-03-22 04:36 simon1tan Note Added: 0017406
2012-09-18 09:54 DuxOrbis Note Added: 0020191
2012-09-19 23:47 DuxOrbis Note Edited: 0020191
2012-09-19 23:48 DuxOrbis Note Edited: 0020191
2013-03-15 05:31 mumra Issue Monitored: mumra
2013-05-26 09:08 mumra Relationship added related to 0005548
2013-05-26 09:39 mumra Tag Attached: AI
2014-03-25 19:57 galehar Note Added: 0025697
2014-03-25 19:57 galehar Status new => resolved
2014-03-25 19:57 galehar Fixed in Branch => 0.14 development branch
2014-03-25 19:57 galehar Resolution open => done
2014-03-25 19:57 galehar Assigned To => galehar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker