Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005354 [DCSS] Bug Report minor random 2012-02-23 15:30 2017-07-11 20:47
Reporter galehar View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0005354: Random startup fail with Windows and non-standard save dir / msysgit
Description Using msysgit (gcc 4.4.0), the game randomly fails to load some files from database/. For example:

Cannot find data file 'database/rand_arm.txt' anywhere, aborting

It's not always the same file and it doesn't always happen. I don't even have to regenerate the database, I just start it again until it works. I have this bug under winXP and win 7 (32 and 64 bits). I filled it as a minor bug since it doesn't seem to happen with the cross compiled official builds.
Additional Information
Tags No tags attached.
Attached Files txt file icon qw2-crashlog.txt [^] (6,279 bytes) 2017-03-27 00:19 [Show Content]

- Relationships
has duplicate 0005164resolvedmumra crawl seems to crash randomly at start. 
has duplicate 0006551closedmumra Randomly fails to start on Windows 8 
has duplicate 0006470resolvedmumra The game window closes at the loading screen if save_dir is set to some folders 
has duplicate 0003312resolvedmumra Tiles crashes immediatly no error file. 
has duplicate 0005504resolvedmumra When I should die, the game instead crashes. 
has duplicate 0005294resolvedmumra Blank window, crawl never loads 
has duplicate 0005685resolvedmumra Sometimes crashes or hangs up at start time 
has duplicate 0007041closedmumra Random crash @ main menu 

-  Notes
(0020350)
jay31415 (reporter)
2012-10-13 21:47

Still happens with the latest checkout of 0.11.

Using msysgit on Windows 7, I checked out the repository and compiled (the ascii version of) 0.11 as described on the website. I got one warning (/bin/sh: pkg-config: command not found) but apart from that everything worked fine. I started the game once to check the results (worked fine), then started working on my patch 0006312. When I wanted to try out its effect, I encountered an odd phenomenon:

Sometimes, in about one out of 10 tries, the game will randomly close with an error such as the following one:
 Cannot find data file 'database/tutorial.txt' anywhere, aborting
 Hit Enter to continue...

At first I thought this was because of the changes I'd done to the speech files (for testing), but I've since reverted those changes and still get these errors. It's also happened with files I hadn't touched such as the FAQ or godspeak.txt.

In the cases where the game did load correctly, I haven't encountered any errors or weirdness in how speech was processed within the game.

This also looks like the same issue as (the older) 0005164.
(0022214)
mumra (developer)
2013-04-08 21:57
edited on: 2013-04-08 21:57

I'm hitting this kind of error a lot on Windows 8 but with .lua and .des files usually - specific error messages are mentioned in my original report 0006551.

(0022666)
mumra (developer)
2013-05-15 03:25

There really are a lot of people encountering this and similar issues; look at the number of duplicates raised!
(0025796)
sgrunt (administrator)
2014-04-07 01:16

I disabled multi-threaded loading on Windows, which seems to be the root of the problem, in 0.15-a0-78-g2e17027 / 0.14-b1-39-gdb6f4b2; I'd like the underlying issue to be investigated better rather than just papered over like this, though.
(0031557)
advil (administrator)
2017-03-27 00:19
edited on: 2017-03-27 00:23

elliptic observed this again in the wild, on linux on 0.20a with a version of qw (at least -- it's similar enough that the same "fix" from https://github.com/crawl/crawl/commit/2e1702711870 [^] stopped crashes for him, too). The fact that it was qw seems to be a red herring though; or at least, that wasn't enough for me to replicate it on os x.

(0031721)
advil (administrator)
2017-07-11 15:18

Disabled for linux in https://github.com/crawl/crawl/commit/d00fd6f4884f [^]
(0031722)
advil (administrator)
2017-07-11 20:47

I got rid of this use of multithreading altogether in https://github.com/crawl/crawl/commit/6841d05e474c [^] . But there is an explanation of what I think was the cause of the bug in the commit message, as well as a hypothetical fix.

- Issue History
Date Modified Username Field Change
2012-02-23 15:30 galehar New Issue
2012-10-13 21:47 jay31415 Note Added: 0020350
2013-04-08 21:54 mumra Relationship added has duplicate 0005164
2013-04-08 21:54 mumra Relationship added has duplicate 0006551
2013-04-08 21:57 mumra Note Added: 0022214
2013-04-08 21:57 mumra Note Edited: 0022214
2013-05-09 20:02 mumra Relationship added has duplicate 0006470
2013-05-09 20:04 mumra Summary random startup crash with windows native build => Random startup fail with Windows and non-standard save dir / msysgit
2013-05-09 20:04 mumra Product Branch 0.11 old branch => 0.12 stable branch
2013-05-09 20:04 mumra Product Version 0.11-a0-232-gcc0dc5f => 0.12.1
2013-05-09 20:09 mumra Relationship added has duplicate 0003312
2013-05-09 20:14 mumra Relationship added has duplicate 0005504
2013-05-09 20:35 mumra Relationship added has duplicate 0005294
2013-05-09 20:35 mumra Relationship added has duplicate 0005685
2013-05-15 03:22 mumra Relationship added has duplicate 0007041
2013-05-15 03:25 mumra Note Added: 0022666
2014-04-07 01:16 sgrunt Note Added: 0025796
2014-04-07 01:16 sgrunt Status new => confirmed
2017-03-27 00:19 advil File Added: qw2-crashlog.txt
2017-03-27 00:19 advil Note Added: 0031557
2017-03-27 00:23 advil Note Edited: 0031557
2017-07-11 15:18 advil Note Added: 0031721
2017-07-11 20:47 advil Note Added: 0031722
2017-07-11 20:47 advil Status confirmed => resolved
2017-07-11 20:47 advil Fixed in Branch => longterm development (0.20+)
2017-07-11 20:47 advil Resolution open => done
2017-07-11 20:47 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker