Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005349 [DCSS] Bug Report minor have not tried 2012-02-21 18:05 2014-01-08 23:00
Reporter Cedor View Status public  
Assigned To KiloByte
Priority normal Resolution duplicate  
Status closed   Product Branch 0.10 ancient branch
Summary 0005349: Moutain dwarf still present in aptitude list
Description When selecting a specie/background, the aptitude list (%) still show mountain dwarf aptitudes.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0005044resolvedMarvinPA mountain dwarves still show up in in-game aptitude listing (?%) 

-  Notes
(0017130)
KiloByte (manager)
2012-02-23 03:17

You can upgrade a mountain dwarf game from 0.8 or 0.9. 0.10, contrary to expectations, ended up compatible with those versions so code for mountain dwarves cannot be purged yet.

Closing as duplicate.
(0017134)
ion_frigate (reporter)
2012-02-23 11:55

Doesn't that create a spoiler-y way to play MD if you desire? Namely, start a 0.8 or 0.9 game with a MD, and upgrade your save?

Also, I would still say that MD should be removed from the ?% list. Their presence there really suggests they're still in the game, which they're not supposed to be. Maybe put in a shim to display the aptitudes only if the current character is a MD? That shouldn't be too hard, given that it already highlights your current species.
(0017135)
evilmike (developer)
2012-02-23 12:26

ion_frigate: yes, if you were insane and really craved a mountain dwarf, you could do that. There's really no good way of dealing with this though, aside from breaking saves (which looks like will happen in 0.11). It's no big deal anyway. Like savescumming, there's no point in having crawl try to prevent it. If players want to go outside of the game to give themselves something extra (and this includes deliberately importing saves with obsolete stuff), so be it.

As a side note, mountain dwarves aren't the only example of this. There's also stuff like the short lived Tuikma's Ball spell.
(0017139)
ion_frigate (reporter)
2012-02-24 00:12

True, but the bar for getting Tukima's Ball is much higher: you'd have to find and likely compile one of the specific builds that had the spell, whereas with MD you just need 0.8 or 0.9. Still, I see the point that it's akin to savescumming, even if it's less directly cheating.

Still though, I'd say the MD aptitudes should be removed from the ?% screen unless you're playing an upgraded MD save. They're gone, so it'd be nice if there weren't something that weirdly hinted they weren't.

- Issue History
Date Modified Username Field Change
2012-02-21 18:05 Cedor New Issue
2012-02-21 18:09 Cedor Issue Monitored: Cedor
2012-02-21 18:09 Cedor Issue End Monitor: Cedor
2012-02-23 03:12 KiloByte Relationship added duplicate of 0005044
2012-02-23 03:17 KiloByte Note Added: 0017130
2012-02-23 03:17 KiloByte Status new => resolved
2012-02-23 03:17 KiloByte Fixed in Branch => 0.11 development branch
2012-02-23 03:17 KiloByte Resolution open => duplicate
2012-02-23 03:17 KiloByte Assigned To => KiloByte
2012-02-23 11:55 ion_frigate Note Added: 0017134
2012-02-23 12:26 evilmike Note Added: 0017135
2012-02-24 00:12 ion_frigate Note Added: 0017139
2014-01-08 23:00 Cedor Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker