Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005306 [DCSS] Bug Report minor have not tried 2012-02-11 16:36 2013-12-19 15:11
Reporter nagdon View Status public  
Assigned To mumra
Priority normal Resolution done  
Status closed   Product Branch 0.10 ancient branch
Summary 0005306: TSO penance from a hog just turned back to human
Description I killed Kirke with a fireball, so her hogs turned back to humans. The fireball also hit hog->human after killing Kirke so I got penance from the Shining One for attacking a non-hostile being. I guess this can also happen with Pikel and his slaves.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018118)
nomoreoxygen (reporter)
2012-05-22 09:27

Yeah, exactly the same happened for me with Pikel.
(0018119)
Kyrris (reporter)
2012-05-22 14:33

I think this should stay, at least as piety loss, and spread to Ely. Pikel's slaves should also trigger the same for Ely, even while still hostile. "$DIETY dislikes when you or your allies kill victims who could have been freed." Granted, forcing single-target attacks wouldn't change much for Pikel's strategy, but it would put Kirke even deeper into the crazy-dangerous territory. Both uniques should be called evil for TSO piety purposes, and every hog/slave freed should count as a pacification for Ely. Zin, prizing law over mercy, doesn't care about the plight of the slaves, but Kirke should probably be worth piety for being a forcible transmuter, if she isn't already.
(0018121)
nomoreoxygen (reporter)
2012-05-22 17:08

No, it shouldn't stay, all other accidental damaging is forgiven, it's a bug that happens because they "transform" the same frame as their master died. Moral is very arbitrary in crawl, look at the PC, barging in to a society with angels, demons, all people and all animals living in peace and murdering everything. This is apparently fine, but casting regeneration? IMMORAL!
(0018123)
ion_frigate (reporter)
2012-05-22 23:56

I think Kyrris is suggesting a piety loss for attacking the slaves/pig-men regardless of whether or not they're currently hostile. This would be consistent, and not merely depending on a bug (the monsters becoming non-hostile when their enslaver dies).

It would also be very obscure, and mostly pointless. Few Elyvilon players use conjurations, and few players worship TSO before finding Kirke. Mostly it'd penalize early Healers who use wands of fire/cold/lightning to kill Pikel. It wouldn't change the usual strategy for dealing with these uniques; you always want to attack the leader first anyway. Still though, it's probably better than the current behavior of randomly getting penance.
(0018162)
Kyrris (reporter)
2012-05-29 23:48

It would become way less obscure when Ely showers you in piety for killing Pikel.
(0022850)
mumra (developer)
2013-05-26 07:27

I resolved this in trunk; Kirke and Pikel's post-death effects are now postponed until after all other effects have been run so you will no longer trigger penance based on the turn when conversion happens (although a longer-lasting area effect e.g. conjure flame or firestorm could still trigger penance on subsequent turns of course).

- Issue History
Date Modified Username Field Change
2012-02-11 16:36 nagdon New Issue
2012-05-22 09:27 nomoreoxygen Note Added: 0018118
2012-05-22 14:33 Kyrris Note Added: 0018119
2012-05-22 17:08 nomoreoxygen Note Added: 0018121
2012-05-22 23:56 ion_frigate Note Added: 0018123
2012-05-29 23:48 Kyrris Note Added: 0018162
2013-05-26 07:27 mumra Note Added: 0022850
2013-05-26 07:27 mumra Status new => resolved
2013-05-26 07:27 mumra Fixed in Branch => 0.13 development branch
2013-05-26 07:27 mumra Resolution open => done
2013-05-26 07:27 mumra Assigned To => mumra
2013-12-19 15:11 nagdon Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker