Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005291 [DCSS] Bug Report tweak have not tried 2012-02-06 16:19 2014-10-04 02:46
Reporter KiloByte View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005291: wizardry stacking is a bad joke -- remove?
Description Currently, wearing one ring of wizardry reduces the fail chance to 74.9%, wearing four to 66.8%. With a difference that small, it just misleads people into thinking it stacks.

Options:
1. just don't stack
2. stack better

I think 1. is a safer option, but it looks like there is no consensus. Opinions?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0016898)
Galefury (updater)
2012-02-06 16:39

Both would be better than the status quo IMO, but I would prefer better stacking. Making stacking wizardry sometimes be a good idea could be interesting, removing stacking removes that decision.

There obviously has to be some kind of diminishing returns or a hard cap due to Octopodes. But making wizardry stacking better should be pretty safe, as long as it never gets you reliable spells on its own. Reducing spell failure rates by as much as 70% (for Octopodes with 8 rings and a staff) shouldn't be problematic.
(0016899)
elliptic (developer)
2012-02-06 17:39

I vote for not stacking more than two levels of wizardry (or just one is fine too), and put a wizardry line with two dots (or just one dot) on the '%' screen so that this is clear. (We can surely remove something from that screen to make room... I nominate Res.Rott. as one option for removal, since it almost never changes during the course of a game.)

I'd suggest either 80%/70% if we want two levels or just 75% if we want one level.
(0016900)
XuaXua (reporter)
2012-02-06 18:12
edited on: 2012-02-06 18:16

I vote for exponentially reduced stacking, where each additional source of wizardry works half as well as the prior source.

And, IIRC, staves of wizardry and randart wizardry stacks, right? So it's not just octopodes.

I don't know the wizardry rates, but let's say one source of wizardry reduces failure by 25% (FOR EXAMPLE), you get this chart of diminishing returns:
 
1 source reduces by 25 %
2 sources reduce by 38 % (25 + 13)
3 sources reduce by 45 % (25 + 13 + 7)
4 sources reduce by 49 % (25 + 13 + 7 + 4)
5 sources reduce by 51 % (25 + 13 + 7 + 4 + 2)
6+ reduce by 1% each, etc.

(0016903)
MarvinPA (developer)
2012-02-06 19:03

Capping it at two levels sounds reasonable to me (the staff and ring would probably need to both provide the same sized bonus in that case, which would make more sense anyway).
(0016912)
minmay (reporter)
2012-02-07 03:17

I also prefer better stacking. If it gets capped, though, three levels sounds more natural than two, since non-octopodes can only get three (unless you count Vehumet "wizardry" and the like, which stacks differently anyway).
(0016914)
evilmike (developer)
2012-02-07 03:34

The way wizardry stacking works is bad, but I think it's good if wearing two rings actually has an effect over just one ring. I think that, in general, it's better to have rings be "stackable" like this. So, I vote for 2-level wizardry.

Replacing the rRot line on the % screen with wizardry is a good idea. rRot is practically synonymous with "you are undead", which makes it pretty useless to show there.
(0016917)
ion_frigate (reporter)
2012-02-07 06:41
edited on: 2012-02-07 06:47

@elliptic: Most people aren't going to use two levels of wizardry, so increasing the gap between one and two rings of wizardry by *nerfing* one ring is pretty close to a pure nerf, and rings of wizardry are not overpowered as it is. I like XuaXua's suggestion much better: 75%->62.5%, but capped at two levels (two rings, or one staff).

@evilmike: Zin worshipers get rotting resistance. If rRot is removed from the % screen, that might need to be made a little clearer. Or the whole issue could be sidestepped by tying rRot to rN again, which would make draconian callers less of a ridiculous nuke, and actually present the player with a reason to have rN+++ once they reach XL27.

(0016918)
evilmike (developer)
2012-02-07 09:46

True, zin provides rotting resistance. This can be added to the ^ screen though.
(0016919)
KiloByte (manager)
2012-02-07 10:26

Zin doesn't provide rotting resistance except for Stamina.
(0016920)
evilmike (developer)
2012-02-07 10:43

Hmm yeah, just tried in wizmode. The % screen is just lying about rRot when you have high piety with Zin (set your piety to 150 or higher). Maybe a bug?

The % screen certainly fooled me. I guess I never tried getting hit by a ghoul on my one Zin character. :P
(0016924)
XuaXua (reporter)
2012-02-07 16:26
edited on: 2012-02-07 16:29

If it's set up as diminishing returns (see my first response), I don't see why there needs to be a hard cap (at 2 or any number).

Do note, I don't know what the actual percentage per ring/stave/god is, so I'm just pulling base numbers out of thin air.

The first value (25% for the ring as my example) should be based on the highest value of wizardry (if a Staff gives 30% or a god bonus gives 40%) and then add exponential reductions with each additional source.

So, if rings were 25 each, two rings would give 37, an octopode with 8 rings would get 54%

If wizardry or general staves were 30%, stave plus a ring would be 45%, plus two would be 53%; octopode with 8 rings would be 63%.

Since this only affects success (right?), Spellcasting eventually neuters any bonus.

What ARE the sources of Wizardry? Rings, Staves... do rings of Ice/Fire count, or is that just power? What about elemental magic staves that aren't wizardry?

(0016925)
Galefury (updater)
2012-02-07 16:37

A hard cap would have the advantage of being able to easily and clearly display wizardry on the % screen. If there is a hard cap it should be communicated clearly, the % screen is a great place to do this, so it all works out.

Also, what's the point in allowing Octopodes to stack 9 levels of wizardry if about 6 of them wont provide a noticeable benefit? It would be the same as the current situation, except only for Octopodes.
(0016935)
elliptic (developer)
2012-02-08 12:19

Kilobyte's numbers for wizardry are incorrect because he didn't take into account the rounding down that happens throughout the calculation. The correct numbers for how wizardry-type effects currently work are as follows:

1 ring: 74%
staff: 71%
vehumet: 67%
2 rings: 66%
1 ring + staff: 64%
2 rings + staff: 58%
any wizardry + Vehumet: 50%
brilliance: 50%

Also, I think some people in this conversation may not know what this number actually means; "66%" doesn't mean that you miscast spells 66% as often. Instead, this multiplier is applied to a number that is compared with random2avg(100, 3). This usually means a far larger decrease in failure rate. As an example:

failure rate with no modifiers: 38%
failure rate with one ring of wiz: 16%
failure rate with two rings of wiz: 11%
failure rate with staff + two rings of wiz: 8%
failure rate with Vehumet + one ring of wiz: 4%

Anyway, on thinking about things further I think that wizardry just shouldn't stack at all. I'd also suggest making it 75% instead of 74% (wizardry is rather strong so it can take the nerf), and then the table would simply be:

wizardry: 75%
vehumet: 67%
wizardry + vehumet: 50%
brilliance: 50%
(0016936)
KiloByte (manager)
2012-02-08 13:42

The numbers came from learndb -- if wizardry indeed practically stacks, the premises behind this issue are wrong.
(0016937)
XuaXua (reporter)
2012-02-08 16:01
edited on: 2012-02-08 16:02

Elliptic - what happens with 3+ rings in your list (Octopodes)?

I'm of the pro-stacking side (of one, apparently), as I feel the entire advantage of Octopodes is the fact they can use more than one ring and they get more choices in this fashion to compensate for their lack of defensive protection.

(0016947)
elliptic (developer)
2012-02-09 19:42

KiloByte: oh, yes, I see ??wizardry[3-5] is rather wrong... I still think using a more sensible stacking (or lack of stacking) formula might be better though, since 74% -> 66% is still not nearly as good as 100% -> 74%, and the second wizardry ring does nothing with vehumet-supported spells anyway.

XuaXua: here you go:
3 rings: 60%
4 rings: 54%
5 or more rings: 50%
(0016960)
galehar (administrator)
2012-02-10 15:26

I like the simplicity of elliptic's suggestion. Seems balanced too.
(0027426)
PleasingFungus (administrator)
2014-10-04 02:46

This was fixed a while ago!

- Issue History
Date Modified Username Field Change
2012-02-06 16:19 KiloByte New Issue
2012-02-06 16:39 Galefury Note Added: 0016898
2012-02-06 17:39 elliptic Note Added: 0016899
2012-02-06 18:12 XuaXua Note Added: 0016900
2012-02-06 18:13 XuaXua Note Edited: 0016900
2012-02-06 18:14 XuaXua Note Edited: 0016900
2012-02-06 18:16 XuaXua Note Edited: 0016900
2012-02-06 18:16 XuaXua Note Edited: 0016900
2012-02-06 18:17 XuaXua Issue Monitored: XuaXua
2012-02-06 19:03 MarvinPA Note Added: 0016903
2012-02-07 03:17 minmay Note Added: 0016912
2012-02-07 03:34 evilmike Note Added: 0016914
2012-02-07 06:41 ion_frigate Note Added: 0016917
2012-02-07 06:47 ion_frigate Note Edited: 0016917
2012-02-07 09:46 evilmike Note Added: 0016918
2012-02-07 10:26 KiloByte Note Added: 0016919
2012-02-07 10:43 evilmike Note Added: 0016920
2012-02-07 16:26 XuaXua Note Added: 0016924
2012-02-07 16:28 XuaXua Note Edited: 0016924
2012-02-07 16:29 XuaXua Note Edited: 0016924
2012-02-07 16:37 Galefury Note Added: 0016925
2012-02-08 12:19 elliptic Note Added: 0016935
2012-02-08 13:42 KiloByte Note Added: 0016936
2012-02-08 16:01 XuaXua Note Added: 0016937
2012-02-08 16:01 XuaXua Note Edited: 0016937
2012-02-08 16:02 XuaXua Note Edited: 0016937
2012-02-09 19:42 elliptic Note Added: 0016947
2012-02-10 15:26 galehar Note Added: 0016960
2014-10-04 02:46 PleasingFungus Note Added: 0027426
2014-10-04 02:46 PleasingFungus Status new => resolved
2014-10-04 02:46 PleasingFungus Fixed in Branch => 0.16 development branch
2014-10-04 02:46 PleasingFungus Resolution open => done
2014-10-04 02:46 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker