Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005290 [DCSS] Upload: Maps and Vaults feature have not tried 2012-02-06 15:40 2014-06-06 20:31
Reporter KiloByte View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005290: (unfinished) exploding sheep altar
Description This is an unfinished version of the vault. The problems are:

1. sheep can't survive the 3d20 explosion, unless 2. happens
2. they are placed north-to-south, allowing northmost sheep to act before the center explodes. If they wake up on time and the exit leads north, they get out alive (not a hard enemy even for weak chars). The vault shouldn't depend on a particular orientation.

2. could be avoided by placing the sheep with lua. 1. is harder: what I'd want is having the sheep damaged and on fire, running out in panic.
Additional Information
Tags No tags attached.
Attached Files ? file icon xom_exploding_sheep.des [^] (1,415 bytes) 2012-02-06 15:40 [Show Content]
? file icon kilobyte_xom_exploding_sheep.des [^] (2,696 bytes) 2012-07-07 22:00 [Show Content]

- Relationships

-  Notes
(0018822)
sgrunt (administrator)
2012-07-07 22:05

Since I find the idea of this altar hilarious (Xom finds this hilarious!), I decided to tinker with it to get it closer to the above stated vision and generally improve it.

Primarily, the sheep (now placed with Lua at the moment of seeing the altar) will now properly flee in terror for the few moments that they have before they explode. Most of the time they separate from each other enough for at least half of them to explode individually.

Some other tinkering:

- The internal name is now kilobyte_xom_exploding_sheep; this is more reflective of other recent vault names.

- The permarock walls are now stone walls (it's been suggested to me previously that permarock should be used sparingly, and I can't think of a good reason that it would need to be used here).

- The Lua for removing the walls and door has been simplified.

- The messaging has been tinkered with to match the effect of the player sticky-flaming a herd of sheep, and you only hear the "divine giggling" once (and on the Xom channel).

I feel that this now works rather well, and hope you all agree.
(0021860)
mumra (developer)
2013-03-27 06:32

I don't see any reason not to add this in trunk
(0026407)
sgrunt (administrator)
2014-06-06 20:31

After finally rewriting my functionality to get monsters to speak through Lua, this is in as 0.15-a0-1307-g49c7870.

- Issue History
Date Modified Username Field Change
2012-02-06 15:40 KiloByte New Issue
2012-02-06 15:40 KiloByte File Added: xom_exploding_sheep.des
2012-07-07 22:00 sgrunt File Added: kilobyte_xom_exploding_sheep.des
2012-07-07 22:05 sgrunt Note Added: 0018822
2013-03-15 00:38 mumra Issue Monitored: mumra
2013-03-27 06:32 mumra Note Added: 0021860
2014-06-06 20:31 sgrunt Note Added: 0026407
2014-06-06 20:31 sgrunt Assigned To => sgrunt
2014-06-06 20:31 sgrunt Status new => resolved
2014-06-06 20:31 sgrunt Resolution open => done
2014-06-06 20:31 sgrunt Fixed in Branch => 0.15 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker