Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005080 [DCSS] Bug Report minor have not tried 2011-12-17 15:52 2015-12-21 22:21
Reporter st View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005080: Fedhas doesn't protect plants from fireball and cloud spells
Description it's quite frustrating that you're at a disadvantage using these spells compared to non Fedhas chars since you get penance. note: the actual beam of fireball doesn't hurt plants but the blast does
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0016303)
moxian (reporter)
2011-12-17 16:09

I do think it's natural. You can "shoot" through plants without harming them (they move to create a clear line of sight), but you cannot "nuke" them without harming them.

Yes, you are at disadvantage for using those spells. Likewise TSO followers are at even greater disadvantage - they get insta-excommunicated for casting necromutation, despite it cannot harm allied angels at all!
You chose your own god yourself.
(0016304)
st (reporter)
2011-12-17 16:24
edited on: 2011-12-17 16:28

Fedhas is supposed to support ranged/conjurer characters, this is actively imparing them. Your TSO comparison is nonsense.

The message when you shoot through plants is "Fedhas protects your plant from harm." They don't "move out of the way." Why doesn't Fedhas protect them from nuking or standing in freezing vapours?

(0016305)
moxian (reporter)
2011-12-17 16:41

Okay, you've got a point. And, yes, my TSO comparison was overly sarcastic.

Anyway, flavor-wise, I've always imagined that with Fedhas help you and plants gain common consciousness, so that before you shoot you first make a path for your projectile.

If Fedhas merely protected plants from harm, then you wouldn't be able to shoot (with a bow, for example) through them - the arrows just wouldn't make it through. And if Fedhas can "protect plants from harm" when you fire through them, why cannot he protect them against enemy fire?

So I think that the wording is wrong here, and not what actually happens (flavor-wise).
(0016309)
KiloByte (manager)
2011-12-17 22:31

There's a related problem with Demonspawn: if a Fedhasite later in the game gets the Ignite Blood facet, you can't continue. The clouds are marked as caused by you, so the moment a monster bleeds, plants go in flames, with you getting the blame. Even if blame was diverted, wandering mushrooms fight in melee (ie, get splashed), oklobs use acid (ie -- even more blodd than regular damage), toadstools grow on corpses (usually bloodied). That means, you can just abandon immediately, for all wrath niceties.

Solutions here:
1. hard-ban Fedhas for Demonspawn (as we can't leak whether you'll get Ignite Blood later)
2. make Fedhas stop blood from igniting under plants, and stop mushrooms from wandering into clouds
3. make Fedhas extend your flame cloud immunity to plants
(0016328)
moxian (reporter)
2011-12-19 03:25

Another solution to Demonspawn problem would be to remove said mutation from them.
(0017336)
MarvinPA (developer)
2012-03-18 05:46

Fedhas protects plants from your clouds now. Not sure if he should protect them from explosions too, I suppose it's probably fine to do so?
(0030051)
wheals (administrator)
2015-12-21 22:21

And it was done in 42870f95.

- Issue History
Date Modified Username Field Change
2011-12-17 15:52 st New Issue
2011-12-17 16:09 moxian Note Added: 0016303
2011-12-17 16:24 st Note Added: 0016304
2011-12-17 16:28 st Note Edited: 0016304
2011-12-17 16:28 st Note Edited: 0016304
2011-12-17 16:41 moxian Note Added: 0016305
2011-12-17 22:31 KiloByte Note Added: 0016309
2011-12-19 03:25 moxian Note Added: 0016328
2012-03-18 05:46 MarvinPA Note Added: 0017336
2013-03-27 19:02 mumra Issue Monitored: mumra
2015-12-21 22:21 wheals Note Added: 0030051
2015-12-21 22:21 wheals Status new => resolved
2015-12-21 22:21 wheals Fixed in Branch => 0.18 development branch
2015-12-21 22:21 wheals Resolution open => done
2015-12-21 22:21 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker