Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005073 [DCSS] Bug Report minor always 2011-12-16 19:36 2013-08-21 03:43
Reporter casmith789 View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005073: Interface confusing when switching armour.
Description Crawl tells me "You stop training armour." when removing my leather armour for scale mail. This is confusing and seems to a new user of the feature that I have to reenable it somehow as there is not a message about retraining it. I suggest removing the message in the first place as it just adds to spam and is mostly irrelevant.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0016284)
moxian (reporter)
2011-12-16 20:45

There is a message about retraining at the very end, but it is lost in spam.

Concerning the spam, it currently gives me message:
"You start removing your armour.
You continue taking off your +0 scale mail. x6
You finish taking off your +0 scale mail.
You start putting on your armour.
You continue putting on your +0 leather armour.
You stop training armour.
You continue putting on your +0 leather armour. x2
You finish putting on your armour.
You resume training Armour."

Notice that "You stop training armour." is shown at the wrong time and creates an extra spam line above it. It should be shown immidiately after "You finish taking off your armour".

Also, are those "You start/stop putting on/taking off" lines really needed?

Concerning the confusion for new users, what about rewording the message to "You cannot train your Armour skill without wearing armour", jr (a bit shorter, but more obscure) "You cannot train your Armour without one"?
(0016288)
elliptic (developer)
2011-12-16 22:09

A simple solution to this confusion and message spam would be to remove the restriction on training armour skill and make it always trainable. I don't think differentiating between robes and leather, say, in this way really achieves anything... armour skill is nearly but not completely useless with either one.
(0016290)
casmith789 (reporter)
2011-12-16 23:04

I am 100% sure there wasn't a message about retraining armour skill when I looked with ^P immediately after wearing the scale mail.
(0016301)
ion_frigate (reporter)
2011-12-17 09:31

At the very least the message spam should be removed unless the state of your armour training changes for longer than it takes to change armour - that is, it should only say "You stop training armour" if you're interrupted and left without any armour; otherwise, it's unnecessary and could be mildly confusing. Though I agree with elliptic that armour should probably be always trainable - especially since currently, you're quite able to train Dodging while wearing GDA, but not Armour while wearing a robe. Strange, since the first case is actually more useful (you can get 50/30/50 by doing the first, but maybe 23/40/50 by doing the second).
(0023801)
chris (updater)
2013-08-21 02:49
edited on: 2013-08-21 02:50

Armour skill does not appear to be restricted anymore after fd0a1caa87b0dd7aa33f540463c7ae7c2eba0cf6

dat/database/help.txt however is still lying about this:

                               <h>Training restrictions</h>
* Armour requires wearing an armour with an evasion penalty.


- Issue History
Date Modified Username Field Change
2011-12-16 19:36 casmith789 New Issue
2011-12-16 20:45 moxian Note Added: 0016284
2011-12-16 22:09 elliptic Note Added: 0016288
2011-12-16 23:04 casmith789 Note Added: 0016290
2011-12-17 09:31 ion_frigate Note Added: 0016301
2013-08-21 02:49 chris Note Added: 0023801
2013-08-21 02:50 chris Note Edited: 0023801
2013-08-21 03:43 MarvinPA Status new => resolved
2013-08-21 03:43 MarvinPA Fixed in Branch => 0.13 development branch
2013-08-21 03:43 MarvinPA Resolution open => done
2013-08-21 03:43 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker