Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005030 [DCSS] Bug Report crash have not tried 2011-12-09 18:12 2015-02-23 16:08
Reporter neil View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005030: Expiring monster confusion when changing levels can crash?
Description Crash dump at:

  http://crawl.develz.org/morgues/trunk/nht/crash-nht-20111209-164511.txt [^]

The player changed levels, apparently while an orc was confused by a vial. Upon returning to the level (perhaps immediately), the enchantment expired because of update_level(); for confusion this would blink the monster to simulate its random wandering, but when that tried to check whether the monster could fly (to determine safe terrain), it crashed because get_monster_data returned NULL.

I cannot reproduce this.

Not sure if the monster was dead: there was no message about it, but it could have happened offscreen. Possibly step from time could cause the same crash?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0028548)
wheals (administrator)
2015-02-23 16:08

You probably fixed this 3 years later in http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=583cba717a02d28c1. [^]

- Issue History
Date Modified Username Field Change
2011-12-09 18:12 neil New Issue
2015-02-23 16:08 wheals Note Added: 0028548
2015-02-23 16:08 wheals Status new => resolved
2015-02-23 16:08 wheals Fixed in Branch => 0.16 development branch
2015-02-23 16:08 wheals Resolution open => done
2015-02-23 16:08 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker