Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000005 [DCSS] Bug Report crash sometimes 2009-11-20 09:42 2013-03-17 21:04
Reporter Matthew Cline View Status public  
Assigned To mumra
Priority normal Resolution unable to reproduce  
Status resolved   Product Branch
Summary 0000005: tiles: weird nvidia crash on Linux
Description Sometimes when tiles starts up the screen will be blank, and won't stop being blank until the window is minimized and then restored. However, sometimes doing that will cause a crash in Nvidia's OpenGL library.
Additional Information I've reported the bug to a Linux Nvidia driver developer here:

http://www.nvnews.net/vbulletin/showthread.php?t=141521 [^]
Tags crash, Linux, nvidia, tiles
Attached Files

- Relationships

-  Notes
(0000014)
Matthew Cline (developer)
2009-11-20 12:43

I've narrowed the crash down: it happens during the call to SDL_GL_SwapBuffers() in method TilesFramework::redraw(), line 1307 of tilesdl.cc
(0021629)
mumra (developer)
2013-03-17 21:04

No movement for a long time on this one, neither here or on the nvnews thread linked to. Could have been faulty hardware for all we know. If this still reproduces with .11 / trunk please reopen.

- Issue History
Date Modified Username Field Change
2009-11-20 09:42 Matthew Cline New Issue
2009-11-20 09:42 Matthew Cline Test Custom Field => crash, tiles, nvidia, Linux
2009-11-20 09:53 Matthew Cline Tag Attached: crash
2009-11-20 09:53 Matthew Cline Tag Attached: Linux
2009-11-20 09:53 Matthew Cline Tag Attached: nvidia
2009-11-20 09:53 Matthew Cline Tag Attached: tiles
2009-11-20 09:56 Matthew Cline Test Custom Field crash, tiles, nvidia, Linux =>
2009-11-20 12:43 Matthew Cline Note Added: 0000014
2011-01-22 11:12 Napkin Operating System Linux (Mandriva One) => Linux
2011-01-22 11:12 Napkin Console or Tiles 2.6.31.5 => Tiles
2011-01-22 11:12 Napkin Local or Remote x86 => Local
2013-03-17 21:04 mumra Note Added: 0021629
2013-03-17 21:04 mumra Status new => resolved
2013-03-17 21:04 mumra Resolution open => unable to reproduce
2013-03-17 21:04 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker