Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004890 [DCSS] Bug Report minor always 2011-11-12 16:42 2014-06-15 21:55
Reporter minmay View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.10 ancient branch
Summary 0004890: Transforming and unequipping can directly lead to drowning
Description Melding +Lev armour or a +Lev weapon causes you to stop levitating. You drown if you do this over water. The game shouldn't allow you to cast a transformation if it would cause you to drown immediately.

In addition, unwielding a +Lev weapon or taking off +Lev armour over water will drown you immediately, yet you don't even get a prompt. This is even worse since unwielding a weapon only requires hitting a single key!
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026461)
wheals (administrator)
2014-06-11 18:29

Seems to have been fixed.

- Issue History
Date Modified Username Field Change
2011-11-12 16:42 minmay New Issue
2011-11-14 13:26 mursu Issue Monitored: mursu
2014-06-11 18:29 wheals Note Added: 0026461
2014-06-11 18:29 wheals Status new => resolved
2014-06-11 18:29 wheals Fixed in Branch => 0.15 development branch
2014-06-11 18:29 wheals Resolution open => done
2014-06-11 18:29 wheals Assigned To => wheals
2014-06-15 21:55 minmay Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker