Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004889 [DCSS] Bug Report crash always 2011-11-12 15:24 2012-08-04 16:57
Reporter tsohg View Status public  
Assigned To edlothiol
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0004889: ERROR in tileview.cc at line 946: non-door file
Description Followed a normal staircase down in the Vault and this error popped up, crashing crawl. Trying to load the game results in the error window popping up- saved file can no longer be loaded.
Additional Information
Tags No tags attached.
Attached Files ? file icon Hankzetterberg.cs [^] (2,315,559 bytes) 2011-11-12 16:02
? file icon Hankzetterberg2.cs [^] (2,307,665 bytes) 2011-11-12 16:49
? file icon wh1te.cs [^] (382,415 bytes) 2012-08-04 11:55
? file icon Berryman.cs [^] (533,744 bytes) 2012-08-04 15:51

- Relationships
related to 0004872closededlothiol some black tiles in an abyss vault 
has duplicate 0005835resolvededlothiol Some floor tiles randomly change to wrong tiles 
related to 0006032closedneil floor tile idx (0/0) out of bounds:1 x18 

-  Notes
(0015825)
edlothiol (developer)
2011-11-12 15:47

Thanks for the report. Could you upload the save file?
(0015827)
tsohg (reporter)
2011-11-12 16:02

Save file uploaded, thanks.
(0015828)
edlothiol (developer)
2011-11-12 16:52

I've tried to fix the problem in this particular savefile -- tsohg, try loading the attached file.

I'm stumped about what caused this, though. There are FLOOR_ROUGH and FLOOR_HALL tile overrides all over the map in V:5; it seems even as feature overrides (which caused the assert). Interestingly, both seem to legitimately occur in vaults on the map.
(0015831)
tsohg (reporter)
2011-11-12 17:00

Thanks for the fix, the save you uploaded loads just fine. I see the rough tiles also... odd.
(0015847)
Galefury (updater)
2011-11-13 12:03

The save I uploaded in 4872 also has large amounts of tiles replaced by vault tiles. Apparently not doors, though, so no crashes. I don't know if the black abyss tiles are related, but they might be. Also all this might be related to 4705.
(0018735)
edlothiol (developer)
2012-07-05 21:05

It looks like the cells in question somehow got feat_idx set, which then caused feat to be changed to a vault tile in _reinit_flavour_tiles. I'm still not sure where the feat_idx came from, though -- it should only be set by vaults.
(0019398)
edlothiol (developer)
2012-08-04 11:56

Another instance from CSN, except much worse. Somehow, the default tile flavour got changed.
(0019400)
edlothiol (developer)
2012-08-04 16:57

Fixed in b7903a7b.

- Issue History
Date Modified Username Field Change
2011-11-12 15:24 tsohg New Issue
2011-11-12 15:24 tsohg Issue Monitored: tsohg
2011-11-12 15:47 edlothiol Note Added: 0015825
2011-11-12 15:59 tsohg Note Added: 0015826
2011-11-12 16:02 tsohg File Added: Hankzetterberg.cs
2011-11-12 16:02 tsohg Note Deleted: 0015826
2011-11-12 16:02 tsohg Note Added: 0015827
2011-11-12 16:49 edlothiol File Added: Hankzetterberg2.cs
2011-11-12 16:52 edlothiol Note Added: 0015828
2011-11-12 17:00 tsohg Note Added: 0015831
2011-11-13 12:01 Galefury Relationship added related to 0004872
2011-11-13 12:03 Galefury Note Added: 0015847
2012-07-05 20:50 edlothiol Relationship added related to 0005835
2012-07-05 21:03 edlothiol Relationship replaced has duplicate 0005835
2012-07-05 21:05 edlothiol Note Added: 0018735
2012-08-04 11:55 edlothiol File Added: wh1te.cs
2012-08-04 11:56 edlothiol Note Added: 0019398
2012-08-04 15:51 elderman File Added: Berryman.cs
2012-08-04 16:57 edlothiol Note Added: 0019400
2012-08-04 16:57 edlothiol Status new => resolved
2012-08-04 16:57 edlothiol Fixed in Branch => 0.11 development branch
2012-08-04 16:57 edlothiol Resolution open => done
2012-08-04 16:57 edlothiol Assigned To => edlothiol
2012-08-04 17:59 sgrunt Relationship added related to 0006032


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker