Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004786 [DCSS] Bug Report tweak always 2011-10-21 09:52 2013-05-23 06:11
Reporter XuaXua View Status public  
Assigned To mumra
Priority normal Resolution no change required  
Status closed   Product Branch 0.10 ancient branch
Summary 0004786: High Orc Priests do not sort
Description OK... so if I am on a board with 100 orc followers of various kinds, apparently the strongest warriors of my Beogh orc religion bubble over next to me for the purposes of stair travel.

The uniques (Blork, Nergalle, Saint Roka, etc.),
then the strongest warriors (Knights, warriors),
then wizards who piss me off because they blink away to die all the time (wizards and sorcerers),
then priests (green),
then regular orcs,
then HIGH PRIESTS.

It takes three dips to get a high priest. They should be sorted in before the regular priests. High Priests stay quite the heck away. What's up with that? It's almost impossible to get them to go with.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015435)
XuaXua (reporter)
2011-10-21 17:16
edited on: 2011-10-21 18:38

Proximity Order appears to be:

1 : ALLY : Summons / Undead
2 : ORC : Uniques except Saint Roka / Named Warlords
3 : ORC : Warlords / Named Knights
4 : ORC : Knights / Named Sorcerers
5 : ORC : Sorcerers / Named Warriors / Warriors / Named Priests / Named Wizards / Named High Priests / High Priests / Saint Roka
6 : ORC : Priests / Wizards / Normals

Proximity Order, assuming ALLY characters can be grouped in the 3-square connectivity range with ORCS but only under Beogh, probably should be:

01 : ORC : ALL Uniques / Named Warlords
02 : ORC : Warlords / Named Sorcerers / Named High Priests
03 : ALLY : Level-Travel-Allowed Ally created by or for Player
04 : ORC : Named Knights / Sorcerers / High Priests
05 : ORC : Knights / Named Priests / Named Wizards
06 : ALLY : Level-Travel-Allowed Ally created by Ally
07 : ORC : Named Warriors
08 : ORC : Warriors / Priests / Wizards
09 : ALLY : Any other Ally allowed level travel
10 : ORC : Normals
11 : ALLY : Ally restricted from level travel

Edited because I just converted Saint Roka and he's as far away from me as possible.

(0015472)
jpeg (manager)
2011-10-22 17:34

AFAIK, there's no special code to decide how allies are supposed to push through crowds. What you're seeing here is the result of two simple rules:

1. Stronger monsters (decided by HD) push past weaker ones.
2. Monsters with area/smite attacks tend to hang back.

You're right that the second rule probably doesn't make much sense for allies beelining for the player.

And of course, only monsters within the same genus group allow position swaps, though I guess that, too, could be loosened for allies moving towards the player.
(0021956)
mumra (developer)
2013-03-29 06:39

Recent changes to Beogh followers and inter-level recall should have improved this situation
(0022111)
XuaXua (reporter)
2013-04-03 06:21

I'll have to test before I close this.

- Issue History
Date Modified Username Field Change
2011-10-21 09:52 XuaXua New Issue
2011-10-21 17:16 XuaXua Note Added: 0015435
2011-10-21 17:18 XuaXua Note Edited: 0015435
2011-10-21 17:27 XuaXua Note Edited: 0015435
2011-10-21 17:27 XuaXua Note Edited: 0015435
2011-10-21 18:38 XuaXua Note Edited: 0015435
2011-10-22 17:34 jpeg Note Added: 0015472
2013-03-29 06:39 mumra Note Added: 0021956
2013-03-29 06:39 mumra Status new => resolved
2013-03-29 06:39 mumra Fixed in Branch => 0.12 development branch
2013-03-29 06:39 mumra Resolution open => no change required
2013-03-29 06:39 mumra Assigned To => mumra
2013-04-03 06:21 XuaXua Note Added: 0022111
2013-05-23 06:11 XuaXua Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker