Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004675 [DCSS] Bug Report minor have not tried 2011-10-03 15:55 2015-02-16 20:52
Reporter mumra View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0004675: Fire and Flame cloud discrepancy
Description There's a little inconsistency in the uses of "fire" and "flame" when it comes to clouds (which resulted in me using the wrong type in the new cloud traps!)

There are two fire clouds in the enum: CLOUD_FIRE, and CLOUD_FOREST_FIRE.

However in _terse_cloud_names (which is used for parsing the cloud type in Lua calls), these are respectively "flame" and "fire".

Confusingly, in _verbose_cloud_names, they are *both* described as "roaring flames". But, _verbose_cloud_names appears to be used *solely* for an obscure check on rain clouds (with a comment "Special message for unmodified rain clouds"). At least, that is the only usage that I could find, perhaps I missed something.

Proposed solution:
a) Rename CLOUD_FIRE to CLOUD_FLAME
b) Remove _verbose_cloud_names (and implement that particular logic for rain in a slightly simpler fashion)?

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015020)
KiloByte (manager)
2011-10-03 21:37

I'd rather fix CLOUD_FOREST_FIRE not telling people what it is.

I did implement it a long time ago but my memory is a bit cloudy. I think I did it this way because cloud code prepends "cloud of " in a number of places, and thus it was hard to explain that it's a burning tree rather than just hot air.
(0028495)
wheals (administrator)
2015-02-16 20:52

Fixed in 08d921687a64c.

- Issue History
Date Modified Username Field Change
2011-10-03 15:55 mumra New Issue
2011-10-03 21:37 KiloByte Note Added: 0015020
2015-02-16 20:52 wheals Note Added: 0028495
2015-02-16 20:52 wheals Status new => resolved
2015-02-16 20:52 wheals Fixed in Branch => 0.16 development branch
2015-02-16 20:52 wheals Resolution open => done
2015-02-16 20:52 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker