Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004614 [DCSS] Bug Report trivial have not tried 2011-09-25 01:34 2013-08-22 00:21
Reporter smock View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0004614: Issues with auto-remove from shipping list
Description Two small issues.

First, the "do you want to remove from shopping list" message appears before the message describing the identity manual is displayed.

Second, when a manual of fighting is on the shopping list and another manual of fighting is identified, you receive a prompt asking if you want to remove the manual from the shopping list. There's no reason one would want to do so for manuals.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Shopping-list-Do-not-prompt-for-removing-manuals.patch [^] (1,769 bytes) 2013-08-21 16:51 [Show Content]

- Relationships
related to 0001402closedneil Shopping list asks to remove manual when a different kind of manual is picked up 

-  Notes
(0015890)
elliptic (developer)
2011-11-18 09:21

Just noting that you also get incorrect prompts about removing items from your shopping list with some other items, like rings of slaying.
(0017152)
raskol (reporter)
2012-02-24 20:05

Just had this happen with two DIFFERENT manuals, which makes even less sense -- on readiding a manual of bows it asked if I wanted to remove a manual of dodging from my shopping list.
(0017371)
neil (administrator)
2012-03-19 08:06
edited on: 2012-03-19 08:07

Partially fixed in trunk (the part about being prompted for the wrong kind of manual or for a manual that has not yet been identified). I'm leaving this one open because manuals of the same type still prompt for removal, despite the fact that they are consumable.

(0023823)
chris (updater)
2013-08-21 16:52

Uploaded this:
Subject: Shopping list: Do not prompt for removing manuals

As the comment said, but the logic not really supported, those are
consumables and as such it is very feasible to continue being interested
in them after identifying one of their kind.

Tomes of destruction technically also fit that description, but instead
of prompting for removal they are just automatically removed now when
another tome is encountered. Whyever they ended up on a shopping list at
all will remain a mystery though.
(0023827)
neil (administrator)
2013-08-22 00:21

Chris's patch is in trunk (0.13-a0-2748-gab8f36f), thanks!

- Issue History
Date Modified Username Field Change
2011-09-25 01:34 smock New Issue
2011-11-18 09:21 elliptic Note Added: 0015890
2012-02-24 20:05 raskol Note Added: 0017152
2012-03-18 05:23 MarvinPA Relationship added related to 0001402
2012-03-19 08:06 neil Note Added: 0017371
2012-03-19 08:07 neil Note Edited: 0017371
2013-08-21 16:51 chris File Added: 0001-Shopping-list-Do-not-prompt-for-removing-manuals.patch
2013-08-21 16:52 chris Note Added: 0023823
2013-08-22 00:21 neil Note Added: 0023827
2013-08-22 00:21 neil Status new => resolved
2013-08-22 00:21 neil Fixed in Branch => 0.13 development branch
2013-08-22 00:21 neil Resolution open => done
2013-08-22 00:21 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker