Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004573 [DCSS] Implementables feature N/A 2011-09-20 01:05 2014-03-21 10:33
Reporter dpeg View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0004573: ?/G and ?/B improvements
Description Players can learn something about gods and branches using the ?/G and ?/B commands. (That' is not as obscure as it sounds as dungeon overview Ctrl-O hints at the commands.) This implementable deals with the output of these screens which could be improved a bit.

1. ?/G keys
The key to access a god should be the god's initial. For the Shining One, use 1.
I am not sure if the key letters should be uppercase or lowercase. In any case, bonus points for printing the letter (but not the god name) in the god's colour.

2. ?/B keys
Similarly, the key to access a branch description should be the travel key for the branch (the list you get when you press G).

3. ?/B tree
In the best of all worlds, we would present the branches not in a list, but in a tree shape. This is not so easy to do giving the screen limitations we have to assume. (80 columns is fixed, using more than 24 lines might be okay.)
Wensley provided a mock up for how this could look like. Coder's choice to modify the presentation, of course.

                                    (D) The Dungeon
                                      |
           (T) The Ecumenical Temple -|
                                      |- (O) The Orcish Mines
                        (L) The Lair -|   |
                         |            |  (E) The Elven Halls
      (P) The Snake Pit -|            |
          (S) The Swamp -|            |- (H) The Hive
         (A) The Shoals -|            |
    (N) The Spider Nest -|            |- (V) The Vaults
                         |            |   |
     (M) The Slime Pits -|            |   |- (B) The Hall of Blades
                                      |   |- (C) The Crypt
                       (?) The Abyss -|       |- (W) The Tomb of the Ancients
                                      |
                     (?) Pandemonium -|- (U) The Vestibule of Hell
                      |               |   |- (D) The Iron City of Dis
                      |               |   |- (Y) Tartarus
                      |               |   |- (X) Cocytus
                      |               |   |- (G) Gehenna
                      |               |
                      |              (Z) The Realm of Zot
Additional Information
Tags No tags attached.
Attached Files ? file icon godmenu.patch [^] (2,853 bytes) 2011-09-21 20:41 [Show Content]
? file icon altar_colours.patch [^] (786 bytes) 2011-09-21 22:17 [Show Content]
? file icon singleselect.patch [^] (3,817 bytes) 2011-09-22 12:57 [Show Content]
? file icon primary_hotkey.patch [^] (1,887 bytes) 2011-09-22 12:57 [Show Content]

- Relationships
related to 0005605closedMarvinPA Need descriptions for the portal vaults. 

-  Notes
(0014714)
KiloByte (manager)
2011-09-20 01:07

I hate the "tree" part, let's make it a graph with cycles :p
(of course, that's a change to more than just display...)
(0014716)
dpeg (administrator)
2011-09-20 01:33

I didn't expect the tree view to be conscentious because nobody reads ?/B anyway.

Seriously, I'd be really happy about the ?/G change. I think it is a genuine improvement.

Changing the ?/B is less intuitive but probably a slight gain in overall consistency. Perhaps we reserve the tree view for tiles -- it should be possible to _draw_ a nice-looking graphic. (And it'd mean that kilobyte and I would never have to look at it :)
(0014717)
KiloByte (manager)
2011-09-20 01:43

dpeg: sorry if I was unclear. I don't have anything against the ASCII display -- heck, it would be pretty nice.

I was talking about our dungeon layout being stupidly limited to a tree, mechanics-wise. I want shortcuts from Lair:8 to Vaults and so on :p
(0014723)
jpeg (manager)
2011-09-20 19:04
edited on: 2011-09-20 19:07

While I agree on the first part (the current behaviour is a needless interface complication), I beg to differ on the latter two.

The first problem is that other than for the gods, the branch shortcuts are largely arbitrary. Even if the branches themselves remain listed alphabetically, a new player might be puzzled at the arbitrarily assigned keys. Still, an explanation should help alleviate that problem, so this might actually be useful.

As for 3., I just can't see the full tree display working out. If a comparatively new player who hasn't memorised the order of branches yet, comes across, say, the entrance to the Spider's Nest and decides to check it out in the database, the tree layout actually makes it *harder* to find the abbreviation they need to get more information. It's useful information, but I don't think it should be mixed in with the menu mechanics and ASCII doesn't exactly help the readability, either.

What I could see, however, is a graphical display of immediate *sub*branches of the branch you're looking at. First the player is presented with the usual alphabetical list of branches. Then, once they select branch to read its description, the resulting screen lists all branches (and their depth ranges) leading directly off the selected branch, or the information that said branch does not have any subbranches.

(0014754)
ldierk (reporter)
2011-09-21 20:43

?/G screen with gods initial as hotkey and god_colour() as hotkey colour
(0014755)
ldierk (reporter)
2011-09-21 22:20

the altar colours patch makes ?/G use altar colours. It has more different colours, but some god a have 2 or 3 possible colours (so the colours are not always the same). Ash is default yellow. I think it still looks better though. The patch has to be applied on top of godmenu.patch.
(0014763)
ldierk (reporter)
2011-09-22 12:57

I can't see the reason why MenuEntrys in Menus with the MF_SINGLESELECT flag set, can only have one hotkey. This patch removes this restriction. I tried spellbooks, shops, stash, inventory and the discribe menus and could not notice any side effects. I'm not 100% sure about it, as this patch removes three checks to make sure only the primary hotkey is allowed.
The second commit makes the ?/G Menu display uppercase initials, but allows both upper- and lowercase initials as hotkeys.
(0014764)
ldierk (reporter)
2011-09-22 12:58

In case the singleselect.patch is not used I attached primary_hotkey.patch wich makes Menu::select_item use the proper method to determine the primary hotkey.
(0014784)
Wensleydale (updater)
2011-09-23 02:17

jpeg: The letters used in the tree, while indeed somewhat arbitrary, are identical to those used in the "Where to?" (G) interface. Creating parity between these two screens was dpeg's idea, in fact. :)

As for the tree layout itself, well... while it leaves much to be desired, I really can't imagine a worse depiction of the branches than the current flat layout. I'm a very spatially-minded person, though.

And I agree with KiloByte... let's get some cycles in here!
(0014788)
dpeg (administrator)
2011-09-23 11:35

I am not sure about the remaining item anymore. Should I close it, and we'll look at patches for ?/B as they come?
(0014792)
KiloByte (manager)
2011-09-23 12:12

dpeg: only the first two patches are applied, and I can't test them in tiles right now.
(0017890)
KiloByte (manager)
2012-04-27 00:36

I wonder what was the point of assigning to me. I have little clue about menu stuff.
(0017893)
BlackSheep (reporter)
2012-04-27 04:33

All that's left to do is the tree menu? I can give that a shot, assuming it's still wanted.
(0017894)
galehar (administrator)
2012-04-27 10:25

3rd patch looks good to me, will test and push.

@BlackSheep: the tree menu could be nice, but IMO, the improvement / amount of coding ratio is quite low.

But if you want to do it for fun, go ahead! I think the first step would be to convert the menus to PrecisionMenu, and that would be a significant improvement, by allowing arrows and mouse controls.

Since you're interested in interface improvements, I'll make an implementable with the most urgent ones.
(0017895)
galehar (administrator)
2012-04-27 11:52

Oh, I forgot. It would be good to use the GodMenu for the zotdef create altar ability (and wizmode command while we're at it).
(0017904)
neil (administrator)
2012-04-28 05:14

It would also be nice to support displaying quotes in ?/B. Currently only Tomb has a quote, but many of the portal vaults do have quotes on their entrance features that could be moved to the branch/portal vault itself.
(0025669)
MarvinPA (developer)
2014-03-21 10:33

Resolving this, the god menu changes have been in and the rest isn't desirable any more I think.

- Issue History
Date Modified Username Field Change
2011-09-20 01:05 dpeg New Issue
2011-09-20 01:07 KiloByte Note Added: 0014714
2011-09-20 01:33 dpeg Note Added: 0014716
2011-09-20 01:43 KiloByte Note Added: 0014717
2011-09-20 19:04 jpeg Note Added: 0014723
2011-09-20 19:07 jpeg Note Edited: 0014723
2011-09-21 20:41 ldierk File Added: godmenu.patch
2011-09-21 20:43 ldierk Note Added: 0014754
2011-09-21 22:17 ldierk File Added: altar_colours.patch
2011-09-21 22:20 ldierk Note Added: 0014755
2011-09-22 12:57 ldierk File Added: singleselect.patch
2011-09-22 12:57 ldierk Note Added: 0014763
2011-09-22 12:57 ldierk File Added: primary_hotkey.patch
2011-09-22 12:58 ldierk Note Added: 0014764
2011-09-23 02:17 Wensleydale Note Added: 0014784
2011-09-23 11:35 dpeg Note Added: 0014788
2011-09-23 12:12 KiloByte Note Added: 0014792
2011-10-21 02:36 SamB Status new => assigned
2011-10-21 02:36 SamB Assigned To => KiloByte
2012-04-27 00:35 KiloByte Assigned To KiloByte =>
2012-04-27 00:36 KiloByte Note Added: 0017890
2012-04-27 04:33 BlackSheep Note Added: 0017893
2012-04-27 04:34 BlackSheep Issue Monitored: BlackSheep
2012-04-27 10:25 galehar Note Added: 0017894
2012-04-27 11:52 galehar Note Added: 0017895
2012-04-28 05:14 neil Note Added: 0017904
2012-04-28 05:25 neil Relationship added related to 0005605
2013-08-10 22:50 BlackSheep Issue End Monitor: BlackSheep
2014-03-21 10:33 MarvinPA Note Added: 0025669
2014-03-21 10:33 MarvinPA Status assigned => resolved
2014-03-21 10:33 MarvinPA Fixed in Branch => 0.14 development branch
2014-03-21 10:33 MarvinPA Resolution open => done
2014-03-21 10:33 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker