Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004553 [DCSS] Bug Report text have not tried 2011-09-16 03:03 2013-05-21 07:19
Reporter reid View Status public  
Assigned To mumra
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0004553: experience display does not always update correctly when reaching XL 27
Description I can't reproduce this in debug mode, because the display is different, but I've seen it happen when reaching XL 27 that there is leftover text in the XL line, like

XL: 27 Next: 97%

This might only happen when regaining XL 27 after being drained. The extra text goes away when the screen is redrawn.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0022204)
mumra (developer)
2013-04-08 20:27
edited on: 2013-04-08 20:27

Can't reproduce this but if it still happens please comment / reopen. Better reproduction steps would be useful. A save file just prior to the bug triggering would be really useful but I realise it's hard to get.

(0022329)
reid (reporter)
2013-04-18 04:10

XL: 27 Next: 100%

This happened to me on coolrobin (TeCK) in 0.13-a, somewhere around turn 71000. (I'd give you a -tv command but FooTV seems to be unable to play the ttyrec for some reason.)
(0022370)
reid (reporter)
2013-04-22 00:47

FooTV is able to play the game now. !lg coolrobin teck 11 -tv:<T71000:>T71200
(0022378)
elliptic (developer)
2013-04-22 07:13

This just happened to me on my first time reaching XL 27 in a game. gid=elliptic:cszo:20130319070249S, turn 84554 (78870.0 time).
(0022726)
neil (administrator)
2013-05-21 07:19

Fixed in trunk (0.13-a0-821-g8a32599), thanks!

- Issue History
Date Modified Username Field Change
2011-09-16 03:03 reid New Issue
2013-04-08 20:27 mumra Note Added: 0022204
2013-04-08 20:27 mumra Status new => resolved
2013-04-08 20:27 mumra Fixed in Branch => 0.13 development branch
2013-04-08 20:27 mumra Resolution open => unable to reproduce
2013-04-08 20:27 mumra Assigned To => mumra
2013-04-08 20:27 mumra Note Edited: 0022204
2013-04-18 04:10 reid Note Added: 0022329
2013-04-18 04:11 reid Status resolved => new
2013-04-18 04:11 reid Resolution unable to reproduce => reopened
2013-04-22 00:47 reid Note Added: 0022370
2013-04-22 07:13 elliptic Note Added: 0022378
2013-05-21 07:19 neil Note Added: 0022726
2013-05-21 07:19 neil Status new => resolved
2013-05-21 07:19 neil Resolution reopened => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker