Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004454 [DCSS] Patches feature N/A 2011-08-29 18:17 2012-08-28 22:21
Reporter dpeg View Status public  
Assigned To Kate
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0004454: Hive as a portal vault
Description This is a somewhat larger Implementable. It is about turning the Hive branch into a portal vault, setting up a race-like mini-game for those who want as much food as possible.

The patch will require both C++ coding as well as .des (level file) syntax and lua (for the portal vault) but for the latter two there are similar vaults whose code can be adopted. Feel free to come to ##crawl-dev for discussion, especially with new maps.

The plan:

1) Turn the Hive branch into a (single level) guaranteed, untimed portal vault (still called The Hive). It occurs exactly once in each game.

2) New mechanic: killer bee larvae will go towards bee food, i.e. honeycombs and royal jellies. When they reach a square with such an item, they spend a turn to eat it, thereby becoming killer bees. There should be a message for larvae eating (even when they eat outside the player's sight, like jelly slurping): "You hear a popping sound." or so.
There should be no additional generation of larvae. This means that if N food items and L larvae are initially generated, the player will get at least N-L food items. He'll get one more food item for each larva killed.
This mechanic might or might not be used for killer bee larvae outside of the portal vault.

3) For learning purposes, there should be some larvae together with food in the starting room. In this way, the player can observe the eating, the metamorphosis and the level sound -- no further explanation necessary.

4) It might be possible to re-use the existing Hive:2 maps, although I think new maps made from subvaults are better. The point is that the Hive portal vault should present a race, and that a player who is smart and willing to spend resources (mapping, teleport, speed, polymorph, digging/fire for melting wax walls etc.) should have an easier time. For most Hive:2 maps, I am not sure if they're ideal for this purpose.
This step can be hard -- ask in ##crawl-dev if you want. For example, we oculd start with a first, hand drawn, fixed map. Later on, we definitely will want more and/or random maps, so that the challenge is not known in advance.
For the purpose of the patch, you can make up a preliminary vault yourself,
set up something elaborate with subvaults, use an existing Hive:2 map or ask
on ##crawl-dev for a map.

5) Optional: A) Killer bees in sight of the queen and you go berserk. (This is an attempt to make otherwise boring fights more interesting -- there is not so much you can do with bees.)
B) If the queen is killed, the next eating larva becomes queen.
Additional Information
Tags No tags attached.
Attached Files ? file icon hive.des [^] (2,154 bytes) 2011-09-22 00:25 [Show Content]
? file icon 0001-Turn-hive-into-a-portal-vault-and-make-bees-more-int.patch [^] (11,019 bytes) 2011-10-04 17:47 [Show Content]
? file icon 0002-Add-more-vaults-and-entries-for-hive-and-make-it-not.patch [^] (32,852 bytes) 2011-10-08 06:05 [Show Content]

- Relationships

-  Notes
(0014430)
galehar (administrator)
2011-08-31 22:04

For easier vault design, I suggest that eggs are placed instead of larvas. The eggs have a timer which is based on the distance to the entrance (with some randomisation of course). When the egg hatches, it creates a larva which goes to eating the closest bee food.
It should be much simpler than having larvas at increasing distance to food the deeper you go in the vault (which would be artificial and cumbersome).
Also, the egg->larva->bee is great flavour.
(0014435)
BirdoPrey (reporter)
2011-09-01 05:54

Maybe instead of 'B) If the queen is killed, the next eating larva becomes queen.', the next larva that eats a royal jelly should become queen.
(0014438)
evilmike (developer)
2011-09-01 11:33

It might be worth making queen bees more dangerous. Right now they're only about twice as strong as a normal killer bee and die fast enough that it doesn't matter much. Having the "queen makes other bees go berserk" thing would help, but failing that she should at least get a boost to hp and damage.
(0014759)
mumra (developer)
2011-09-22 00:27

I've made a simple portal vault. The route through the hex combs should be randomised. Not sure if numbers of monsters and food are good - will need testing once the changes are in! (Note: I haven't tested it at all; sorry if there are any mistakes. Will need additional header lines and LUA to make it work for the portal anyway.)
(0015046)
GreatZebu (updater)
2011-10-04 17:50

I've attached a patch that disables the hive branch, adds a guaranteed portal to mumra's hive map on D12, allows queens to berserk workers, and lets larvae eat honeycombs or royal jelly to turn into killer bees. There is still a lot of work to be done on balancing and possible hive maps and entries, but this should take care of the basic functionality.
(0015091)
GreatZebu (updater)
2011-10-08 06:07

New patch--it adds the old hive entry vaults as hive portal entries and the old hive 2 fixed layouts as possible portal vault maps. It also makes the portal random from D11-16 instead of guaranteed.
(0015233)
Kate (developer)
2011-10-14 21:45

I tried this out a little, it seems to work nicely but I'm not sure that the old, sprawling Hive:2 maps are really appropriate for the portal vault Hive, personally. Maybe it'd be better to try this patch with just maps designed specifically for the race-for-the-food style portal (even if that is just one at the moment), and then if the other maps could possibly be re-purposed for the new Hive?
(0015358)
Cryptic (developer)
2011-10-20 21:08

I love the concept, I can't speak to how its implemented, but I would agree that some of the larger, older maps for hive might not be appropriate. I would think that limiting this just to the new layouts would be a good approach.
(0015385)
dpeg (administrator)
2011-10-21 03:25

Getting Hive as a random (non-guaranteed) portal vault for 0.10 would be awesome!
And yes, the old maps won't work very well. They should not be used.
(0015477)
Kate (developer)
2011-10-22 20:06

I've pushed this with just the one map so that we can try out the functionality, if it's good then we can ask for more vaults I imagine. Thanks to mumra and GreatZebu for the map and patch! :)
(0015489)
GreatZebu (updater)
2011-10-23 04:32

Great! I agree that the old maps shouldn't be used--Mumra's new map is an excellent start for the new vault.
(0015496)
Kate (developer)
2011-10-23 14:08

Re-opening - there were some save compatibility issues and kilobyte suggested holding off on the patch until after his level_type fixes are in trunk.
(0019204)
jeffqyzt (reporter)
2012-07-23 19:32

Does this still need to remain open? Didn't this happen already?
(0019221)
KiloByte (manager)
2012-07-24 02:52

Hive has since been removed, and no one seems to think restoring it as a portal vault would be a good idea -- a boring branch would be a boring portal vault.

I'd say, let's purge the enums, salvage a few vaults that can be repurposed, and remove the rest.

- Issue History
Date Modified Username Field Change
2011-08-29 18:17 dpeg New Issue
2011-08-31 22:04 galehar Note Added: 0014430
2011-09-01 05:54 BirdoPrey Note Added: 0014435
2011-09-01 11:33 evilmike Note Added: 0014438
2011-09-22 00:25 mumra File Added: hive.des
2011-09-22 00:27 mumra Note Added: 0014759
2011-10-04 17:47 GreatZebu File Added: 0001-Turn-hive-into-a-portal-vault-and-make-bees-more-int.patch
2011-10-04 17:50 GreatZebu Note Added: 0015046
2011-10-07 21:14 Kate Issue Monitored: Kate
2011-10-08 06:05 GreatZebu File Added: 0002-Add-more-vaults-and-entries-for-hive-and-make-it-not.patch
2011-10-08 06:07 GreatZebu Note Added: 0015091
2011-10-14 21:45 Kate Note Added: 0015233
2011-10-16 01:04 Kyrris Note Added: 0015248
2011-10-16 01:04 Kyrris Note Deleted: 0015248
2011-10-20 20:52 SamB Status new => feedback
2011-10-20 20:52 SamB Category Implementables => Patches
2011-10-20 21:08 Cryptic Note Added: 0015358
2011-10-21 03:25 dpeg Note Added: 0015385
2011-10-22 20:06 Kate Note Added: 0015477
2011-10-22 20:06 Kate Status feedback => resolved
2011-10-22 20:06 Kate Fixed in Branch => 0.10 development branch
2011-10-22 20:06 Kate Resolution open => done
2011-10-22 20:06 Kate Assigned To => Kate
2011-10-23 04:32 GreatZebu Note Added: 0015489
2011-10-23 14:06 Kate Status resolved => feedback
2011-10-23 14:06 Kate Resolution done => open
2011-10-23 14:08 Kate Note Added: 0015496
2011-10-23 14:08 Kate Status feedback => confirmed
2011-10-23 14:08 Kate Assigned To Kate =>
2012-07-23 19:32 jeffqyzt Note Added: 0019204
2012-07-24 02:52 KiloByte Note Added: 0019221
2012-08-28 22:21 Kate Status confirmed => resolved
2012-08-28 22:21 Kate Fixed in Branch 0.10 stable branch => 0.12 development branch
2012-08-28 22:21 Kate Resolution open => done
2012-08-28 22:21 Kate Assigned To => Kate
2012-08-28 22:21 Kate Issue End Monitor: Kate


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker