Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004453 [DCSS] Implementables minor N/A 2011-08-29 14:52 2013-03-14 00:40
Reporter galehar View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.10 ancient branch
Summary 0004453: spider branch end vaults
Description The Spider branch is shaping up and we'll start testing it in trunk soon. Branch end vaults are welcome.
Additional Information
Tags No tags attached.
Attached Files txt file icon Spider mini vaults.txt [^] (1,484 bytes) 2011-09-16 18:55 [Show Content]

- Relationships

-  Notes
KiloByte (manager)
2011-08-29 14:58

Actually, entries, welcomes and regular mid-branch vaults, big and small, are welcome too.
mumra (developer)
2011-08-29 18:01

Just wondering about some guidelines on the end vaults;

- Should end vaults feature Ghost Moths?
- Should layouts fit the "diagonal corridors" theme discussed on the wiki?
- I assume it should be comparable to e.g. Snake:5 in terms of difficulty and loot?
- Are there any size restrictions? (Would full-level layouts like Crypt ends be permissible or are you looking for smaller areas of map that will still have the level generated around them?)
- Is there any more information around on exactly what is required/planned for spiders nest (the wiki page hasn't been updated or commented on in a while, there are a lot of ideas there, but it's all a bit jumbled).

- What will the total monster set be for the initial implementation? Currently it seems like there aren't that many - compared to e.g. Snake which has a whole variety of snakes as well as the entire Naga race, or Shoals which has a huge range of beasts plus all the merfolk ... and both have their own uniques ... or will Spider be more like Slime with a fairly small variety of monsters a single boss Ghost Moth at the end?
KiloByte (manager)
2011-08-31 13:49

There's one big issue with branch ends here: we don't know what will happen with the Hellspider. It pretty thoroughly changes the final fight...

Thus, I guess it'd be safer to think about regular vaults only for now.
Guppyfry (reporter)
2011-09-16 18:56

I uploaded 4 mini vaults for spider. Let me know if they need edits.
evilmike (developer)
2011-09-17 10:24

I agree with kilobyte, designing branch ends is a bit premature at the moment. I'd just like to say, I'm willing to try making one or two spider branch endings though, when the time comes (which may be pretty soon - I don't know). Right now I'd say there are two things holding me back:

(a) The regular monsters don't seem good enough yet. I just mean general, _varied_ threats worthy of a branch ending. Aside from ghost moths, the only real ending-level threat I can see are emperor scorpions... which are melee-only. Without more ranged attackers, I fear the ending to spider will be a bit too easy unless ghost moths are used heavily (this will get old fast if every spider ending is like this). There are ideas on the wiki that will address this. I particularly like the idea of a web-spitting spider, even though I've never seen a real spider do anything like that. To clarify: I _do_ think it is possible to design a challenging ending using current monsters, I just think it would have to over-rely on ghost moths.

(b) The hellspider. If the hellspider turns out to be a difficult boss, then the spider ending vault itself could be made a bit lighter (no need for more than a couple high level enemies). But, there's still the matter of which enemies would work well in conjunction with the hellspider... and until the details are ironed out, there's no way to tell which enemies (and which arrangement of them) would work best. Therefore, there's no point in trying to design anything for it at the moment, beyond a simple placeholder vault.

- Issue History
Date Modified Username Field Change
2011-08-29 14:52 galehar New Issue
2011-08-29 14:58 KiloByte Note Added: 0014370
2011-08-29 18:01 mumra Note Added: 0014371
2011-08-31 13:49 KiloByte Note Added: 0014427
2011-09-16 18:55 Guppyfry File Added: Spider mini vaults.txt
2011-09-16 18:56 Guppyfry Note Added: 0014679
2011-09-17 10:24 evilmike Note Added: 0014687
2013-03-02 03:22 MarvinPA Status new => resolved
2013-03-02 03:22 MarvinPA Fixed in Branch => 0.12 development branch
2013-03-02 03:22 MarvinPA Resolution open => done
2013-03-02 03:22 MarvinPA Assigned To => MarvinPA
2013-03-14 00:40 galehar Status resolved => closed

Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker