Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004419 [DCSS] Bug Report minor have not tried 2011-08-20 13:16 2013-11-10 20:09
Reporter KiloByte View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0004419: changes to the stock config file don't apply to user files
Description Whenever there is a change in the base config file, actual configs used by people don't receive updates. This is especially bad for lua includes but affects other settings as well.

This leads to reports "Lua error: Can't find 'lua/pickup.lua'" and similar.

Thus, I believe any line in stock init.txt that is not commented out is an error.

Scalar options are simple to fix: they can be set by Crawl itself.

Lua includes, most of default ones implement config file options that don't differ from ones implemented in C++ at all. That's trapwalk, runrest_ignore, kills dump. A couple others implement keybound commands: autofight, gearset. All of them could be moved into an internal place (be it C++ or Lua) and executed unconditionally. The player can redefine them later.

wield.lua looks like a bizarre case of redundant methods. All of this logic should be in one place.

List options are a tricky issue, though. If we set some "force_more_message"s or "note_message"s, the player can't remove them later.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0004669resolvedKiloByte Scroll of Paper stash filter 

-  Notes
(0024372)
MarvinPA (developer)
2013-11-10 20:09

The default config is blank now.

- Issue History
Date Modified Username Field Change
2011-08-20 13:16 KiloByte New Issue
2011-10-02 13:51 KiloByte Relationship added has duplicate 0004669
2013-11-10 20:09 MarvinPA Note Added: 0024372
2013-11-10 20:09 MarvinPA Status new => resolved
2013-11-10 20:09 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-10 20:09 MarvinPA Resolution open => done
2013-11-10 20:09 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker