Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004351 [DCSS] Testing and Feedback minor N/A 2011-08-03 20:29 2013-11-11 15:26
Reporter dpeg View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.9 ancient branch
Summary 0004351: Tutorial feedback
Description I've played through the tutorials, and there is what I found. Not all items are serious, but some are.

1. The colour for marked squares (currently blue) should be changed to something much brigter, for example lightred.

2. The "You can move diagonally..." explanation misses the last line of the Numpad/vi-keys diagrams. This can be salvaged by moving it one line up, to the far right.

3. The first lesson ends with "Are you sure you want to leave the Dungeon? This will make you lose the game!". The other ones are okay.

4. Picking up could also mention 'g'. (Second lesson, quarterstaff.)

5. There is no explanation message when you increase a skill (killing the first dummy increases Dodging.)

6. Successfully doing a lesson was supposed to make the next lesson the default? Did this work at some point. (Currently, it does not.)

7. The tutorial was also supposed to only show the special tutorial help screen. (Currently, you have to press '??' to get there.

8. Lesson three: "This dagger was picked up automatically because you didn't have a sharp-edged_butchering tool yet. You know the drill: Wield it with w." This is wrong (the dagger is not picked up, which is correct).

9. Trying the scroll of enchant armour on the Ratskin cloak has no effect -- this may confuse players.

10. "There are some nasty monsters behind that door. Remember to use the items you just bought!" would be better as "There are some nasty monsters behind that door. Remember to use the items you hopefully just bought!"

11. Magic lesson: the player is supposed to buy the bad potions for Evaporate, but those potions just got more expensive!

12. Players are told that destroying spellbooks forgets spells. This is correct, but the more fringe use. At least mention scrolls of amnesia!
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0004082closedMarvinPA Tutorial example for dropping things when burdened doesn't work properly with new autopickup defaults 

-  Notes
(0014069)
MarvinPA (developer)
2011-08-04 00:50
edited on: 2011-08-04 00:54

Addressed some of these issues in e63c548aa1. Still to fix: 2? (not sure what the issue is here, it seems to work for me), 5, 6, 7, 9, 12. Also 0004082.

(0014082)
MarvinPA (developer)
2011-08-06 00:13

Pushed some more fixes. I'm not sure how to fix 6 or 7, and for 5, I'm not sure how best to briefly explain the skill system. Could probably come up with something but I'll leave it a bit in case someone wants to volunteer any ideas.
(0014083)
MarvinPA (developer)
2011-08-06 04:44

Oh hm, also having changed the tutorial pads to red instead of blue for better visibility in console means that either the tile for them needs to be changed or the messages need to be different between tiles/console.
(0014111)
KiloByte (manager)
2011-08-09 02:27

While red does look fugly (too close to blood), this sounds like a good idea.

I see you changed them to lightblue rather than blue or red, but that still looks pretty hard to see, at least on my monitor at work.

Changing the tile is a matter of literally one command in Gimp -- or two if we want to tone down the brightness of the middle layer (red is perceived as far brighter than blue by humans).
(0014194)
galehar (administrator)
2011-08-13 17:29

I've addressed 5 by using the skill raise hint mode message in tutorial (and I have updated it too). I've fixed 7. No idea what's wrong with 6, it works fine for me. I tested both console and tiles locally.
(0024385)
MarvinPA (developer)
2013-11-11 15:26

These have since been fixed.

- Issue History
Date Modified Username Field Change
2011-08-03 20:29 dpeg New Issue
2011-08-04 00:50 MarvinPA Note Added: 0014069
2011-08-04 00:51 MarvinPA Relationship added related to 0004082
2011-08-04 00:54 MarvinPA Note Edited: 0014069
2011-08-04 00:54 MarvinPA Note Edited: 0014069
2011-08-06 00:13 MarvinPA Note Added: 0014082
2011-08-06 04:44 MarvinPA Note Added: 0014083
2011-08-09 02:27 KiloByte Note Added: 0014111
2011-08-09 16:19 galehar Issue Monitored: galehar
2011-08-13 17:29 galehar Note Added: 0014194
2011-10-20 21:06 Cryptic Status new => assigned
2011-10-20 21:06 Cryptic Assigned To => evktalo
2011-10-25 00:25 galehar Issue End Monitor: galehar
2011-11-02 07:07 roctavian Note Added: 0015662
2011-11-02 07:09 roctavian Note Deleted: 0015662
2012-02-15 13:06 evktalo Assigned To evktalo =>
2012-02-15 13:06 evktalo Status assigned => acknowledged
2013-11-11 15:26 MarvinPA Note Added: 0024385
2013-11-11 15:26 MarvinPA Status acknowledged => resolved
2013-11-11 15:26 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-11 15:26 MarvinPA Resolution open => done
2013-11-11 15:26 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker