Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004234 [DCSS] Bug Report minor sometimes 2011-07-08 01:06 2011-09-06 11:21
Reporter KoboldLord View Status public  
Assigned To galehar
Priority normal Resolution done  
Status resolved   Product Branch 0.9 ancient branch
Summary 0004234: autoexplore tracks escaping item mimics
Description If a teleporting mimic picks an autopickup item as its new disguise, autoexplore will unerringly zero in on its new location even if the mimic ended up far away. This makes killing mimics more trivial than intended, since it cannot rest up to full health after the player shoots it.

This is easiest to reproduce in a fully explored level. It will fail to reproduce if the mimic randomly picks a non-autopickup disguise and/or if the mimic ends up in an unrevealed or inaccessible tile, but it appears to reproduce in every other case.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0014541)
galehar (administrator)
2011-09-06 11:21

No more teleporting and changing item mimics.

- Issue History
Date Modified Username Field Change
2011-07-08 01:06 KoboldLord New Issue
2011-09-06 11:21 galehar Note Added: 0014541
2011-09-06 11:21 galehar Status new => resolved
2011-09-06 11:21 galehar Fixed in Branch => 0.10 development branch
2011-09-06 11:21 galehar Resolution open => done
2011-09-06 11:21 galehar Assigned To => galehar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker