Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004187 [DCSS] Implementables minor N/A 2011-06-28 02:07 2013-08-21 15:55
Reporter dpeg View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0004187: Announce -cTele and Bazaar/Lab
Description From fnwc's https://crawl.develz.org/tavern/viewtopic.php?f=8&t=1855 [^]

Suppressed controlled teleports should be announced on the main screen (for example in the area where Sick, Pois etc. go): -cTele

Announced portal vaults (currently labyrinths and bazaars) should be indicated there as well: Lab, Bazaar (in their specific colours).
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Show-cTele-in-status-lights.patch [^] (3,794 bytes) 2011-07-02 04:16 [Show Content]
? file icon 0001-Mark-the-ring-of-teleport-control-useless-when-cTele.patch [^] (1,077 bytes) 2011-07-02 04:38 [Show Content]

- Relationships

-  Notes
(0013597)
golgepapaz (reporter)
2011-07-01 11:27

Working on this a question though,should I place the level messages;
on it's own line where the ZP is shown in zotdef (not shown in zot defense which make sense)
or in the status line (which doesn't make much sense because they are not status effects and probably make people think it's some kind of affect and confuse them)

I am leaning on the first option and would code as such atm.
(0013598)
KiloByte (manager)
2011-07-01 11:40

Lab might be ok since it lasts a short time and is a priority, but -cTele would do nothing but de-sentisize people to warning flags where they need them most -- in places with a hard fight.
(0013600)
golgepapaz (reporter)
2011-07-01 12:25

Are you saying not to include -cTele and no_map and just show the portals on the status line?
(0013603)
dpeg (administrator)
2011-07-01 14:21

This was discussed on ##crawl-dev (only briefly though). The lights for Bazaar and Labyrinths would be good to have in any case. Having -cTele could come with an option.
(0013604)
KiloByte (manager)
2011-07-01 15:58

golgepapaz: yeah, unlike the Lab timer ticking down on a level which requires an urgent action, like being hungry, -cTele is merely a property of the level which doesn't change and is thus merely a reminder of a spoiler -- spoiler you already received when entering the level.
(0013607)
reid (reporter)
2011-07-01 18:38
edited on: 2011-07-01 18:38

I can't imagine ever not being aware of whether there's a labyrinth or (non-permanent) bazaar on a level. As soon as one enters a level with an announced portal vault, finding it as quickly as possible becomes the focus of the level; if this weren't enough, there are also repeated reminders every 100 turns or so, and you get the announcement again if you leave and reenter the level. I certainly wouldn't find Lab or Bazaar status lights useful at all, and space in the status line area is at a premium already.

I like the idea of a -cTele status light though. It's true that the game tells you whether teleport control is blocked when you enter a level; but it's possible to spend thousands of turns on a level before this information is relevant, at which point you've probably forgotten. -cTele is not entirely spoiler information either, as middle zig levels may or may not have it. (Also, I never imagine that baileys could possibly have -cTele, but some of them do...) The -cTele status of a level can easily be a matter of life or death, for obvious reasons. If the -cTele status light was optional, I would certainly enable the option. In any event, it would be nice to have some way to check the -cTele status of a level without consulting spoilers or paging up through tons of messages, even if a status light is not necessarily the most appropriate place to put this information.

(0013608)
MarvinPA (developer)
2011-07-01 20:01

Scrolling through hundreds of messages to find out if your current Zig floor is non-cTele or not is really tedious, yeah. One alternative place to indicate it might be the % screen (red x instead of green + for the cTele line). That or a status light both sound good to me, anyway.
(0013610)
dpeg (administrator)
2011-07-01 22:51

Okay, if everyone shares his experience, here is mine: I would benefit from the Labyrinth/Bazaar status lights a lot. First of all, I happen to miss the announcement at times. And worse, I have a habit of saving immediately after I note it (so as to make it less likely to die in the expected rush). When I reload (which can be after several days), I have frequently forgotten the initial announcement.
(0013612)
galehar (administrator)
2011-07-01 23:33

I think -cTele should be in the status light and also in % screen. It's not directly a player status, but it's very important and many players have died because of they didn't realize they couldn't cTele.

We can also add a confirmation prompt when casting control teleport in a -cTele zone and mark the spell as useless (same for the ring). And fix the message, because it just tells you that you are in control while you really aren't.
(0013623)
golgepapaz (reporter)
2011-07-02 04:36
edited on: 2011-07-02 04:40

Patch added for -cTele

Replaces cTele if already cast.Marks the Control Teleport Spell as useless
and prevents casting with a message.I don't think a confirmation is necessary here because it's not really a choice.I can change it to generic your spell fizzles if you think we don't need to prevent people from shooting their own foot.
Also puts X in the resistances(%) overview

Edit:added patch for marking the ring useless.Although it doesn't seem like it's doing anything.

(0013625)
reid (reporter)
2011-07-02 06:07

Casting cTele on a -cTele level can be useful, though, if it's one which loses -cTele after a rune is picked up (Zot:5 would be the most obvious example except that the -cTele situation there has changed in trunk).
(0013626)
reid (reporter)
2011-07-02 06:11

Also, a status light for Lab/Bazaar is fine with me (it would be rare and for a short duration anyways). I don't think it should go on its own line, though, since I'd much rather have an extra line of monster list instead.
(0013632)
MarvinPA (developer)
2011-07-02 16:59

Preventing casting cTele on -cTele floors is definitely bad, yeah. Hells (and Tomb to a lesser extent) are other good examples of places where you could definitely want to cast it while cTele is still disabled.
(0013634)
golgepapaz (reporter)
2011-07-02 19:06

although I can't really comment how useful it would be able to cast cTele on -cTele level but from a gameplay perspective it should fail. There is a magical force that that prevents you from controlling your teleport, so your attempt to control it should also fail IMHO.Anyway I am not a decision maker so if I can get authoritative answer how it should be I can modify the code and be done with it...
(0013635)
MarvinPA (developer)
2011-07-02 19:27
edited on: 2011-07-02 19:28

Well, for now I pushed the patch but without making Control Teleport uncastable in -cTele areas, the status light and display on the % screen is awesome and much appreciated :)

I can see the point about preventing casting it in a non-cTele area, thematically. I guess if we decide to change that then that can be done fairly easily, I'd say just don't worry about it.

(0013666)
dpeg (administrator)
2011-07-04 01:37

Shall we resolve this?
(0013677)
MarvinPA (developer)
2011-07-04 17:52
edited on: 2011-07-04 17:54

Well there's nothing in trunk for Bazaars/Labyrinths, but this could be marked as resolved and they could become a seperate implementable if that's still a desired feature?

The -cTele stuff is great and fully functional, anyway (and there's an option to disable it now).

(0013682)
golgepapaz (reporter)
2011-07-05 14:13

well sorry for not updating but real life got in.
  
 I have Baz/labyrinth almost ready,What I am doing is iterating thorough the lua markers for the current level in the print status loop and check if any of them has the dst property equal to Labyrinth or Bazaar (I've added the property in Lab.des). This way if the portal expires while we still in the level
I believe the marker is removed and we can update the status accordingly without waiting another load level event.The downside is we have to check every turn for the markers.

 Second consideration is should I also tie this to show_spammy_spoilers option too as it's with the -cTele now.

 Any thoughts and advice is welcome
(0013683)
KiloByte (manager)
2011-07-05 14:33

That wouldn't work right since permanent bazaars are markers, too.

My suggestion: add a dlua function to turn on or off the marker and call it just once when the clock gets initialized/expires.

For show_spammy_spoilers, the presence of a Lab is not a static property of the place/monster type/etc, but something that depends only on the level in question.
(0013686)
golgepapaz (reporter)
2011-07-05 19:19

I was afraid it would come to this. To be frank, I don't know lua(for now) and have no idea how it interacts with the crawl so above suggestion does not really tell me anything at the moment. until I get a grasp of it this is on hold from my perspective ..
(0023813)
chris (updater)
2013-08-21 12:47

The -cTele status light has been in use for ages, and the new portal branch announcements should remind you of that certain something even in the scenario dpeg outlined. Any reason to keep this ticket idling around?
(0023821)
MarvinPA (developer)
2013-08-21 15:55

Probably not, resolving it.

- Issue History
Date Modified Username Field Change
2011-06-28 02:07 dpeg New Issue
2011-06-28 02:10 dpeg Summary Announce => Announce -cTele and Bazaar/Lab
2011-07-01 11:27 golgepapaz Note Added: 0013597
2011-07-01 11:40 KiloByte Note Added: 0013598
2011-07-01 12:25 golgepapaz Note Added: 0013600
2011-07-01 14:21 dpeg Note Added: 0013603
2011-07-01 15:58 KiloByte Note Added: 0013604
2011-07-01 18:38 reid Note Added: 0013607
2011-07-01 18:38 reid Note Edited: 0013607
2011-07-01 20:01 MarvinPA Note Added: 0013608
2011-07-01 22:51 dpeg Note Added: 0013610
2011-07-01 23:33 galehar Note Added: 0013612
2011-07-02 04:16 golgepapaz File Added: 0001-Show-cTele-in-status-lights.patch
2011-07-02 04:36 golgepapaz Note Added: 0013623
2011-07-02 04:38 golgepapaz File Added: 0001-Mark-the-ring-of-teleport-control-useless-when-cTele.patch
2011-07-02 04:40 golgepapaz Note Edited: 0013623
2011-07-02 06:07 reid Note Added: 0013625
2011-07-02 06:11 reid Note Added: 0013626
2011-07-02 16:59 MarvinPA Note Added: 0013632
2011-07-02 19:06 golgepapaz Note Added: 0013634
2011-07-02 19:27 MarvinPA Note Added: 0013635
2011-07-02 19:28 MarvinPA Note Edited: 0013635
2011-07-04 01:37 dpeg Note Added: 0013666
2011-07-04 17:52 MarvinPA Note Added: 0013677
2011-07-04 17:53 MarvinPA Note Edited: 0013677
2011-07-04 17:54 MarvinPA Note Edited: 0013677
2011-07-05 14:13 golgepapaz Note Added: 0013682
2011-07-05 14:33 KiloByte Note Added: 0013683
2011-07-05 19:19 golgepapaz Note Added: 0013686
2013-03-14 16:48 mumra Issue Monitored: mumra
2013-04-12 12:42 mumra Issue End Monitor: mumra
2013-04-12 12:42 mumra Issue Monitored: mumra
2013-08-21 12:47 chris Note Added: 0023813
2013-08-21 15:55 MarvinPA Note Added: 0023821
2013-08-21 15:55 MarvinPA Status new => resolved
2013-08-21 15:55 MarvinPA Fixed in Branch => 0.13 development branch
2013-08-21 15:55 MarvinPA Resolution open => done
2013-08-21 15:55 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker