Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004171 [DCSS] Bug Report minor always 2011-06-25 04:08 2014-05-09 20:56
Reporter MarvinPA View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status closed   Product Branch 0.9 ancient branch
Summary 0004171: Monster damage mirror can reflect player-mirrored damage
Description If a player worshipping Yredelemnul activates damage mirror against a monster (such as an unborn deep dwarf) that also has damage mirror active, the monster is able to reflect player-reflected damage back at the player. This means that whenever the unborn hurts you, you reflect the damage, and then it is reflected back again so you suffer twice as much damage as you should.

This is particularly fun when the unborn successfully casts agony on the player, resulting in instantly bringing the player to near-death from any value of health (it doesn't quite instantly kill the player, probably because of the unborn's damage shaving).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0013538)
KiloByte (manager)
2011-06-25 10:50

This works as designed -- any point of damage can be reflected as most once.

It's just interaction with agony being fun.
(0025918)
sgrunt (administrator)
2014-04-26 07:05

0.15-a0-251-g4f3d0c6 makes it so that mirrored damage can't itself be mirrored, i.e. as written above that any point of damage can only be reflected once.

- Issue History
Date Modified Username Field Change
2011-06-25 04:08 MarvinPA New Issue
2011-06-25 04:09 MarvinPA Description Updated
2011-06-25 04:10 MarvinPA Description Updated
2011-06-25 10:50 KiloByte Note Added: 0013538
2014-04-26 07:05 sgrunt Note Added: 0025918
2014-04-26 07:05 sgrunt Assigned To => sgrunt
2014-04-26 07:05 sgrunt Status new => resolved
2014-04-26 07:05 sgrunt Resolution open => done
2014-04-26 07:05 sgrunt Fixed in Branch => 0.15 development branch
2014-05-09 20:56 MarvinPA Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker