Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004047 [DCSS] Bug Report minor have not tried 2011-05-25 07:39 2014-03-27 07:02
Reporter b0rsuk View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.9 ancient branch
Summary 0004047: Rakshasa illusions can use items
Description A Rakshasa was zapping a wand of paralysis on me. Finally I killed the right one and received (received a lot of experience). The wand dropped in a doorway. An illusion that remained picked up the wand and proceeded to zap me with it.

If we assume they're just illusions, images with little or no material presence they should not be able to use wands. There are hints they are not completely illusionary - you can't walk through them. It would make revealing them trivial if you could.

One additional thing that might be done is making illusions disappear when their creator dies. Experienced players know when the real thing dies because of experience gain. So they won't be fooled, just annoyed. Alternatively, and I think this could be better, fix illusions to fool even experienced players: award experience only after rakshasa and all illusions die (similar to ballistomycete). This could be problematic, though - are illusions temporary ? What if player kills the real Rakshasa and flees ? What if he goes to another level ?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0013252)
OG17 (reporter)
2011-05-25 08:17

This would reveal clones through their refusal to pick up items, and I'm not sure what the problem is given how they interact with everything else (eg doors, traps, mindless allies). For the second suggestion, rakshasa clones are still technically a threat, while Mara's actually are - I'd think that destroying them when the original monster dies is an unneeded nerf and making players kill them all is an unneeded buff.
(0013255)
galehar (administrator)
2011-05-25 11:12

I changed the illusions to allow them to use items, to make them harder to distinguish.
Maybe we could print a different message when you kill an illusion.
(0013257)
KiloByte (manager)
2011-05-25 11:53

Since you get xp, and for Mara, also a milestone, having the illusions reveal themselves on death is a good idea.

Alternatives like not granting xp until all illusions expire would be inconsistent and quirky.

- Issue History
Date Modified Username Field Change
2011-05-25 07:39 b0rsuk New Issue
2011-05-25 08:17 OG17 Note Added: 0013252
2011-05-25 11:12 galehar Note Added: 0013255
2011-05-25 11:53 KiloByte Note Added: 0013257
2014-03-27 07:02 MarvinPA Status new => resolved
2014-03-27 07:02 MarvinPA Fixed in Branch => 0.14 development branch
2014-03-27 07:02 MarvinPA Resolution open => done
2014-03-27 07:02 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker