Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003904 [DCSS] Bug Report minor always 2011-05-01 16:53 2015-02-16 20:37
Reporter casmith789 View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.9 ancient branch
Summary 0003904: Corpse chopping does not work as intended if you are desecrating one
Description If you are chopping up a megabat corpse (first) and a kobold corpse under zin (the kobold corpse is not allowed) then after answering yes to whether you wish to chop up the megabat corpse it asks you whether you want to chop up the kobold corpse with a confirmation. When you say yes to this, it chops up the kobold corpse first and does not chop up the megabat corpse at all.

It should chop up the megabat corpse first surely before the kobold corpse.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0012922)
KiloByte (manager)
2011-05-01 21:05

It is caused by yesno() popping a delay off the stack, but since butcher prompts in general are currently broken ("You finish chopping the kobold corpse into pieces." "You stop butchering the corpse."), I'd wait for the bigger bug to be fixed first since my diagnosis might be wrong.
(0028489)
wheals (administrator)
2015-02-16 20:37

Fixed in 0.16-a0-4018-gd39c4f4.

(Better late than never, eh?)

- Issue History
Date Modified Username Field Change
2011-05-01 16:53 casmith789 New Issue
2011-05-01 21:05 KiloByte Note Added: 0012922
2013-03-19 19:29 mumra Issue Monitored: mumra
2015-02-16 20:37 wheals Note Added: 0028489
2015-02-16 20:37 wheals Status new => resolved
2015-02-16 20:37 wheals Fixed in Branch => 0.16 development branch
2015-02-16 20:37 wheals Resolution open => done
2015-02-16 20:37 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker