Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003878 [DCSS] Bug Report minor always 2011-04-25 19:30 2013-05-09 20:30
Reporter Eumel71 View Status public  
Assigned To mumra
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0003878: shiftes keys for running do not work
Description Running with Shift + Key (direction or numpad) does not work on Linux.

I tried:
- Ubuntu (Gnome) Maverick and Natty beta
- XUbuntu Natty beta
- LUbuntu Maverick

- Crawl 0.6.0 from Maverick repositories
- 0.7.1 from Natty repositiories
- 0.8.0 compiled from sources

- numlock on and off

Always exactly the same behavior - shift-key does the same as key alone, no running.

/ + key does work.

I cross checked with Windows XP - there shift-keys do work.

Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0002486new Shift-move and /-move only work with some movement keys 

-  Notes
(0012863)
KiloByte (manager)
2011-04-25 21:46

Not sure if this can be done -- I seem to get the key values as if Num Lock was on. I am knowledgeable about terminal output only though, perhaps someone who knows input can tell more.
(0012870)
Eumel71 (reporter)
2011-04-26 08:53

more testing done: I just compiled 0.8 with tiles on XUbuntu 11.04 beta - and the shifted keys for running did work.
But I prefer the console version...
(0022608)
mumra (developer)
2013-05-09 20:30

Closing, duplicate of 0002486

- Issue History
Date Modified Username Field Change
2011-04-25 19:30 Eumel71 New Issue
2011-04-25 21:46 KiloByte Note Added: 0012863
2011-04-26 08:53 Eumel71 Note Added: 0012870
2013-03-19 19:24 mumra Issue Monitored: mumra
2013-05-09 20:29 mumra Relationship added duplicate of 0002486
2013-05-09 20:30 mumra Note Added: 0022608
2013-05-09 20:30 mumra Status new => resolved
2013-05-09 20:30 mumra Fixed in Branch => 0.13 development branch
2013-05-09 20:30 mumra Resolution open => done
2013-05-09 20:30 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker