Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003759 [DCSS] Bug Report minor always 2011-04-08 07:18 2014-03-24 17:05
Reporter OG17 View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0003759: Yred's inconsistent with giving piety
Description Golems and gargoyles are rewarded, but dancing weapons and statues (and elementals?) are ignored. Roxanne should give piety too, as Yred would either consider her alive or group her in with other "artificial beings" as "neither truly alive nor subject to death or undeath."

Plant enemies should also give piety, though I don't know if there's a way of doing so that reasonably excludes firewood, as that'd be in-flavor but obnoxious.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0012386)
dolorous (updater)
2011-04-11 05:51

For the record, the rationale I used when first implementing artificial beings is as follows: Golems and gargoyles are animated and, furthermore, are constructs designed for that purpose, so they count as beings. Dancing weapons are also animated, but they don't count as beings because they're more objects than constructs. The same applies to elementals, since they're just embodiments of elemental forces rather than constructs. So, at least in my mind, dancing weapons and elementals are out.

On the other hand, I agree that statues could go either way, given cases like Roxanne; I didn't count them originally because it could lead to odd interactions with e.g. the Statue card.

Also, allowing piety gain for plant kills could be interesting, although I can't think of solutions at the moment to the problems you mention.
(0025691)
MarvinPA (developer)
2014-03-24 17:04

Statues are artificial now.

- Issue History
Date Modified Username Field Change
2011-04-08 07:18 OG17 New Issue
2011-04-11 05:51 dolorous Note Added: 0012386
2014-03-24 17:04 MarvinPA Note Added: 0025691
2014-03-24 17:04 MarvinPA Status new => resolved
2014-03-24 17:04 MarvinPA Fixed in Branch => 0.14 development branch
2014-03-24 17:04 MarvinPA Resolution open => done
2014-03-24 17:04 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker