Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000373 [DCSS] Implementables major have not tried 2010-01-09 21:27 2011-05-03 22:00
Reporter dpeg View Status public  
Assigned To galehar
Priority normal Resolution done  
Status resolved   Product Branch
Summary 0000373: make weapon swap for butchery implicit
Description From anym's [[SFTracker>2557220]],
https://sourceforge.net/tracker/?func=detail&aid=2557220&group_id=143991&atid=757516 [^]

"I find having to switch to a butchering tool for butchering (even when it's done automatically) annoying and as I don't see the benefits of it, I'd like to propose removing the need for that. It wastes turns, it causes message spam and characters using already underpowered non-edged weapons have to pay special attention not to attack with their butchering tool when the game didn't switch back and have to watch any temporary brands on their weapons evaporate when they switch away from it for the purpose of butchering. Admittedly, all minor points, sure, but they still bother me.

Note that I'm not proposing removing the actual requirement of having a safe-to-wield butchering tool and having a clear mind and your hands free in order to use it, but just that the actual use of the butchering tool is moved from main screen to the message area, i.e. in the form of "You start butchering the giant bat corpse with your dagger." After all, the game doesn't require you to wield potions before quaffing them or to remove your gloves before putting on rings, even though you won't be able to change rings when your gloves are cursed. If it's done implicitly there, I think it would be good to do it implicitly here as well.

Note that clawed characters can already butcher without having to switch from their wielded weapon and that it makes playing as unarmed or with clubs quite a bit more convenient IMHO. Actually, they can even butcher while wielding a cursed weapon, although whether that's a feature or a bug, I can't tell."
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Removed-need-for-sharp-weapon-when-butchering.patch [^] (5,772 bytes) 2011-04-17 20:23 [Show Content]
? file icon 0002-Removed-knives-from-the-game.patch [^] (9,718 bytes) 2011-04-28 14:55 [Show Content]

- Relationships

-  Notes
(0000963)
dpeg (administrator)
2010-01-09 21:52

I absolutely second this proposal (and the FR is full of support, too). In my opinion, this would solve elegantly quite a number of little problems. Recap:
The same restrictions as now apply. If met, start a multiturn action as now _without_ wielding the butchering weapon. Interruptions handled as now.

Some comments:

* [dpeg] There is a gameplay effect: butchering under stressful conditions will be a bit easier. This is not trivial, e.g. when a hostile monster is around that can animate corpses. One solution would be to increase the butchering duration by one turn.

* [Eino] What if the non-identified butchering tool turns out to be cursed? I
propose the curse status is identified, and if it's cursed, it's "magically teleported" to the hand. (Unfortunately the simplicity of the code just went down a notch.) It's a bit iffy, but still much smoother in my opinion than the current situation, and worth it.
Another solution (also Eino): simply allow cursed butchering tools, i.e. don't care. dpeg doesn't like this.
[Note: we have a similar problem with throwing weapons, which are also officially not touched. Whatever we decide upon, we should use the same solution for both.]

* [anym]: something to be addressed explicitly is distortion. Should you trigger distortion effects when butchering while wielding a blunt weapon of distortion and can you use an edged weapon of distortion for butchering without triggering
distortion effects? Personally, I'd lean towards not triggering effects in either case.
[dpeg] on this: there shouldn't be blunt weapons of distortion (or only restricted, e.g. randarts).

* [Eino]: Currently, you can't use a two-handed butchering weapon while wearing a shield. (It actually gives a misleading message, but that's minor).
One idea: Just allow the use. Respect the curse status of the shield (don't allow butcher with cursed shield & two-handed butcher tool). Adding a long delay to simulate shield switching is optional as far as I'm concerned - I don't find it interesting, whereas having the cursed shield might generate some interesting situations/choices.
Gloves and claws while not carrying a butchering tool. I don't see a straightforward solution here. Maybe keep the unwear-butcher-wear logic.
(0000966)
Twinge (updater)
2010-01-09 22:21

Why not go one step further and just assume all adventures carry a small knife with them? This was brought up before as an expansion of this idea, and it seems solid - and it also means you don't have to worry about any of the odd exceptions. Having to keep a knife or such around is merely a minor tedious thing any mace/staff/unarmed user straight-up *has* to do - it doesn't really add anything interesting or challenging to the game.

The knife item itself would then be removed at the same time this was put into effect. If you were wielding a cursed blunt weapon, you would still be unable to butcher corpses because you couldn't wield your auto-knife.
(0000970)
Vandal (updater)
2010-01-10 00:27

Hooray whenever this finishes being made real :D
(0009844)
dpeg (administrator)
2010-12-22 23:20

Twinge may be right. I wanted to keep knives, so as to make cursed blunt weapons something that matters, but his proposal does that all the same.
(0011161)
XuaXua (reporter)
2011-02-15 21:24

If I am cutting up and eating raw meat, why can't I just rip the body open with my teeth at the cost of extra time?

There is so much "to do" in the descriptions regarding eating RAW MEAT, and yet being a Wizard of Fire does nothing to help.
(0011263)
Eronarn (updater)
2011-02-21 01:51

Absolutely agreeing with Twinge on this.
(0011488)
effo (reporter)
2011-03-05 01:15

I agree with dpeg about keeping the dilemma of cursed blunt weapons, and I think that is really the only purpose served by having knives in the dungeon. For me, auto-knife would be the greatest improvement since auto-explore.
(0011498)
KiloByte (manager)
2011-03-06 08:15

Uhm no, that spot is already taken by auto-fight :p
(0011682)
Prezombie (reporter)
2011-03-18 18:27

I strongly agree with Twinge, but with one exception. The unlisted knife would only be unusable if both hands have a cursed item, meaning a two-handed blunt weapon, or a blunt weapon and a shield, both cursed.
(0012611)
galehar (administrator)
2011-04-16 00:31

Prezombie idea is interesting. It makes sense but the inability to butcher would be quite rare. Maybe too much? On the other hand, it would help Ash without wrecking the god flavour. For Ash worshippers, the new restriction would open up some more choices, especially with the new skill boost planned for 0.9.
(0012653)
galehar (administrator)
2011-04-18 00:20

Boot knife, really?
You can also get rid of gloved_butcher and the bladed weapon autopickup.
There's probably even more clean up to do, but that's a good start, thanks!
(0012659)
ghallberg (reporter)
2011-04-18 10:06

I couldn't figure out a good name!

Suggestions welcome, I'll keep working on it.

I liked gloved_butcher for flavor, trolls with giant claws can't wield the tiny pocket knife.

Gonna try to make sure that people with claws can't butcher with a cursed two-hander equipped as well, unless that is intended?
(0012662)
OG17 (reporter)
2011-04-18 13:54

Why would two-handed/shield behavior be changed along with this? Curses are generally trivial to begin with and Ash doesn't need the help any more than basic game functions need racial special cases. Either use Twinge's suggestion as written or entirely abandon blunt weapons blocking butchering - butchering through a one-handed blunt weapon makes the feature nearly pointless.

I don't know if cursed claws are intended or not but it should stay, it's an interesting side benefit to the mutation and is consistent with things like cursed consumable, evocable, and throwing use - a cursed weapon keeps you from using another weapon, including a knife, but doesn't prevent other actions.
(0012664)
galehar (administrator)
2011-04-18 14:10

Boot knife is going to be a problem for nagas... I suggest just knife for now. And change the message so that it says "You start butchering with your knife." instead of "you swap to knife for butchering". And no more "switching back" message either. Also, there are a few problems with messages if you're already empty handed or if you're wielding a cursed blunt weapon.

It makes sense that species with claws wouldn't bother carrying a knife. What about if you gain the claws mutation?

butchering with claws while holding a cursed two-handed blunt weapon seems definitely wrong to me. And if we allow butchering with claws with a cursed one-handed weapon, then we should also allow using the butchering knife with the off-hand as Prezombie suggested.
(0012665)
OG17 (reporter)
2011-04-18 14:29

There's already no difference between a cursed one-hander and two-hander and claws aren't wielded like a knife is. If you're going to do this you should also prevent eating/items/throwing/equipping/doors with "both" hands cursed, which I'd hope is an obviously bad idea.

Ignore races and have everyone butcher with claws when available. If you have claws and gloves, use the knife. If you have claws and gloves and a cursed blunt weapon, remove and return the gloves as currently.
(0012666)
dpeg (administrator)
2011-04-18 14:35

OG17: "curses are generally trivial to deal with" -- true, but it won't stay that way. This is why we should try to get a consistent solution already now.
(0012667)
OG17 (reporter)
2011-04-18 14:43
edited on: 2011-04-18 14:44

That's why I'm against adding inconsistencies that make curses more trivial, yes.

(0012672)
galehar (administrator)
2011-04-18 23:13

The inconsistency is being able to butcher with claws without unwielding your weapon in my opinion.
(0012673)
OG17 (reporter)
2011-04-18 23:51

How is that different from all the above actions you can do without unwielding your weapon, or anything else that has to do with curses in crawl? The only reason "off-hand" knives should be excluded is because blunt-weapon butchering would trivialize cursed blunt weapons, and this can be rationalized by mentally grouping knives with actual equippable weapons so that the curse prevents "wielding" it - claws don't trivialize things in the same manner and hands aren't blocked by curses.

Even so, this system could still work while barring cursed-item claws if you really want to lose the feature, but the way to do that is to simply not allow claw butchering if you're holding any cursed weapon - in this case, claws should follow the same rules as the knife and off-hand claws should be a non-issue. This idea of having both hands stuck to a cursed weapon goes against all the rest of the game's behavior.
(0012779)
shock (reporter)
2011-04-22 01:26

On the "auto-knife" option: can you attack with it? Some spellcasters don't start with a weapon. It's hard to imagine a knife sharp enough to butcher with that isn't useful in a fight.

From a flavor perspective, if I was not skilled in unarmed combat, I'd sure as hell be using my steak knife to defend myself.
(0012780)
XuaXua (reporter)
2011-04-22 02:15

Attacks with the knife should be treated as unarmed combat, in my opinion.
(0012783)
Wensleydale (updater)
2011-04-22 10:47

I think Twinge is on to something.

While we're at it, I propose we expand the list of tools that cannot be used for butchering to two-handed bladed weapons. This both makes curses a tad bit more severe and makes thematic sense as well.
(0012786)
galehar (administrator)
2011-04-22 11:44

The idea is that the butchering knife isn't a real item. If you're interrupted while butchering and decide to not switch back to your main weapon, you'll be empty handed.
(0012789)
KiloByte (manager)
2011-04-22 12:15

A problem: people will ask: "if I have a knife, why would I fight bare-handed?".
(0012809)
OG17 (reporter)
2011-04-22 22:20

It makes sense that a little utility knife can't hold up to combat. It's also not changing much, as the current knife item is comparable to unarmed combat at zero skill and very quickly falls behind.

For Wensley, taking butchering from two-handed blade weapons wouldn't add much but occasional annoyance. A character's going to be able to handle the occasional curse well before he's able to effectively use a two-hander, and later when there's a lot of curses there's nothing to butcher. And thematically, being able to butcher with a greatsword doesn't seem much worse than being able to use a longsword (or axe).
(0012812)
KiloByte (manager)
2011-04-22 23:09

A knife that is big and sharp enough to butcher with can't possibly make you worse in combat that even grandmaster-like unarmed skills. A butter knife is no good for butchering.
(0012813)
OG17 (reporter)
2011-04-23 00:01

Is that why high unarmed skill is a zillion times better than a knife?
(0012873)
ghallberg (reporter)
2011-04-26 21:01

I'm gonna focus on the butchering issues here, I may or may not get to changing cursed two-hander+claws, but I'll probably leave that for another patch set, if we decide to make changes to throwing and the other stuff mentioned by OG17.
(0012944)
galehar (administrator)
2011-05-03 22:00

Done.

- Issue History
Date Modified Username Field Change
2010-01-09 21:27 dpeg New Issue
2010-01-09 21:52 dpeg Note Added: 0000963
2010-01-09 22:21 Twinge Note Added: 0000966
2010-01-10 00:27 Vandal Note Added: 0000970
2010-01-12 09:48 evktalo Status new => acknowledged
2010-12-19 11:07 evktalo Severity minor => major
2010-12-19 11:07 evktalo Category FR: Interface Improvements => Implementables
2010-12-22 23:20 dpeg Note Added: 0009844
2011-02-15 21:24 XuaXua Note Added: 0011161
2011-02-21 01:51 Eronarn Note Added: 0011263
2011-03-05 01:15 effo Note Added: 0011488
2011-03-06 08:15 KiloByte Note Added: 0011498
2011-03-18 18:27 Prezombie Note Added: 0011682
2011-04-16 00:31 galehar Note Added: 0012611
2011-04-17 20:23 ghallberg File Added: 0001-Removed-need-for-sharp-weapon-when-butchering.patch
2011-04-18 00:20 galehar Note Added: 0012653
2011-04-18 10:06 ghallberg Note Added: 0012659
2011-04-18 13:54 OG17 Note Added: 0012662
2011-04-18 14:10 galehar Note Added: 0012664
2011-04-18 14:29 OG17 Note Added: 0012665
2011-04-18 14:35 dpeg Note Added: 0012666
2011-04-18 14:43 OG17 Note Added: 0012667
2011-04-18 14:44 OG17 Note Edited: 0012667
2011-04-18 23:13 galehar Note Added: 0012672
2011-04-18 23:51 OG17 Note Added: 0012673
2011-04-22 01:26 shock Note Added: 0012779
2011-04-22 02:15 XuaXua Note Added: 0012780
2011-04-22 10:47 Wensleydale Note Added: 0012783
2011-04-22 11:44 galehar Note Added: 0012786
2011-04-22 12:15 KiloByte Note Added: 0012789
2011-04-22 22:20 OG17 Note Added: 0012809
2011-04-22 23:09 KiloByte Note Added: 0012812
2011-04-23 00:01 OG17 Note Added: 0012813
2011-04-26 21:01 ghallberg Note Added: 0012873
2011-04-28 14:55 ghallberg File Added: 0002-Removed-knives-from-the-game.patch
2011-05-03 22:00 galehar Note Added: 0012944
2011-05-03 22:00 galehar Status acknowledged => resolved
2011-05-03 22:00 galehar Fixed in Branch => 0.9 development branch
2011-05-03 22:00 galehar Resolution open => done
2011-05-03 22:00 galehar Assigned To => galehar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker