Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003672 [DCSS] Bug Report minor always 2011-03-27 21:16 2015-02-02 18:23
Reporter turnerjer View Status public  
Assigned To elliptic
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0003672: Maprot in the Shoals with Ashenzari
Description I'm not sure if Ash is involved, but I'm getting a lot of maprot in the Shoals, which is playing hell with autoexplore.

Playing on CDO using Putty.
Additional Information
Tags No tags attached.
Attached Files png file icon maprot.png [^] (1,485,569 bytes) 2013-03-27 09:01

- Relationships
related to 0007847closedelliptic Autoexplore never finishes in Shoals. 

-  Notes
(0018799)
neil (administrator)
2012-07-07 18:34

Shoals autoexplore should be a lot better now. Reopen if there are still problems.
(0021822)
aleksil (reporter)
2013-03-26 07:27

This is still a problem with local tiles 0.12-a0-2859-g855fd10 and it's definitely related to Ashenzari's mapping ability. Looks like an explored tile gets overwritten by remote mapping if its current state doesn't match what's remembered.

Possible fix: don't overwrite explored floor/shallow water/deep water tiles in Shoals.
(0021834)
mumra (developer)
2013-03-26 22:30

I can't reproduce this at all in trunk, could you maybe post a before/after screenshot to show exactly what is happening with the issue?
(0021883)
aleksil (reporter)
2013-03-27 09:09

Sorry, I forgot to mention that the issue is most obvious with aquatic species who can explore the whole level uninterrupted by tides. Permaflight would probably work too.

I've uploaded a screenshot. Note the spots of magic-mapped maprot at the borders of shallow/deep water and water/land.

Steps to reproduce:
1) Start a game with a merfolk.
2) Worhsip Ashenzari.
3) Max out Ash piety.
4) Enter Shoals.
5) Explore the whole level.
6) Keep hitting autoexplore.
(0021891)
mumra (developer)
2013-03-27 15:19

(Possibly related) I've noticed that when mesmerised, blue squares show up well outside LOS (they disappear again when not mesmerised). There was an older bug report I was unable to reproduce as well to do with tiles / map / and possibly submerged creatures. Finally there is an issue where the endless ocean map edge can sometimes be seen using X before the level has been mapped.

There is definitely something buggy with Shoals and mapping in tiles.
(0021894)
mumra (developer)
2013-03-27 17:01

I can definitely reproduce this now with a merfolk. What's interesting is nothing happens when standing still and waiting for a long amount of time. Then as soon as I move, lots of squares become maprotted(/remapped?) (but not on the minimap) at boundaries where tides have been changing. Just walking around the map the squares gradually become rotted.
(0021923)
aleksil (reporter)
2013-03-27 23:48

Also reproducible in ASCII with a godless DDFi wearing boots of flying.

Scrolls of magic mapping function similarly, but with them it doesn't really feel like a bug.
(0028419)
elliptic (developer)
2015-02-02 18:23

Should be fixed now.

- Issue History
Date Modified Username Field Change
2011-03-27 21:16 turnerjer New Issue
2011-03-27 21:17 turnerjer Issue Monitored: turnerjer
2012-07-07 18:34 neil Note Added: 0018799
2012-07-07 18:34 neil Status new => resolved
2012-07-07 18:34 neil Fixed in Branch => 0.11 development branch
2012-07-07 18:34 neil Resolution open => done
2012-07-07 18:34 neil Assigned To => neil
2013-03-26 07:27 aleksil Note Added: 0021822
2013-03-26 22:30 mumra Note Added: 0021834
2013-03-27 09:01 aleksil File Added: maprot.png
2013-03-27 09:09 aleksil Note Added: 0021883
2013-03-27 15:16 mumra Assigned To neil =>
2013-03-27 15:16 mumra Status resolved => new
2013-03-27 15:16 mumra Resolution done => reopened
2013-03-27 15:19 mumra Note Added: 0021891
2013-03-27 17:01 mumra Note Added: 0021894
2013-03-27 23:48 aleksil Note Added: 0021923
2015-01-24 06:53 PleasingFungus Relationship added related to 0007847
2015-02-02 18:23 elliptic Note Added: 0028419
2015-02-02 18:23 elliptic Status new => resolved
2015-02-02 18:23 elliptic Fixed in Branch 0.11 ancient branch => 0.16 development branch
2015-02-02 18:23 elliptic Resolution reopened => done
2015-02-02 18:23 elliptic Assigned To => elliptic


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker