Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003668 [DCSS] Bug Report minor always 2011-03-26 23:51 2015-01-03 02:26
Reporter danr View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch stable branch
Summary 0003668: Crawl Tiles spans across dual monitors (vertically) (Linux Mint 10, Gnome, Nvidia Twinview)
Description I don't know if this is related to https://crawl.develz.org/mantis/view.php?id=3634, [^] but I'm having an issue on my (admittedly pretty unique) hardware setup.

On my system I have dual monitors running one above the other. OS is Linux Mint 10, Gnome desktop, using nVidia Twinview for the dual display configuration.

When I compile and run trunk tiles version, the Crawl window spans vertically across both windows, with the inventory "panel" in the bottom right of the bottom screen and everything else at the top.

I think it should probably just fill one screen.

I can't say what it would do on windows with vertical dual monitors, I don't have that setup.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0002178closedjpeg tiles open a big window that spans both screens on double-headed machines 
related to 0003634resolvedmumra Window size is bigger than screen on some monitors 
related to 0006722resolvedneil Cannot use fullscreen on dual monitors 

-  Notes
(0011825)
due (developer)
2011-03-26 23:56

Have you tried disabling full screen mode and setting the relevant width and height of an individual monitor in your .crawlrc?
(0011826)
due (developer)
2011-03-26 23:57

Also, can you please pay attention to which project you file bugs under? This belongs under "DCSS" -- "Wiki", etc, are internal projects for our wiki, bug tracker, etc, issues.
(0011852)
danr (reporter)
2011-03-28 08:11

Sorry, I hadn't noticed that I was under the wrong project.

I was able to make it work fine, I just set a max window height in tiles-options.txt or whatever it's called.

I think however that the game should by default not span multiple monitors, it should not be necessary to tweak config files to get a proper display on a vertical multi-monitor setup.
(0012457)
galehar (administrator)
2011-04-13 10:36

I think we need to upgrade to SDL 1.3 to properly support multiple monitors.
(0021514)
KiloByte (manager)
2013-03-15 04:32

galehar: there's no point in supporting them, as all what Crawl needs is a single window on a single monitor. It just needs to be positioned well, and not try to span multiples.

By allowing the window manager to manage the window, all these problems instantly disappear -- and we get niceties like maximizing without editing the config file, etc. Some initial work is on the "resize" branch, but sadly, it's so crashy it's unusable. Webtiles and console are resizable, so doing this to local tiles shouldn't be impossible without crashing.
(0028052)
dcampbell24 (reporter)
2014-12-11 02:54

I suggest replacing SDL_GetDesktopDisplayMode with SDL_GetCurrentDisplayMode. I tested this on my dual monitor setup and it works great. Below is a patch.


diff --git a/crawl-ref/source/windowmanager-sdl.cc b/crawl-ref/source/windowmanager-sdl.cc
index 622ae5c..4abcc4f 100644
--- a/crawl-ref/source/windowmanager-sdl.cc
+++ b/crawl-ref/source/windowmanager-sdl.cc
@@ -334,7 +334,7 @@ int SDLWrapper::init(coord_def *m_windowsz, int *densityNum, int *densityDen)
     }
 
     SDL_DisplayMode display_mode;
- SDL_GetDesktopDisplayMode(0, &display_mode);
+ SDL_GetCurrentDisplayMode(0, &display_mode);
 
     _desktop_width = display_mode.w;
     _desktop_height = display_mode.h;
(0028053)
dcampbell24 (reporter)
2014-12-11 03:05

Sorry for the hasty post because I seem to have missed something. This appears to be fixed already without the change on the master branch. So just direct people to the latest version.
(0028208)
neil (administrator)
2015-01-03 02:26
edited on: 2015-01-03 02:27

Should be fixed in trunk (0.16-a0-2558-g6680ffd) with the switch to SDL2, as dcampbell24 noticed.


- Issue History
Date Modified Username Field Change
2011-03-26 23:51 danr New Issue
2011-03-26 23:56 due Note Added: 0011825
2011-03-26 23:57 due Note Added: 0011826
2011-03-27 00:04 Napkin Project Wiki => DCSS
2011-03-28 08:11 danr Note Added: 0011852
2011-03-31 18:45 jpeg Relationship added has duplicate 0002178
2011-04-13 10:36 galehar Note Added: 0012457
2013-03-15 04:26 mumra Relationship added related to 0003634
2013-03-15 04:32 KiloByte Note Added: 0021514
2013-03-15 04:42 mumra Relationship added has duplicate 0006722
2013-03-16 18:04 neil Relationship deleted has duplicate 0006722
2013-03-16 18:05 neil Relationship added related to 0006722
2014-12-11 02:54 dcampbell24 Note Added: 0028052
2014-12-11 03:05 dcampbell24 Note Added: 0028053
2015-01-03 02:26 neil Note Added: 0028208
2015-01-03 02:26 neil Status new => resolved
2015-01-03 02:26 neil Fixed in Branch => 0.16 development branch
2015-01-03 02:26 neil Resolution open => done
2015-01-03 02:26 neil Assigned To => neil
2015-01-03 02:27 neil Note Edited: 0028208


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker