Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003346 [DCSS] Bug Report minor have not tried 2011-01-30 19:15 2014-12-04 21:36
Reporter Twilight View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0003346: Kobold's short sword of flaming not identified until it stopped flaming?
Description From the message history:

The kobold unwields an uncursed runed short sword.
(NOTE: The sword is unidentified at this point)
It stops flaming. The kobold wields a blowgun. The kobold shoots a poisoned needle. The poisoned needle hits you!
You are poisoned.
You see here a poisoned needle.
The kobold unwields an uncursed blowgun.
The kobold wields an uncursed short sword of flaming.
(NOTE: And now it is identified, even before the flame message below)
It bursts into flame!

Since the short sword was listed as a short sword of flaming when the kobold wielded it again, before it was described as bursting into flame, but it was unidentified before hand, it seems the "It stops flaming." message was what identified it as a short sword of flaming.

But if we can tell it is a short sword of flaming once it *stopped* flaming, shouldn't we be able to tell it's a short sword of flaming while it *is* still flaming?

In other words, if a monster is holding a flaming weapon, only identifying it as such once they unwield it and it ceases to flame seems really odd.

Does this seem counter-intuitive to anyone else?
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0000754resolvedmumra Monster weapon brands ID when unwielding 
has duplicate 0005252resolvedmumra Weapon of venom not id'ed on sight while wielded by an NPC 

-  Notes
(0010792)
jpeg (manager)
2011-01-30 20:10

This was mostly handled this way for consistency with the messages. Since I don't want to give away weapon brands on sight, I guess we should just remove the "stops flaming" message and identification on unwielding.
(0010803)
OG17 (reporter)
2011-01-31 01:51

0000754
(0027980)
PleasingFungus (administrator)
2014-12-04 21:36

Should be moot now.

- Issue History
Date Modified Username Field Change
2011-01-30 19:15 Twilight New Issue
2011-01-30 20:10 jpeg Note Added: 0010792
2011-01-31 01:51 OG17 Note Added: 0010803
2013-04-20 16:08 Medar Relationship added related to 0000754
2013-05-27 20:04 mumra Relationship replaced has duplicate 0000754
2013-05-27 20:15 mumra Relationship added has duplicate 0005252
2014-12-04 21:36 PleasingFungus Note Added: 0027980
2014-12-04 21:36 PleasingFungus Status new => resolved
2014-12-04 21:36 PleasingFungus Fixed in Branch => 0.16 development branch
2014-12-04 21:36 PleasingFungus Resolution open => done
2014-12-04 21:36 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker