Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003196 [DCSS] Bug Report minor have not tried 2011-01-12 15:59 2012-07-07 19:14
Reporter KiloByte View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0003196: new pig form means game over
Description In pig form, since commit 91d7a78a, you cannot read scrolls, quaff potions, zap wands, evoke items, put on rings (melded, ok) nor amulets, etc.

This effectively means game over for any character that doesn't happen to:
* fight unarmed
* have a randart amulet with tele/blink already worn
* worship Trog/Makhleb/high TSO and have a free square within two steps where a demon/bro/daeva might be placed

This is akin to paralysis, except that instead of a few turns, it lasts a few hundred. An AC character suddenly stripped of all armour will go down in several turns (just like a paralyzed EV one!), however, even EV chars have no chance to survive long against a horde of very uglies.

I'd change the restrictions to what felids can do, except for no rings and no speech (-> no spellcasting).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0010408)
OG17 (reporter)
2011-01-12 20:00

"This is akin to paralysis, except" is only accurate for "this is akin to paralysis, except you can move." If you're able to trivialize hogform by burning a tele scroll or whatever, what's the point of the effect and unique? If a player's really incapable of dealing with Kirke between basic positioning and hogform being faster than ugly things, he's always free to treat her like a legitimate high-threat monster and avoid her completely, or to just use ranged attacks/wands or the like - it's hardly necessary to stand next to her in a ball of ugly things.

Also, looking at release versions only, hogform allowed consumable use and item switching in .6, where Kirke had 7 kills for 746 deaths. .7 blocked consumables and switching and she had 33 kills for 1194 deaths. Likewise, .8 trunk versions have all of 4 kills for 406 deaths, and Kirke's only managed 57 kills for 3073 deaths overall. Game over?
(0010419)
KiloByte (manager)
2011-01-13 00:38

1. She very rarely casts this specific spell, and has a laughable chance to actually pass anyone's magic resistance. 2. Being faster has any effect only if you fight at a range, fighting a spamming summoner is mostly guaranteed to get you surrounded. 3. 0.7 had about no AC chars.

1. is of course a concern on its own.
(0010420)
OG17 (reporter)
2011-01-13 02:10

1. Kirke seems to cast the spell at least as often as she casts her other enchantments, and it even affects max-level normal-MR-race characters that are well above where a player would typically meet her. People aren't surviving because they're never being turned into hogs, they're surviving because being turned into a hog is anything but a death sentence.

2. Kirke seems to spit out three summons a turn at most - if she can do four, it's very rare - and if you're reasonably positioned, that's not going to instantly swamp you. You can even unload wands from behind her own summons - it's not like she can move or shoot through the things. If she's turning you into a hog, she has LOS, and if she has LOS, there's no reason for you to be surrounded. And if anyone's concerned about her slowing them before turning them into pigs (even if both are rare effects with laughable success!) and somehow getting overwhelmed, they can haste as a precaution like they'd do for any number of other uniques.

3. But .8 saw a flood of AC characters? Though an AC hog is no different from a straight spellcaster hog, save for having more HP.

In reality Kirke is almost toothless, never mind compared to uniques that cast actual paralysis.
(0010421)
KiloByte (manager)
2011-01-13 02:20

1. "you resist" x 100
2. Eh, "if she has LOS, there's no reason for you to be surrounded"?? It means precisely that she can summon around you, and if you're not a conjurer, she can summon on both sides (as non-Haunt summoning has range 2). Unlike porkalator, summons never fail so it's very likely you'll have some on both sides, no matter if in a corridor or in open.

If you don't do UC, it _is_ paralysis, except that it doesn't go away after a couple turns.
(0010422)
OG17 (reporter)
2011-01-13 04:14

Reality and Kilobyte aren't seeing eye-to-eye? Time to bludgeon the universe into submission!
(0010423)
minmay (reporter)
2011-01-13 04:23

Well, so damn much for not using the tracker for feedback.

It is a death sentence for most characters if you were close to Kirke, but you don't need to be close to Kirke. If you teleport and land next to a sphinx and you have crappy MR, your reaction should be to teleport again or something similar. Same thing for landing next to Kirke with crappy MR.
(0010424)
OG17 (reporter)
2011-01-13 04:51

If it was a death sentence she'd actually be killing people (to death).

General note, her four .8 victims not only demonstrate people turning into pigs, but also careless play and completely avoidable deaths.
(0010431)
elliptic (developer)
2011-01-13 11:07

I've never had trouble with Kirke casting hogform on me... you can just run away. I've had games in which I got hogformed by Kirke multiple times and ran away before eventually killing her. You don't want to let yourself get surrounded by uglies *anyway*, so if you are getting completely surrounded by uglies and then hogformed after that then you really have only yourself to blame. I'll also note that a lot of melee characters are already berserk at the time, meaning that you can do a pretty decent job finishing Kirke off even without unarmed skill.

Kirke isn't getting particularly many kills (or ikills), so why does anything need to be changed? Having hogform actually be potentially dangerous rather than just something to cause you to teleport away seems like a good thing to me, not something to be bug reported.
(0010442)
ledtim (reporter)
2011-01-13 18:48

I think pig form is fine in most cases, but for Chei worshipers, it's devastating since melded items keep ponderousness now.
(0010444)
OG17 (reporter)
2011-01-13 19:24

Also note that hogs can still use invocations.
(0018809)
neil (administrator)
2012-07-07 19:14

Pigs can now use scrolls and drink (0.11-a0-1080-ga94f099).

- Issue History
Date Modified Username Field Change
2011-01-12 15:59 KiloByte New Issue
2011-01-12 20:00 OG17 Note Added: 0010408
2011-01-13 00:38 KiloByte Note Added: 0010419
2011-01-13 02:10 OG17 Note Added: 0010420
2011-01-13 02:20 KiloByte Note Added: 0010421
2011-01-13 04:14 OG17 Note Added: 0010422
2011-01-13 04:23 minmay Note Added: 0010423
2011-01-13 04:51 OG17 Note Added: 0010424
2011-01-13 11:07 elliptic Note Added: 0010431
2011-01-13 18:48 ledtim Note Added: 0010442
2011-01-13 18:48 ledtim Issue Monitored: ledtim
2011-01-13 19:24 OG17 Note Added: 0010444
2012-07-07 19:14 neil Note Added: 0018809
2012-07-07 19:14 neil Status new => resolved
2012-07-07 19:14 neil Fixed in Branch => 0.11 development branch
2012-07-07 19:14 neil Resolution open => done
2012-07-07 19:14 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker