Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000313 [DCSS] FR: Other minor N/A 2010-01-03 18:02 2013-11-10 19:47
Reporter TGW View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch
Summary 0000313: Reset monster memory on leaving the level
Description As far as I can tell, monsters don't actually forget where you are no matter how many stairs you can take. In the case of having a lot of guys following you, this makes escaping with stairs extremely silly because they're back on your ass the moment you enter the level again.

In the same way teleportation makes enemies forget where you are, leaving the level and taking stairs back should.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000793)
rob (developer)
2010-01-03 18:26

Changed the summary to be more clear -- I believe what teleporting does nowadays is reset monsters' foe memory. I support this (in some form).
(0000809)
jpeg (manager)
2010-01-04 14:01

I disagree and think this would lead to stairscumming.

Currently, monsters do forget about you if you stay away from the level far a long enough time, and they'll disperse when the level is eventually loaded again. Both of these parameters (monster memory and dispersal distance) could be tweaked but I see no reason to make using stairs make monsters forget you.

Doing the same for teleportation is necessary because monsters would otherwise swarm towards your *new* position, which is not an issue if you are no longer on the level.
(0000840)
dpeg (administrator)
2010-01-05 10:12

Seconding jpeg.

TGW: do you mean that monsters know where you are if you leave the level by stair A and enter again using stair B? That would be a bug similar to the teleportation bug. But monsters awaiting you when you come back on stair A is intended behaviour.
(0000860)
TGW (reporter)
2010-01-05 18:32

I mean different stairs.
(0024367)
MarvinPA (developer)
2013-11-10 19:47

Closing some old FRs (also monsters do now forget you if you take a different staircase back to the level).

- Issue History
Date Modified Username Field Change
2010-01-03 18:02 TGW New Issue
2010-01-03 18:26 rob Note Added: 0000793
2010-01-03 18:26 rob Summary Reset stealth on leaving the level => Reset monster memory on leaving the level
2010-01-04 14:01 jpeg Note Added: 0000809
2010-01-05 10:12 dpeg Note Added: 0000840
2010-01-05 18:32 TGW Note Added: 0000860
2013-11-10 19:47 MarvinPA Note Added: 0024367
2013-11-10 19:47 MarvinPA Status new => resolved
2013-11-10 19:47 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-10 19:47 MarvinPA Resolution open => done
2013-11-10 19:47 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker