Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002885 [DCSS] Bug Report minor always 2010-11-29 02:51 2015-05-18 13:38
Reporter Lord Fell View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.7 ancient branch
Summary 0002885: Numerical Item Drop Fail
Description I'm new to Stone Soup, and was playing the tutorial. At a point in the process, the player receives a stack of 50 Meat Rations, and is given instructions to drop 10 of them to become unencumbered.

Type: D (to drop) then "10" to select ten of the item...
None of that works. I also attempted to 10 Drop item. I checked number lock, used both key pad and the top numerical keys. Support to drop a partial amount of a stack of an item just doesn't seem to be enabled. Definitely not in the way the tutorial indicates that it should work.

I am using Win XP.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009448)
MrMisterMonkey (reporter)
2010-11-29 03:14

d is drop not D
(0009452)
Lord Fell (reporter)
2010-11-29 04:27

Actually, yes, I was aware of that.

Once I enter the drop screen, I seem to have the option to drop all of the stack, or to abort the drop. This may be a documentation issue.
(0009454)
galehar (administrator)
2010-11-29 09:53

The documentation is correct. It says:

You can also drop e.g. only 10, by typing d, 10 and then selecting the meat rations.

You have to type the number before selecting the item. If your meat rations is in the k slot, type d10k
(0009455)
jpeg (manager)
2010-11-29 10:05

Looks fine to me, too. Still, if you were confused the text could obviously be phrased better. Now that you know how it works, do you have any suggestions for improvement?
(0009460)
MarvinPA (developer)
2010-11-29 14:17

Personally I think having no feedback at all for what number of things you're dropping is the biggest annoyance/interface issue (nothing happens when you type a number, and when you then select an item it's highlighted with # which still doesn't tell you how many you're going to drop).

I'd like it if the "Drop what? (Press _ for help.)" line at the top changed to read "Drop x of what?" or something similar if you entered a number x, although I don't know if that'd solve the particular problem here?
(0009468)
Lord Fell (reporter)
2010-11-29 17:12

So, yes... this is actually a documentation fail.

I messed around with this a bit.
Merely typing: d10k
(as per the example) does NOTHING. I mashed some more keys, didn't seem to accomplish anything, and then [esc] out of the drop interface. Tried again, nothing, tried, nothing...

In addition to not having anywhere to indicate that you've selected (x) number of an item, the documentation doesn't indicate how to complete the drop. I happened to try hitting Enter, which worked... but coming from playing other Roguelikes, there's really nothing intuitive about the drop menu that would suggest that's the way to do it.
(0009469)
dpeg (administrator)
2010-11-29 17:24

This is not a major bug; adjusted the tracker.

While I agree that dropping a quantity has always been slightly tricky (i.e. produced a fair share of questions), the last report by the OP is at least misleading.

"Merely typing: d10k does NOTHING."
This is wrong. The item indicator changes from - (or +) to #. That's something.

"...the documentation doesn't indicate how to complete the drop."
Whenever you're dropping (or picking up for that matter) something, you use keys to select options. You have used Enter to confirm selection and proceed to pick up/drop items all the time. Whether you're dropping full or partial stacks does not matter at all.

"...there's really nothing intuitive about the drop menu that would suggest that's the way to do it."
This is bordering on trolling.

I would just close this issue, but there's one off chance that might have got the OP justifiably confused: are you using the drop_mode=single option (which is not default)?
(0009471)
OG17 (reporter)
2010-11-29 18:03

Marvin's suggestion would make this a lot less "slightly tricky."
(0009473)
dpeg (administrator)
2010-11-29 18:09

OG17: Yes, the interface can be improved. But the situation is not as bad as the OP claims. In particular, the topic is not as urgent as stated.
(0009483)
Lord Fell (reporter)
2010-11-29 23:16

What I thought was a major bug, does turn out to be a documentation thing, so agreed. This deserves a downgrade.

I was not at all trying to Troll. What was coming across was the frustration of being unable to navigate an interface in a tutorial. Most of the posters here are long time players; I picked DCSS up over the weekend, played a few fast games, decided that enough of the game was different from the roguelikes that I'm used to, that I'd better go through the tutotial. The documentation from the tutorial operates on the assumption that I know how the menus in DCSS already work; that's not the case at all. That's why I needed the tutorial.

I did not change any of my options (that I'm aware of). I don't think I'm using drop_mode=single.
(0009484)
Lord Fell (reporter)
2010-11-29 23:22

"Whenever you're dropping (or picking up for that matter) something, you use keys to select options. You have used Enter to confirm selection and proceed to pick up/drop items all the time. Whether you're dropping full or partial stacks does not matter at all."
-This is not true.
When I encounter an item on the floor, I seem to automatically pick up consumables. Other items, I must "g"et. When there is a stack of items, the interface asks me: do you want to pick up (item)? and I answer yes or no.
(0009488)
dpeg (administrator)
2010-11-30 09:24

Lord Fell: I see, you are referring to the query list when picking up. But you may have seen that the full menus (where you have to confirm with Enter) come up in two related places: if you turn the pickup query list into a menu by pressing , or g (not sure you've done that yet, but it's indicated and quite useful for large piles) and whenever you're dropping (since you said you didn't change the option).

We are trying to make the game newbie friendly. Please answer these questions:
1. If you press 'd' in order to drop stuff. Do you select items and confirm with Enter?
2. If you press 'd', then a number (let's say '5') and then a stackable item (say some darts), is there a change in the item's line?

The effect may be too subtle to be noted unless you already know about it.
(0009489)
jpeg (manager)
2010-11-30 10:03

Well, it would be nice if there was an indication how many of an item you selected. Marvin's suggestion sounds good.

If there never is any indication that where multiple selection is allowed, the choice has to be confirmed with Enter, we might want to add a note about that somewhere.
(0009493)
Lord Fell (reporter)
2010-11-30 17:01

I'm posting this to remind myself to check this thread, and then experiment with "," and "d" menus when I have time, so I can post results.
(0011261)
Saxman_72 (reporter)
2011-02-20 14:38

I came to this thread because I had the exact same problem as Lord Fell. I probably spent about 20 minutes trying to figure out what was wrong with dropping before I did a search and found this thread.

By including feedback on the screen when you type in the number to be dropped AND including the step about needing to confirm with Enter, I'm certain you would save many newbies a lot of frustration over something which really should not be. :)
(0029063)
MarvinPA (developer)
2015-05-18 13:38

Closing in favour of 0008328 (which is possibly obsolete now too).

- Issue History
Date Modified Username Field Change
2010-11-29 02:51 Lord Fell New Issue
2010-11-29 03:14 MrMisterMonkey Note Added: 0009448
2010-11-29 04:27 Lord Fell Note Added: 0009452
2010-11-29 09:53 galehar Note Added: 0009454
2010-11-29 10:05 jpeg Note Added: 0009455
2010-11-29 14:17 MarvinPA Note Added: 0009460
2010-11-29 17:12 Lord Fell Note Added: 0009468
2010-11-29 17:24 dpeg Note Added: 0009469
2010-11-29 17:24 dpeg Severity major => minor
2010-11-29 18:03 OG17 Note Added: 0009471
2010-11-29 18:09 dpeg Note Added: 0009473
2010-11-29 23:16 Lord Fell Note Added: 0009483
2010-11-29 23:22 Lord Fell Note Added: 0009484
2010-11-30 09:24 dpeg Note Added: 0009488
2010-11-30 10:03 jpeg Note Added: 0009489
2010-11-30 17:01 Lord Fell Note Added: 0009493
2011-02-20 14:38 Saxman_72 Note Added: 0011261
2011-10-20 21:06 Cryptic Status new => assigned
2011-10-20 21:06 Cryptic Assigned To => evktalo
2012-02-15 13:17 evktalo Assigned To evktalo =>
2012-02-15 13:17 evktalo Status assigned => acknowledged
2013-04-08 21:52 mumra Issue Monitored: mumra
2015-05-18 13:38 MarvinPA Note Added: 0029063
2015-05-18 13:38 MarvinPA Status acknowledged => resolved
2015-05-18 13:38 MarvinPA Fixed in Branch => 0.16 pre-release branch
2015-05-18 13:38 MarvinPA Resolution open => done
2015-05-18 13:38 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker