Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002680 [DCSS] Implementables feature have not tried 2010-10-05 13:34 2016-11-17 19:15
Reporter dpeg View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.9 ancient branch
Summary 0002680: Interface improvements
Description DCSS is quite good at user interface. But much more could be done. Patches improving the interface are always welcome. You can find a rather long list at https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables [^]

Some issues are less clear-cut than others. You can stop by at ##crawl-dev and ask about the usefulness of certain ideas.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-running-follows-corridors.patch [^] (10,601 bytes) 2011-10-09 15:36 [Show Content]

- Relationships

-  Notes
(0014250)
blueDave (reporter)
2011-08-19 06:16

Patch 4415 uploaded for "Improve on shop modes".
(0015003)
Wensleydale (updater)
2011-10-03 00:44

Bumped, at dpeg's request (if only there were a way to sticky mantis issues)
(0015053)
kittel (reporter)
2011-10-05 18:53

Small patch uploaded for "Toggle for showing weights".

A few notes:

Weights can now also be shown even when Options.tile_menu_icons==true, which is achieved by ellision of long item descriptions (only artifacts with many inscriptions affected). Perhaps there is a better way to figure out the max text width in multi-column mode than what I did.

And weights can also be shown in the inventory view, not just in pickup/drop menu.

I tried to test it in both console mode and tile mode with Options.tile_menu_icons either true or false, and it seems ok to me.

Oh, and the Options.show_inventory_weights is still there for now. Its only effect will now be to determine the default value upon startup.

Cheers,
Thomas
(0015062)
kittel (reporter)
2011-10-06 08:34

Another patch for "Easier quantity selection" uploaded.

(to be applied on top of the patch for "Toggle for showing weights" due to my lack of git ninja tricks)

It adds the new burdened state at the top of both drop and pickup menus, including showing the new weights exactly in the pickup menu (previously the "123>456/789 aum" stuff was only shown in the drop menu).

Hope it is useful.

Cheers,
Thomas
(0015065)
kittel (reporter)
2011-10-06 15:22

Another patch for "Toggle between locations and items" uploaded.

I chose '-' as shortcut since it seemed convenient, and I had to reformat the title line a bit to fit in 80 chars.

Cheers,
Thomas
(0015083)
galehar (administrator)
2011-10-07 23:16

They seem to be really good, thanks!
I haven't commited them yet because I need to take a closer look first, but I will.
You seem to hate whitespaces ;)
Please, have a look at docs/develop/coding_conventions.txt
Use spaces instead of tabs and use them around operators too.
(0015085)
KiloByte (manager)
2011-10-08 00:03

I fail to see a reason for toggling inventory weights, though.

What would be the point in ever disabling them?
(0015092)
kittel (reporter)
2011-10-08 09:54

Happy to hear that they are useful! Ok, I'll reread the coding conventions and try to figure out how to teach my emacs to stop adding tabs everywhere :-)

I think the main reason to toggle inventory weights is in case of tiles 2-column display with icons: Artifacts with many inscriptions can have several of them hidden by the weights display, so being able to quickly toggle them off and on can be useful in that case (I agree though that it would be better to have the weights display enabled by default).
(0015095)
jpeg (manager)
2011-10-08 11:43

> I fail to see a reason for toggling inventory weights, though.
>
> What would be the point in ever disabling them?

The point would be not to overwhelm new players with numbers that are not immediately important. I'd prefer if the option defaulted to off and hints mode pointed out its existence at an appropriate time.

(Also, this would be much less of an issue if the options were available in-game.)
(0015111)
kittel (reporter)
2011-10-09 15:36

Uploaded a patch for "Running could follow corridors".

Hopefully I have observed all coding conventions this time :-)
(0015226)
kittel (reporter)
2011-10-14 10:57

Just tested that the "running follow corridors" patch still applies cleanly against latest trunk. I also noticed that when on a path in a forest the code does not work. For that to work one has to consider trees as walls as well, which I don't know if people want or not. One way to do this is to add in _base_feat_type(..) in travel.cc the lines:

    if ( you.religion != GOD_FEDHAS
         && (grid == DNGN_TREE || grid == DNGN_SWAMP_TREE) )
        return (DNGN_ROCK_WALL);

Cheers,
Thomas
(0015478)
MarvinPA (developer)
2011-10-22 20:16

Assigning to galehar since he said he was taking a look at them. Feel free to unassign if you're not doing and want someone else to push these. :P

Also, to kittel: could you possibly put future patches in their own new Mantis item, and link to them from the Implementable? It'd make things a bit more organised and easier to close items once the relevant patch is in-game. (And thanks for the patches, of course!).
(0015573)
MarvinPA (developer)
2011-10-27 15:45
edited on: 2011-10-27 15:45

Pushed the toggle between stacks/locations while searching. Displaying burden state when picking up/dropping seems a bit trickier - I'm not sure it's feasible to get weight, burden status, the help screen prompt, the number of pages, and the number of items selected all on one line at the default termsize (which the pickup prompt is trying to do).

(0015586)
MarvinPA (developer)
2011-10-28 21:55
edited on: 2011-10-28 21:56

Okay, reworked some things and pushed the burden state patch, it should fit on one line now (with Ctrl-W toggling between displaying the burden status by name or just the weight numbers).

(0027054)
PleasingFungus (administrator)
2014-08-20 06:51

...do we really need a generic ticket for "all interface improvements?"

Some of the patches might still be worth applying - e.g. 'running could follow corridors' - but I suspect they're rather rotted by now.
(0031266)
MarvinPA (developer)
2016-11-17 19:14

Closing this as per PF's previous comment - probably better to put up more specific implementables instead of having a general and probably out-of-date one.

- Issue History
Date Modified Username Field Change
2010-10-05 13:34 dpeg New Issue
2010-10-05 18:18 evktalo Description Updated
2011-08-19 06:16 blueDave Note Added: 0014250
2011-10-03 00:44 Wensleydale Note Added: 0015003
2011-10-05 18:46 kittel File Added: 0001-Ctrl-W-toggles-display-of-weights.patch
2011-10-05 18:53 kittel Note Added: 0015053
2011-10-06 08:31 kittel File Added: 0001-drop-and-pickup-menu-display-new-burden-state.patch
2011-10-06 08:34 kittel Note Added: 0015062
2011-10-06 15:21 kittel File Added: 0001-Toggle-between-locations-and-items.patch
2011-10-06 15:22 kittel Note Added: 0015065
2011-10-06 19:01 MarvinPA Issue Monitored: MarvinPA
2011-10-07 23:16 galehar Note Added: 0015083
2011-10-07 23:16 galehar Issue Monitored: galehar
2011-10-08 00:03 KiloByte Note Added: 0015085
2011-10-08 09:54 kittel Note Added: 0015092
2011-10-08 11:43 jpeg Note Added: 0015095
2011-10-09 15:36 kittel File Added: 0001-running-follows-corridors.patch
2011-10-09 15:36 kittel Note Added: 0015111
2011-10-14 10:57 kittel Note Added: 0015226
2011-10-22 20:16 MarvinPA Note Added: 0015478
2011-10-22 20:16 MarvinPA Assigned To => galehar
2011-10-22 20:16 MarvinPA Status new => assigned
2011-10-25 00:28 galehar Assigned To galehar =>
2011-10-25 00:28 galehar Status assigned => acknowledged
2011-10-27 15:45 MarvinPA Note Added: 0015573
2011-10-27 15:45 MarvinPA Note Edited: 0015573
2011-10-28 21:55 MarvinPA Note Added: 0015586
2011-10-28 21:56 MarvinPA Note Edited: 0015586
2013-01-17 20:08 MarvinPA Issue End Monitor: MarvinPA
2014-08-20 06:51 PleasingFungus Note Added: 0027054
2015-02-03 10:25 chris File Deleted: 0001-Ctrl-W-toggles-display-of-weights.patch
2015-02-03 10:25 chris File Deleted: 0001-drop-and-pickup-menu-display-new-burden-state.patch
2015-02-03 10:26 chris File Deleted: 0001-Toggle-between-locations-and-items.patch
2016-11-17 19:14 MarvinPA Note Added: 0031266
2016-11-17 19:14 MarvinPA Status acknowledged => resolved
2016-11-17 19:14 MarvinPA Fixed in Branch => 0.20 development branch
2016-11-17 19:14 MarvinPA Resolution open => done
2016-11-17 19:14 MarvinPA Assigned To => MarvinPA
2016-11-17 19:15 MarvinPA Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker