Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002650 [DCSS] Bug Report minor always 2010-09-27 01:41 2015-02-14 22:36
Reporter hayenne View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.8 ancient branch
Summary 0002650: Animating skeleton from ugly thing corpse fails
Description You see here an ugly thing corpse.
You attempt to give life to the dead...
Before your eyes, flesh is ripped from the corpse!

Things that are here:
2 chunks of ugly thing flesh; an ugly thing skeleton

---
Reproduced with very ugly thing and shapeshifter corpses. General issue with mutagenic corpses?
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0003090closedjpeg Ugly thing corpes can't be zombified, and it's unclear why 
related to 0001842resolvedKiloByte Note somewhere that trapdoor spiders are not zombifyable 

-  Notes
(0008802)
doy (developer)
2010-09-27 01:49

No, the issue is just with monsters that have corpses but can't be turned into zombies or skeletons - I believe this is just (very) ugly things at the moment, due to a quirk of their implementation (I can't reproduce this issue with shapeshifter corpses).
(0008803)
dolorous (updater)
2010-09-27 01:52

The issue is that ugly things can't be zombified. Animate Skeleton could do nothing for such corpses, but, as it is, the current behavior of reliably producing a skeleton could be useful for casters of Bone Shards.
(0008804)
MrMisterMonkey (reporter)
2010-09-27 02:32

Doesn't Corpse Rot also reliably produce skeletons from appropriate corpses?
(0008806)
dolorous (updater)
2010-09-27 06:15

doy:
It can't be reproduced with shapeshifter corpses because shapeshifters don't have skeletons. Hell hound corpses are another working example.

MrMisterMonkey:
Once the miasma cloud disappears, yes.
(0008809)
hayenne (reporter)
2010-09-27 11:38

Does not reproduce with shapeshifters, right.

Could not figure why it did not animate ugly thing skeleton though - it's left on the ground.
(0008813)
dolorous (updater)
2010-09-27 15:58

Monsters that can't be zombified can't have their corpses or their skeletons animated.
(0008817)
hayenne (reporter)
2010-09-27 23:37

I see.

It's not clear from spell description and actually raises next question: what monsters can be zombified?

--
Animate Skeleton

This spell raises an inert skeleton to a state of unlife, even if that skeleton
is still encased in flesh! Note that skeletons are incapable of leaving the
level they were created on.
(0008825)
GameKnut (reporter)
2010-09-28 18:44

Perhaps a line could be added to the description of unraiseable monsters (or their corpses). "This corpse is unsuitable for reanimation", or "This body lacks a skeleton", or something to that effect.

Ideally, such a line would only appear in the description if you had some means of raising the dead...
(0023899)
BlackSheep (reporter)
2013-08-28 19:58

Ugly thing corpses/skeletons can now be animated.

- Issue History
Date Modified Username Field Change
2010-09-27 01:41 hayenne New Issue
2010-09-27 01:49 doy Note Added: 0008802
2010-09-27 01:52 dolorous Note Added: 0008803
2010-09-27 02:32 MrMisterMonkey Note Added: 0008804
2010-09-27 06:15 dolorous Note Added: 0008806
2010-09-27 11:38 hayenne Note Added: 0008809
2010-09-27 15:58 dolorous Note Added: 0008813
2010-09-27 23:37 hayenne Note Added: 0008817
2010-09-28 18:44 GameKnut Note Added: 0008825
2011-03-31 01:23 jpeg Relationship added has duplicate 0003090
2011-03-31 22:50 jpeg Relationship added related to 0001842
2012-09-07 12:14 hayenne Status new => acknowledged
2013-08-28 19:58 BlackSheep Note Added: 0023899
2013-09-05 23:25 MarvinPA Status acknowledged => resolved
2013-09-05 23:25 MarvinPA Fixed in Branch => 0.13 development branch
2013-09-05 23:25 MarvinPA Resolution open => done
2013-09-05 23:25 MarvinPA Assigned To => MarvinPA
2015-02-14 22:36 hayenne Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker