Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002440 [DCSS] FR: Gameplay Balancing trivial always 2010-09-02 16:56 2014-01-31 00:04
Reporter kurper View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0002440: Make fake rakshas also see invisible
Description Currently, fake rakshas can't see invisible but real ones can't. This makes it trivial to tell the difference by examining them. Fake rakshas also roar and real ones are silent. The attached patch fixes both of these. It might be better to make fake rakshas silent instead of making real ones roar, I'm not sure.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Made-fake-rakshas-more-similar-to-real-rakshas-both-.patch [^] (1,313 bytes) 2010-09-02 16:56 [Show Content]

- Relationships

-  Notes
(0007799)
BirdoPrey (reporter)
2010-09-02 17:20

Currently in trunk, fake rakshasa's do not see invisible however examining them says that they do. I think this is a better solution than making them see invisible for real, as at least now there's SOME method of figuring out which one is real without abjuration.
(0007801)
kurper (reporter)
2010-09-02 17:43

Goodness, you're right! I guess that's what I get for assuming trunk hadn't changed since 0.7.
(0007814)
Numeron (reporter)
2010-09-03 03:01

Having fake rakshasas not see invisible when the interface says otherwise turns this into terribly spoilery stuff. Perhaps a note should be added to their description which says that fakes do not have this ability, despite appearing as if they do.
(0007815)
minmay (reporter)
2010-09-03 04:07

I don't understand why the player should have an easy method of figuring out which one is real - doesn't it nullify the entire purpose of the monster? I say make them see invisible properly.
(0007821)
rob (developer)
2010-09-03 12:35

Another issue is the difference in magic resistance. Fake rakshasas are immune, so enchantments fail with "is unaffected" instead of "resists".

I'm unsure which of "make both immune", "give both actual MR" and "make fake rakshasa enchantments fail with 'resists'" is preferable
(0025153)
Medar (developer)
2014-01-31 00:04

This was finally applied in: 0.14-a0-1511-gaa44ba7

- Issue History
Date Modified Username Field Change
2010-09-02 16:56 kurper New Issue
2010-09-02 16:56 kurper File Added: 0001-Made-fake-rakshas-more-similar-to-real-rakshas-both-.patch
2010-09-02 17:20 BirdoPrey Note Added: 0007799
2010-09-02 17:43 kurper Note Added: 0007801
2010-09-03 03:01 Numeron Note Added: 0007814
2010-09-03 04:07 minmay Note Added: 0007815
2010-09-03 12:35 rob Note Added: 0007821
2013-03-19 18:59 mumra Issue Monitored: mumra
2013-12-11 09:27 Medar Issue Monitored: Medar
2014-01-31 00:04 Medar Note Added: 0025153
2014-01-31 00:04 Medar Status new => resolved
2014-01-31 00:04 Medar Fixed in Branch => 0.14 development branch
2014-01-31 00:04 Medar Resolution open => done
2014-01-31 00:04 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker