Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002418 [DCSS] FR: Gameplay Balancing minor N/A 2010-08-31 19:47 2014-06-11 17:04
Reporter OG17 View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0002418: Allies should be better at evaluating ranged weapon value
Description If a companion is carrying a non-stacking thrown weapon like a club, it'll refuse to pick up a ranged weapon like a longbow, even if the thing's stacked with of a pile of ammunition. Also, a companion will drop a hundred arrows in order to quiver a single better-quality one. The player is forced to choose between being supported by underequipped allies or carrying around the items himself until they're willing to take them.

Ranged weapons should be preferred to thrown weapons regardless of ammo, though allies should perhaps still trade weak bows for high-quality javelins and so on. Ammo quantity should be considered along with quality, so that allies don't trade continued usefulness for a few negligibly better shots. However, this behavior should likely be companion-specific, as current behavior works better for hostile monsters.

(Needless to say, telling allies to drop their items would be useful here as well!)
Additional Information
Tags AI
Attached Files

- Relationships

-  Notes
(0007688)
OG17 (reporter)
2010-08-31 19:54
edited on: 2010-08-31 20:10

Also, it might be good for the returning brand to be especially valued on thrown weapons, as it makes them compare much more favorably to weaker ranged weapons.

e: In the FR I meant to say "trade weak arrows for high-quality javelins," not bows. Also, much like the above, it's pretty undesirable that an ally with an ammoless bow will drop a dozen javelins for a single arrow.

(0007689)
BirdoPrey (reporter)
2010-08-31 21:58

This is one of the few issues preventing HoPr from being the most fun combo in the game.
+1
(0007693)
minmay (reporter)
2010-08-31 23:50

What would really be nice is if they'd be willing to carry multiple ammunition stacks (maybe even multiple weapons), though of course they'd need to prefer letting allies which are short on ammo/weapons take them, plus a bunch of other stuff. Not likely to ever happen, of course.
(0007698)
galehar (administrator)
2010-09-01 09:42

+1
Allies usually make decent choices about melee weapon but quite often stupid ones about ranged weapon or ammunition. We don't need them to make optimal choices, but there is definitely room for improvement here.
(0007705)
jpeg (manager)
2010-09-01 11:46

Good point. More specific examples would be helpful in working out what needs to be done:

What is the ideal correlation between arrow (to stick with your example) quantity and quality?

Which of the following would be "obviously best", assuming the ally is carrying a non-branded bow?

35 +0 arrows
10 +2 arrows
8 +0 arrows of flame
17 poisoned arrows
5 +0 javelins
1 +1 hand axe of returning

Currently, quantity isn't considered at all (which is bad, of course) and quality is estimated by an item's base price.

Also: Search the entire stack before deciding which weapons to pick up, in case it contains matching launcher and ammo. Presumably, this would be a single action. Would also involve comparison against the carried launcher and non-launcher throwing weapons.

Anything else?
(0007706)
galehar (administrator)
2010-09-01 12:05

How about they carry 2 stacks of ammunition. One is chosen based on value, the other on quantity. That way, they take good ammo, but when it runs out, they switch to normal ammunition.
It doesn't have to be binary. One could be weighted toward value, the other toward quantity.
As for launcher vs thrown, it could depend on the orc (as suggested by dpeg in 2411). Some use bows, others crossbows and others thrown weapon.
(0007715)
OG17 (reporter)
2010-09-01 18:36
edited on: 2010-09-01 18:39

I thought multiple ammo stacks would be out of the question, but it'd certainly take the edge off the problem here. Giving orcs specific skillsets would do nothing beneficial in any aspect - one would think that it'd be bringing the game closer towards the hazy RTS/whatever image that's to be avoided at all costs, actually (though apparently he'd be wrong!).

Allies could actually use three slots here, I guess - one for good ammo, one for lots of ammo, and one for thrown weapons (and a fourth for the current extra club/spear/axe slot), with them shooting whatever they have that's strongest. Don't know if this is the best method or even desirable, but it'd make things a lot simpler. If not, they'd need to be smart enough to trade ammo stacks for thrown weapon stacks (and other ammo stacks) by making decisions that wouldn't leave the player speechless, just like they would with the current single stack.

If this would be okay for permanent allies but not for monsters, they could just drop their weakest stacks when becoming hostile.

(0007717)
Lemuel (updater)
2010-09-01 19:58

Allowing allies to carry multiple stacks of ammo seems like the best solution -- cut the Gordian knot of comparing ammo. Is it feasible?

Another thing that might be nice would be if allies preferred not to use the same launcher as the player.

And as suggested elsewhere permanent allies should not carry consumables.

I suspect with these changes, the requests for equipment-related orders to allies will go away.
(0007719)
Lemuel (updater)
2010-09-01 20:13

Alternatively, here something that sounds extreme but might work well in play: Implicit ammo sharing between allies.

Get rid of individual ammo slots for intelligent allies. Instead, have all intelligent allies share a single pool of ammo, which can hold an unlimited (or at least large) number of separate stacks. Individual allies still carry their own launchers. Allies pick up any ammo that fits a launcher carried by any other intelligent ally as well as themselves. They fire from the best stack in the pool that fits the launcher they are carrying, or the best thrown weapon in the pool if they don't have a launcher.

When an ally dies, each stack usable by that ally has a proportionate chance of being dropped. E.g. if you had four intelligent allies, two with bows, then if a bow-wielder dies, each stack of arrows would have a 50% chance of being dropped on its space, and each thrown weapon a 25% chance.

This would have the same gameplay effect of explicit code for allies to give ammo to each other, but would be far, far easier to code. And the rare inconsistency of ammo "teleporting" between allies not near each other would be, I'm pretty sure, entirely invisible in play.

I think something like this might be the best solution.
(0007720)
minmay (reporter)
2010-09-01 20:26

galehar's and Lemuel's suggestions both sound great to me.
(0007721)
OG17 (reporter)
2010-09-01 20:31

Lemuel, ammo and consumables aren't the main problem with ally equipment, but more of a sideshow.

A shared pool might work mechanically, but I'm not fond of it, as allies carrying their individual equipment goes a long way in making them seem alive. Guessing that's not your priority, though, but gameplay-wise, a player would have difficulty using ranged weapons himself, as it'd seem like all the ammo in the dungeon is getting absorbed into the blobquiver - playing under this would require a good bit of command-switching, I'd think. Granted, ally play doesn't exactly mesh well with ranged weapons in the first place, but if the player comes across portal projectile, it suddenly becomes very viable.

I don't like "allies prefer not to use the same launcher as the player" for similar reasons - there's very few ammo types in the game, and they each tend to appear in pretty set ranges of the game. A player with a crossbow shouldn't leave allies scrounging for bullets or arrows when they're surrounded by a surplus of bolts.
(0007722)
Lemuel (updater)
2010-09-01 20:49

OG17-

Well, my guess is that it would not affect the sense of their being alive at all, because from the player's point of view, the blobquiver would be indistinguishable from active sharing of ammo by allies.
(0007729)
jpeg (manager)
2010-09-01 22:24
edited on: 2010-09-01 22:26

Nah, multiple stacks are not "out of the question". :) They just require some more thought in the implementation. For simplicity, I think we should stick with a main and a secondary quiver. The main quiver only holds launcher-specific ammunition, the secondary one might contain either launcher-specific or generic ammunition. The question of when to upgrade ammunition still applies, though it becomes less urgent.

Shared ammunition is an intriguing concept, but is bound to cause trouble once allies get split up across different levels. Maybe it would be enough to actively search the surrounding allies for applicable ammo and let them borrow a few whenever necessary.
Imagine the following scenario: orcs A and B both use crossbows. B is freshly out of bolts. A, who happens to be carrying a stack of bolts, is standing nearby (not necessarily adjacent or even in los but in a reasonable distance). In that case, B can "borrow" some bolts from A, i.e. get half of A's stack. If they happen to be adjacent at the time AND are in los of the player, we might add a fancy message ("A passes B some crossbow bolts"), but it's not required.

Restricting access to ammunition useful for the player's launcher also sounds interesting. Allies could ignore this type of ammo unless it was dropped by either the player or a comrade, even in the "pick up everything" setting. Not sure about that, though.

(0007757)
Lemuel (updater)
2010-09-02 00:00

Jpeg's ideas all sound good to me.
(0013397)
user1108
2011-06-06 08:12
edited on: 2011-06-06 08:21

Some notable cases I saw:
A) An orc with a bow of flame dropping a stack of arrows to pick up a single arrow of flame.
B) An orc picking up a randart blowgun but ignoring ammunition for it (the orc was carrying a javelin in the quiver slot).
C) An orc firing a bolt of penetration killing an orc wizard on the other side. (a targeting issue too, but penetration ammo wouldn't be fired much if targeting was fine).

Adding an extra quiver slot for them seems to be the easiest way to fix (or ameliorate) all these cases.

(0026457)
wheals (administrator)
2014-06-11 17:04

Friendlies can't pick up items. Possibly some sort of ammo gifting from beogh to orcs could be added, though.

- Issue History
Date Modified Username Field Change
2010-08-31 19:47 OG17 New Issue
2010-08-31 19:54 OG17 Note Added: 0007688
2010-08-31 19:56 OG17 Note Edited: 0007688
2010-08-31 20:07 OG17 Note Edited: 0007688
2010-08-31 20:10 OG17 Note Edited: 0007688
2010-08-31 21:58 BirdoPrey Note Added: 0007689
2010-08-31 23:50 minmay Note Added: 0007693
2010-09-01 09:42 galehar Note Added: 0007698
2010-09-01 11:46 jpeg Note Added: 0007705
2010-09-01 12:05 galehar Note Added: 0007706
2010-09-01 18:36 OG17 Note Added: 0007715
2010-09-01 18:39 OG17 Note Edited: 0007715
2010-09-01 19:58 Lemuel Note Added: 0007717
2010-09-01 20:13 Lemuel Note Added: 0007719
2010-09-01 20:26 minmay Note Added: 0007720
2010-09-01 20:31 OG17 Note Added: 0007721
2010-09-01 20:49 Lemuel Note Added: 0007722
2010-09-01 22:24 jpeg Note Added: 0007729
2010-09-01 22:26 jpeg Note Edited: 0007729
2010-09-02 00:00 Lemuel Note Added: 0007757
2011-06-06 08:12 user1108 Note Added: 0013397
2011-06-06 08:13 user1108 Note Edited: 0013397
2011-06-06 08:21 user1108 Note Edited: 0013397
2013-05-30 15:00 mumra Tag Attached: AI
2014-06-11 17:04 wheals Note Added: 0026457
2014-06-11 17:04 wheals Status new => resolved
2014-06-11 17:04 wheals Fixed in Branch => 0.15 development branch
2014-06-11 17:04 wheals Resolution open => done
2014-06-11 17:04 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker