Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002371 [DCSS] FR: Interface Improvements minor have not tried 2010-08-25 07:08 2014-09-28 16:47
Reporter b0rsuk View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0002371: Copy god description to altar description
Description I think it's a bit counterintuitive that to get a religion's description you have to pray at an altar. Examining an altar is a natural thing to do and should suffice. Altars can't be corroded, cursed, branded, or contain different things.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007553)
OG17 (reporter)
2010-08-25 14:04

Players can already use the lookup feature to get god information from anywhere in the game, and altar descriptions serve to offer a nice touch of unique flavor about the altar (and by extension, the god). Altar descriptions offering full mock-ups of the god screen would be pretty pointless anyway, as you'd have to walk over and see it again to convert.
(0007559)
b0rsuk (updater)
2010-08-25 21:45

Correction - from outside the game. It doesn't appear when interacting with any game object. Manual is not a part of the game world.

Unless, of course, you *wouldn't* have to see it again, because there would be no description on kneeling*, because most players try to get information about something by examining it. No one with two brain cells to rub together would design it that way. Praying at an altar to see what it does is like drinking an identified (known) potion to see what it does. There is no reason to expect you will get a confirmation prompt and a longer description (unless you've done it before). Just like there is no reason a potion will prompt you for confirmation and offer an extended description of what Agility does.

* longer description could be accessible upon pressing '^' or '!'
(0007560)
OG17 (reporter)
2010-08-25 22:21

Who said anything about outside information? Hit ?/g and wow, all the altars are at your fingertips, and it even takes less keystrokes! You're playing the wrong game if you think that's immersion-breaking, or if you think that explaining altar usage three times over in the manual, hints, and tutorial is somehow insufficient. Also, I'm not sure what you're saying, but interacting with an altar has nothing in common with using an item.
(0007562)
minmay (reporter)
2010-08-25 23:23

When a player sees something on their screen and wants to know something about it, their first impulse is to use the game's examine command, not consult the manual. When you see a new monster, do you use ?/m and type its name to find out what it does?
Gates describe (to some extent) the branch that they lead to; altars should describe the god they are dedicated to.
(0007563)
dpeg (administrator)
2010-08-25 23:43

I think a good solution is this:

Examining an altar lists:
* the god's name (e.g. Makhleb)
* the title (e.g. the Destroyer)
* how to get more information: praying (mention prompt) and god list (?(G)
(0007564)
KiloByte (manager)
2010-08-26 01:03

+1 to dpeg.

The full wall of text is way too spammy.
(0007565)
OG17 (reporter)
2010-08-26 01:11
edited on: 2010-08-26 01:12

Minmay, monsters aren't gods, nor are altars, and it's entirely consistent that examining an altar describes the altar (and again, the god's included in that).

Dpeg's would work, anyway; I'd typed up similar, but then realized this is all in the tutorial/hints, but whatever. Altar descriptions should keep the current flavor lines, though, and examining should keep adjectives like "basalt" for Yred and so on, as they're fun. I don't think there's much reason to show god titles on examination, though, as they're not that important and half the gods don't even have one.

(0007680)
jpeg (manager)
2010-08-31 08:28

Fully agree with b0rsuk's request. When I notice an inaccessible altar (behind glass/water) I should not have to dig out the documentation (including the database!) to find out about the god. Since the information already _is_ available elsewhere I don't see any problem to including the basic god description when _viewing_ an altar. (I think that's what b0rsuk really means.)

Limiting the lists of powers and (dis)likes to only the praying screen is fine with me, but I don't think that printing "Makhleb the Destroyer" rather than plain "Makhleb" would be much of an improvement -- though it would be a good addition to the text displayed when _examining_ the altar in question.
(0007684)
b0rsuk (updater)
2010-08-31 15:18

Here's how I see it:

- praying at an altar is something a player does usually once per character. It's almost mandatory. This is relatively common.

- religion description is likely to be requested much less often than once per character. This is especially true for experienced players.

It is reasonable to expect that experienced players will value clutter-free mandatory religion joining screens. They will only refer to religion description once in a while. You can call it a long-term optimisation. Of course, whatever the decision it's important to make sure new players always know how to reach religion descriptions.
(0027361)
PleasingFungus (administrator)
2014-09-28 16:47

Added (pray here to learn more) to altar descriptions, since god descriptions don't work very well in the context of altars, and gods probably don't need *another* set of descriptions.

- Issue History
Date Modified Username Field Change
2010-08-25 07:08 b0rsuk New Issue
2010-08-25 14:04 OG17 Note Added: 0007553
2010-08-25 21:45 b0rsuk Note Added: 0007559
2010-08-25 22:21 OG17 Note Added: 0007560
2010-08-25 23:23 minmay Note Added: 0007562
2010-08-25 23:43 dpeg Note Added: 0007563
2010-08-26 01:03 KiloByte Note Added: 0007564
2010-08-26 01:11 OG17 Note Added: 0007565
2010-08-26 01:12 OG17 Note Edited: 0007565
2010-08-31 08:28 jpeg Note Added: 0007680
2010-08-31 15:18 b0rsuk Note Added: 0007684
2013-04-08 20:19 mumra Issue Monitored: mumra
2014-09-28 16:47 PleasingFungus Note Added: 0027361
2014-09-28 16:47 PleasingFungus Status new => resolved
2014-09-28 16:47 PleasingFungus Fixed in Branch => 0.16 development branch
2014-09-28 16:47 PleasingFungus Resolution open => done
2014-09-28 16:47 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker