Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002272 [DCSS] FR: Interface Improvements trivial N/A 2010-08-13 19:05 2014-09-19 02:55
Reporter minmay View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.8 ancient branch
Summary 0002272: Don't ask which spell the player wants to cast when (s)he can't
Description Let's say you're starving. If you press z, the game prompts you to pick a spell, and THEN tells you that you're too hungry to cast it. It would be better to simply give the message when you press z.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007186)
TGW (reporter)
2010-08-13 20:29

Why?
(0007188)
S2im (reporter)
2010-08-13 20:57

Because it can. +1.5
(0007193)
reid (reporter)
2010-08-13 22:06

-0.5

I prefer the interface to act as consistently as possible. Naturally I don't pause at all after pressing z, since I use it hundreds of times per game. If I accidentally try to cast Haste (zh) while starving, I don't want to have the game move me west.

However, I'd probably work around this by adding another force_more_message line to my config, so it's not that big a deal.
(0007200)
Timbermaw (reporter)
2010-08-14 02:18

-1

As reid said, this is more bothersome than helpful. I macro my spells (1 = "Za") and this could lead to my character moving with Zh and whatnot..
(0007201)
OG17 (reporter)
2010-08-14 02:41
edited on: 2010-08-14 17:46

This would be "inconsistent?" This would actually be identical to casting under silence. And while I don't think that the default interface needs to cater to heavy macro-users, silence has a built-in force_more anyway.

This should go in, and it should be extended so that all situations where the player can't cast behave the same way (eg having zero mp. Knowing no spells or having zero int don't force_more, either. e: nor does being berserk).

(0007203)
TGW (reporter)
2010-08-14 04:20
edited on: 2010-08-14 04:20

No.

The current behavior is better because it mops up your extra keystroke without being unnecessarily obtrusive. Going through a --more-- every time you accidentally tap z while starving would be more annoyance than is required.

Silence should work the same way if it doesn't.

(0007205)
OG17 (reporter)
2010-08-14 04:58

The game should prompt the player when a command fails in an atypical manner, and casting a spell when you're not able to do so certainly falls under that. Otherwise, even a player without macros is going to end up inputting unwanted actions. It's less annoying to have a "more" prompt than it is to have to cancel another command (eg (a)bilities), never mind misstepping with hjkl.
(0007208)
reid (reporter)
2010-08-14 07:16

Perhaps I should have said "predictably": a keystroke should not have radically different effects depending on changes in game state outside the player's direct control (as would be the case if z simply resulted in a message without force_more).

Anyways, I'd be fine with a built-in force_more as with silence. If I'm trying to cast spells during starving, I want to be made aware so that I can change my plan. I don't think it would come up often enough to be an annoyance.
(0007210)
minmay (reporter)
2010-08-14 16:28

Note that berserk rage, like Silence, also lets you know right away that you can't cast/wield/disarm/whatever. As such, it would make behavior more consistent if nothing else. However, I agree that being unaware and accidentally doing the wrong action is a problem.
In the end, this is one of those interface dilemmas where there is no right option, but one option may be slightly less wrong than the other.
(0027189)
wheals (administrator)
2014-09-10 16:37

I've changed it to be like most other spell-blocking statuses, with the more() that silence has, in 0.16-a0-360-g33738f0.

- Issue History
Date Modified Username Field Change
2010-08-13 19:05 minmay New Issue
2010-08-13 20:29 TGW Note Added: 0007186
2010-08-13 20:57 S2im Note Added: 0007188
2010-08-13 22:06 reid Note Added: 0007193
2010-08-14 02:18 Timbermaw Note Added: 0007200
2010-08-14 02:41 OG17 Note Added: 0007201
2010-08-14 04:20 TGW Note Added: 0007203
2010-08-14 04:20 TGW Note Edited: 0007203
2010-08-14 04:20 TGW Note Edited: 0007203
2010-08-14 04:58 OG17 Note Added: 0007205
2010-08-14 07:16 reid Note Added: 0007208
2010-08-14 16:28 minmay Note Added: 0007210
2010-08-14 17:46 OG17 Note Edited: 0007201
2014-09-10 16:37 wheals Note Added: 0027189
2014-09-10 16:37 wheals Status new => resolved
2014-09-10 16:37 wheals Fixed in Branch => 0.16 development branch
2014-09-10 16:37 wheals Resolution open => done
2014-09-10 16:37 wheals Assigned To => wheals
2014-09-19 02:55 minmay Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker