Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002006 [DCSS] Bug Report minor always 2010-07-18 09:49 2013-11-25 18:23
Reporter OG17 View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.7 ancient branch
Summary 0002006: Bushes are broken
Description Launched and thrown projectiles seem to have zero chance of hitting bushes. Single-target spells like sticky flame pass right through them, and if targetted directly, nothing happens (though piercing and aoe spells hit them either way). They eat orbs of destruction without any message or damage, too.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006378)
KiloByte (manager)
2010-07-18 10:35

The explanation is that bushes are sparse, and thus most missiles just fly through them. It may make some sense to have a small chance of the projectile stopping.

Eating orbs of destruction is a bug -- either the orb should fly through, or explode there. Because of both the orb being much wider than most projectiles, and technical reasons (there are big issues with two monsters on the same square), exploding sounds better.

For spells targetted at the bush, they correctly fly further, I see no bug.
(0006383)
OG17 (reporter)
2010-07-18 11:46
edited on: 2010-07-18 11:49

Spells only fly past the bush if you shoot them past the bush. If you target the bush itself, such spells effectively vanish, and "sparse" or not, covering a bush in napalm should make it burn - spells passing through bushes is one thing, but silently having no effect when shooting directly at the thing's square seems strange, to say the least. However, if they're actually supposed to be flat-out immune to projectiles, it's inconsistent that they block aoe missiles like fireball and are damaged by piercing bolt spells (especially as they don't block exploding ammo or take damage from penetrating ammo). (Also, it's somewhat curious that such seemingly whispy things have 30 AC.)


- Issue History
Date Modified Username Field Change
2010-07-18 09:49 OG17 New Issue
2010-07-18 09:51 OG17 Note Added: 0006376
2010-07-18 10:05 OG17 Note Edited: 0006376
2010-07-18 10:35 KiloByte Note Added: 0006378
2010-07-18 11:46 OG17 Note Added: 0006383
2010-07-18 11:49 OG17 Note Edited: 0006383
2010-08-07 00:49 OG17 Note Deleted: 0006376
2013-03-19 20:04 mumra Issue Monitored: mumra
2013-11-25 18:23 MarvinPA Status new => resolved
2013-11-25 18:23 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-25 18:23 MarvinPA Resolution open => done
2013-11-25 18:23 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker