Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001817 [DCSS] Bug Report major always 2010-06-23 22:38 2015-02-19 20:25
Reporter starless View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.6 ancient branch
Summary 0001817: Screen flicker under OSX
Description I noticed this recently ... could be after the last 10.6.4 OSX update. Sometimes, quite often actually when you cast spells, the screen goes black for a split second.

This happened in 0.6, yesterday I upgraded to 0.6.1 - it still happens quite often, but not always.

2.26 Intel Core 2 Duo, 4gb RAM, Nvidia Geforce 9400M
Additional Information
Tags No tags attached.
Attached Files mov file icon dcss1.mov [^] (1,736,868 bytes) 2010-06-23 22:38

- Relationships

-  Notes
(0028533)
gammafunk (administrator)
2015-02-19 20:25

We've moved to SDL2 and I'm not sure what else might have changed about the SDL rendering loop/code that could have fixed the problem in the many versions since 0.6, but we're not getting reports of screen flashes on OS X in recent crawl, so resolving.

- Issue History
Date Modified Username Field Change
2010-06-23 22:38 starless New Issue
2010-06-23 22:38 starless File Added: dcss1.mov
2015-02-19 20:25 gammafunk Note Added: 0028533
2015-02-19 20:25 gammafunk Status new => resolved
2015-02-19 20:25 gammafunk Fixed in Branch => 0.16 development branch
2015-02-19 20:25 gammafunk Resolution open => done
2015-02-19 20:25 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker