Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001805 [DCSS] FR: Gameplay Balancing minor have not tried 2010-06-21 20:15 2013-07-29 00:00
Reporter olo View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.7 ancient branch
Summary 0001805: change scroll of Vorpalize to scroll of Branding
Description Currently once I find one ?Vorp finding any more are a bit disappointing. I suggest that it become a scroll of Branding and will either add a brand or replace an existing brand on any non-artefact weapon. The brand you get should be random but not include those given by gods (distort/holy/pain).

This would help when you find a good (rare) weapon but hate the brand it has and keep the scrolls more interesting after the first one.
Additional Information
Tags No tags attached.
Attached Files ? file icon rebranding.patch [^] (6,220 bytes) 2013-07-28 02:36 [Show Content]

- Relationships
related to 0001921resolvedmumra Clean up the vorpal brand name 

-  Notes
(0005816)
OG17 (reporter)
2010-06-21 23:16

It'd obviously skip over speed (and chaos?) as well, but I sort of like this. It might need to be a new scroll type, though, as affixing a temp brand should still be possible and it'd be sort of conflicting if it did both.
(0005818)
KiloByte (manager)
2010-06-22 00:05

What about letting the branding spells (and the Blade card) overwrite existing brands instead?
(0022764)
mumra (developer)
2013-05-21 18:02

"What about letting the branding spells (and the Blade card) overwrite existing brands instead?"

@KiloByte - is this still desired? It could make branding spells marginally more useful in some situations but is it worth it, especially taking into account branded artifacts which "cannot be changed by magic or mundane means".
(0023577)
argonaut (reporter)
2013-07-28 02:39

Here's a patch for this issue. It seems to work well and the weights are at least reasonable.

As a bonus it fixes a bug in the venom branding due to changes in OTR.
(0023585)
neil (administrator)
2013-07-28 21:06

Hm, I'm not so sure about reaping, which currently occurs only on unrands and on the worst polearm (scythes). Maybe it would be fine, though.
(0023587)
MarvinPA (developer)
2013-07-29 00:00

Pushed this with reaping brand removed and some other minor tweaks. Thanks for the patch!

- Issue History
Date Modified Username Field Change
2010-06-21 20:15 olo New Issue
2010-06-21 23:16 OG17 Note Added: 0005816
2010-06-22 00:05 KiloByte Note Added: 0005818
2013-05-21 16:58 mumra Relationship added related to 0001921
2013-05-21 18:02 mumra Note Added: 0022764
2013-07-28 02:36 argonaut File Added: rebranding.patch
2013-07-28 02:39 argonaut Note Added: 0023577
2013-07-28 21:06 neil Note Added: 0023585
2013-07-29 00:00 MarvinPA Note Added: 0023587
2013-07-29 00:00 MarvinPA Status new => resolved
2013-07-29 00:00 MarvinPA Fixed in Branch => 0.13 development branch
2013-07-29 00:00 MarvinPA Resolution open => done
2013-07-29 00:00 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker