Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001704 [DCSS] Source Cleanup minor have not tried 2010-06-08 10:25 2014-10-03 03:28
Reporter rob View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.7 ancient branch
Summary 0001704: unify level id handling
Description In particular, get rid of you.where_are_you, you.absdepth0, you.level_type in favour of some global level_id.

That might be you.level, or env.id -- it seems to fit env better, but the save/load code references these settings when (un)marshalling env.

level_id::current would go.

Functions like files.cc:load() should be passed a level_id old_level.

Then there's the redundancy between level_id and packed place. I'm not sure we need both. level_id could be backed by a packed place and used everywhere.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005453)
rob (developer)
2010-06-08 10:54

Also, level_id::operator==(branch_type) needs to go
(0027410)
wheals (administrator)
2014-10-03 03:28

0.16-a0-1013-1018 got rid of packed places; 0.16-a0-1012 got rid of the == operator. I'm not convinced about combining the player fields into a global level_id, especially since level_ids now have just two fields themselves.

- Issue History
Date Modified Username Field Change
2010-06-08 10:25 rob New Issue
2010-06-08 10:54 rob Note Added: 0005453
2014-10-03 03:28 wheals Note Added: 0027410
2014-10-03 03:28 wheals Status new => resolved
2014-10-03 03:28 wheals Fixed in Branch => 0.16 development branch
2014-10-03 03:28 wheals Resolution open => done
2014-10-03 03:28 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker