Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000016 [DCSS] Bug Report minor always 2009-11-22 23:22 2010-02-18 06:09
Reporter TGW View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.5 ancient branch
Summary 0000016: Mephitic cloud range
Description In addition to the one extra tile afforded by the cloud's radius, mephitic cloud consistently travels one tile past its "maximum range" before stopping.
Additional Information What do I use this field for?
Tags 0.6 target
Attached Files ? file icon 0001-Mephitic-Cloud-range-fix.patch [^] (785 bytes) 2010-01-09 05:36 [Show Content]

- Relationships
has duplicate 0000582closed Mephitic cloud travels further with Shift+Dir 

-  Notes
(0000945)
Cryptic (developer)
2010-01-08 23:38
edited on: 2010-01-09 01:46

Confirmed, auto-target correctly limits the cast range to 5, but shift+dir results in the center of the beam being 6 spaces away from the players current location.

Issue seems to be with the STINKING_CLOUD beam, which has a range of 6. An easy fix, but could inadvertently affect other abilities which make use of the STINKING_CLOUD beam.

(0002683)
caotto (developer)
2010-02-18 06:09

Fixed in trunk (commit 9156de34).

- Issue History
Date Modified Username Field Change
2009-11-22 23:22 TGW New Issue
2009-11-22 23:22 TGW Test Custom Field => Or this one?
2009-11-24 11:07 jpeg Issue Monitored: jpeg
2009-12-07 15:42 jpeg Issue End Monitor: jpeg
2010-01-08 23:38 Cryptic Note Added: 0000945
2010-01-09 01:31 Cryptic Note Edited: 0000945
2010-01-09 01:46 Cryptic Note Edited: 0000945
2010-01-09 05:36 Cryptic File Added: 0001-Mephitic-Cloud-range-fix.patch
2010-01-27 16:26 doy Relationship added has duplicate 0000582
2010-02-10 20:57 doy Tag Attached: 0.6 target
2010-02-18 06:09 caotto Note Added: 0002683
2010-02-18 06:09 caotto Status new => closed
2010-02-18 06:09 caotto Resolution open => done
2010-02-18 06:09 caotto Fixed in Branch => 0.7 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker