Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001588 [DCSS] Bug Report minor always 2010-05-19 23:50 2013-08-02 00:11
Reporter OG17 View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.7 ancient branch
Summary 0001588: Spells aren't marked as disliked for Trog
Description Spells should all be colored and have "disliked" description text. It might be best if they were given a unique color (magenta?) to indicate that simply memorizing a spell brings you penance, or if they were red but gave an additional prompt before memorizing (or alternatively, M could be disabled entirely for Trog).
Additional Information
Tags spell colouring
Attached Files

- Relationships
related to 0001930resolvedwheals Warn player of trying to cast prohibited spells 
parent of 0007412closedneil Make Trog hate spells 

-  Notes
(0009686)
ahpla (reporter)
2010-12-11 14:21

All spellbooks (even pre-identified) are already coloured red for Trog followers. Examining one reveals "Trog disapproves of the use of such an item." Similarly, gods in general disapprove of spellbooks containing spells with forbidden effects, and such books are accordingly coloured red.

Although maybe it could be a problem if, for example, you cast a spell which you had memorised prior to becoming a Trog follower.
(0009688)
OG17 (reporter)
2010-12-11 17:49
edited on: 2010-12-11 17:53

Push M with TSO etc, and then push M with Trog.

Also, spell list.

(0009729)
Nobody (reporter)
2010-12-14 18:11

Magenta is already in use for spells from dangerous spellbooks (e.g., Book of Annihilations).
(0009731)
OG17 (reporter)
2010-12-14 19:20

Meant lightmagenta (vs purple), since this is pretty much a stronger version of current magenta's "memorizing is dangerous."
(0023624)
neil (administrator)
2013-08-02 00:11

Fixed in trunk (0.13-a0-2590-g8c14591). Less than three years!

- Issue History
Date Modified Username Field Change
2010-05-19 23:50 OG17 New Issue
2010-05-20 11:45 rob Tag Attached: spell colouring
2010-12-11 14:21 ahpla Note Added: 0009686
2010-12-11 17:49 OG17 Note Added: 0009688
2010-12-11 17:53 OG17 Note Edited: 0009688
2010-12-14 18:11 Nobody Note Added: 0009729
2010-12-14 19:20 OG17 Note Added: 0009731
2013-03-27 19:00 mumra Issue Monitored: mumra
2013-03-27 19:07 mumra Relationship added duplicate of 0001930
2013-03-27 19:08 mumra Relationship deleted 0001930
2013-03-27 19:08 mumra Relationship added related to 0001930
2013-08-02 00:10 neil Relationship added parent of 0007412
2013-08-02 00:11 neil Note Added: 0023624
2013-08-02 00:11 neil Status new => resolved
2013-08-02 00:11 neil Fixed in Branch => 0.13 development branch
2013-08-02 00:11 neil Resolution open => done
2013-08-02 00:11 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker