Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001483 [DCSS] Bug Report minor always 2010-05-03 06:51 2014-03-14 22:52
Reporter MrMisterMonkey View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.7 ancient branch
Summary 0001483: Snapping turtles will attack you from a distance while "fleeing" instead of actually fleeing
Description I was able to reproduce this locally (0.7.0-a0-1562-g9e8ab03): get a snapping turtle down to low health, and position yourself one space away from it; when it flees, it'll continue attacking you from a distance, instead of fleeing. If this is desirable behavior, perhaps "fleeing" isn't the best description.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004594)
MrMisterMonkey (reporter)
2010-05-03 18:45

I guess I was a bit hasty in saying this is a snapping turtles thing; it applies to any frightened monster with a reaching attack.

To reproduce, spawn a merfolk, give it a trident of reaching, frighten it until its status changes to fleeing.
(0004595)
ogaz (updater)
2010-05-03 19:56
edited on: 2010-05-03 19:57

Doesn't this apply to any monster with a ranged attack? I know dragons and acid blobs will occasionally stop fleeing to blast more stuff at you, at least.

(0004596)
MrMisterMonkey (reporter)
2010-05-03 20:12

The difference there is they actually stop fleeing; the monsters with reaching weapons are still marked as fleeing when they attack you, and will continue fleeing if you get out of their range.
(0004608)
OG17 (reporter)
2010-05-03 23:42

I assumed this was intentional - it makes the reaching effect that much more interesting when in a monster's hands.
(0004620)
Kyrris (reporter)
2010-05-04 12:53

It's confusing. You get closer, they run. You get farther, they run.
(0004621)
OG17 (reporter)
2010-05-04 13:29
edited on: 2010-05-04 13:30

I don't see what's confusing - every fleeing creature runs away from you whether you're moving towards or away from it. The only difference is that a fleeing reaching enemy attacks if you're standing two squares away. Basically, when it's in your melee range, it moves away, but if it's at a "safe" distance while you're in its range, it takes a potshot, and again retreats if you close the gap. It's effectively kiting you, which is great.

Giving it another look, this is almost certainly unintentional, but it's still neat behavior.

(0004644)
Core Xii (reporter)
2010-05-05 11:22

But then if the player has a reaching weapon as well, the monster with the reaching attack isn't presumably smart enough to flee from that, is it?
(0004649)
Cryptic (developer)
2010-05-05 17:28

I can certainly understand the odd behavior, though it is neat that the monster is effectively kiting the player.

The only reason I could see to change this behavior is if the monster is getting free attacks while it flees. This is obviously very bad behavior, since you could endlessly chase the turtle and it would always stay 2 squares away from you, doing damage as it went on its merry, fleeing way. I'm not sure if that's the current behavior, but that's how I interpreted it.
(0004765)
MrMisterMonkey (reporter)
2010-05-13 17:40

Currently, turtles and monsters with reaching weapons do not get free attacks.

I see the problem as the behavior being counterintuitive: fleeing monsters should flee; this has almost killed me and I think I've someone else fumble with it on CDO too.

If this is desirable, I think it would be better as the default, rather than triggering upon fleeing.

Related to the "Better AI" section of https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:monster:new_behavior_modes [^]
(0010963)
MarvinPA (developer)
2011-02-06 14:46

Snapping turtles don't behave like this anymore now that they have shells - I'll probably close this, unless it's thought to still be an issue for monsters with weapons of reaching?
(0017916)
paplaukes (reporter)
2012-04-29 17:18

I hope it's okay to post here since it's still open.

The bug happened to me, on Webtiles - a feared orc warrior used a polearm to attack my character instead of fleeing. Morgue (naturally :)) file here:
http://crawl.develz.org/morgues/0.10/paplaukes/morgue-paplaukes-20120429-145554.txt [^]

This probably happens more often now that all polearms have reaching.
(0025607)
gammafunk (administrator)
2014-03-14 22:52

I can't reproduce in 0.14-a0-3294-g830ee6c. Monster fleeing was reformed a bit in 0.14 and quite possibly also in versions between now and 0.10. Marking this as resolved, but feel free to reopen if you can trigger it under specific circumstances in 0.14-a

- Issue History
Date Modified Username Field Change
2010-05-03 06:51 MrMisterMonkey New Issue
2010-05-03 18:45 MrMisterMonkey Note Added: 0004594
2010-05-03 19:56 ogaz Note Added: 0004595
2010-05-03 19:57 ogaz Note Edited: 0004595
2010-05-03 20:12 MrMisterMonkey Note Added: 0004596
2010-05-03 23:42 OG17 Note Added: 0004608
2010-05-04 12:53 Kyrris Note Added: 0004620
2010-05-04 13:29 OG17 Note Added: 0004621
2010-05-04 13:30 OG17 Note Edited: 0004621
2010-05-05 11:22 Core Xii Note Added: 0004644
2010-05-05 17:28 Cryptic Note Added: 0004649
2010-05-13 17:40 MrMisterMonkey Note Added: 0004765
2011-02-06 14:46 MarvinPA Note Added: 0010963
2012-04-29 17:18 paplaukes Note Added: 0017916
2014-03-14 22:52 gammafunk Note Added: 0025607
2014-03-14 22:52 gammafunk Status new => resolved
2014-03-14 22:52 gammafunk Fixed in Branch => 0.14 development branch
2014-03-14 22:52 gammafunk Resolution open => done
2014-03-14 22:52 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker